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Preface 
 

Information and Communication Technology (ICT) continues to transform how 
people live, work, learn, and interact across every sector—from education, 
agriculture, health, finance, to governance. The ability to use ICT tools such as 
computers, smartphones, printers, projectors, and online platforms is no longer 
optional—it is a vital skill required to thrive in the 21st-century knowledge economy. 

This Learner’s Textbook has been carefully developed in alignment with the NCDC 
Competency-Based Curriculum for Subsidiary ICT at A’ Level – (The Aligned A’Level 
Curriculum 2025). It is designed to equip you with practical knowledge and digital 
skills that support lifelong learning, academic success, employability, and digital 
innovation. 

The book covers the Six topics of Senior Five; Introduction to ICTs, Electronic Word 
Processing, Electronic Presentation, Computer Hardware and Software, Electronic 
Spreadsheets. These topics have been structured to include, Clear learning 
outcomes aligned to CBC expectations, Practical hands-on activities, Group-based 
and individual tasks, Real-life examples from school and community settings, Guided 
exercises, peer reviews, and collaborative digital projects. 

Each section encourages you to think critically, apply ICT tools creatively, and develop 
the confidence to use technology in solving problems both in your academic and 
everyday life. 

The language used throughout the book is simple, direct, and learner-friendly, with 
illustrations, tables, and charts carefully designed to enhance visual learning and 
practical interpretation. You are encouraged to explore each activity actively—as an 
individual, in pairs, or in groups—depending on the nature of the task. 

As you progress through this book, you are reminded to; Be a responsible digital 
citizen, Use ICT tools ethically and mindfully, Handle books, devices, and learning 
materials with care, Stay aware of your health and safety while using technology, and 
Practice environmental consciousness in the digital age. 

It is my hope that this textbook will empower you not only to pass your exams, but 
also to become a productive contributor to the digital world, equipped with skills to 
adapt, innovate, and lead in your community and beyond. 

     Welcome to the journey of Mastering ICT at A-Level. Let’s get started!      
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Senior Five Term One 
 

 

 
 

TOPIC INTRODUCTION TO ICTs 

Key Words 

ICT  

Digital Literacy 

Booting Process 

Troubleshooting 

File Organization 

Storage Devices 

File Formats 

The Content of this topic and the activities 

will enable you to; 

a) Explore the utilization of various ICT 

tools in day to-day life. 

b) Use digital tools to solve day to-day life 

challenges. 

c) Create directories and use them to 

manage electronic files. 
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Introduction 
 

Imagine a Uganda without mobile money, digital banking, e-

learning, government e-services, or mobile communication. 

Businesses would rely solely on paperwork, students would 

struggle to access learning materials, and hospitals would 

manage patient records using manual files. How efficient would 

communication, education, and financial transactions be? 

ICT (Information and Communication Technology) has transformed modern life, 

making communication faster, business transactions more efficient, and learning 

more accessible. This chapter introduces the meaning of ICT, its application across 

different sectors, how digital tools solve everyday challenges, and effective file 

management strategies to help you become a competent ICT user. 

 

Why is ICT Important?  

 
ICT (Information and Communication Technology) refers to a collection of related 

technological tools used to create, store, manage and disseminate information.  

 

1.1 Explore the Utilization of Various ICT Tools in Day-to-Day Life 

 
Figure 1: Various ICT Tools in Day-to-Day Life 
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ICT (Information and Communication Technology) has transformed various sectors 

by making work easier, improving efficiency, and enabling faster communication. 

From mobile banking in business to e-learning in education, ICT tools help 

individuals and organizations perform daily tasks with greater accuracy and speed. 

The "World Of ICTs" encompasses all technologies used for information and 

communication, including devices, networks, applications, and services, which are 

crucial for modern computing, communication, and various aspects of daily life. 

 
1.1.1 Identifying and Discussing ICT Tools in Different Fields 
 
ICT tools include hardware, software, and networks that assist in storing, 

processing, and communicating information. These tools are used in education, 

business, health, security, entertainment, and agriculture to enhance efficiency. 

      Example: A Physics teacher in a school uses a projector and Multimedia 

PowerPoint slides to teach lessons. This enhances student understanding and 

makes learning more interactive. 

 
Table 1: Examples of ICT Tools in Ugandan Sectors 

Sector ICT Tools Used Application 

in Uganda Hardware ICT 

Tools 

Software ICT 

Tools 

Network ICT 

Tools 

Education Smartboards, 

Computers, 

Tablets 

E-learning 

platforms (Kolibri, 

U-Learn), Zoom, 

Google Meet, 

Microsoft Teams, 

Moodle, Google 

Classroom, Digital 

Libraries 

(eGranary, Uganda 

Online Library) 

Wi-Fi 

Networks, 

Educational 

LANs (School 

Networks), 

Fiber Internet 

Used in 

schools, 

universities, 

and training 

centers for 

digital 

learning and 

research. 

Business  

&  

Finance 

POS (Point of 

Sale) machines, 

ATMs, Cash 

Deposit 

Banking Software 

(FlexCube, 

Finacle, Temenos), 

Accounting 

Banking 

Networks, 

Mobile 

Banking 

Used in 

banks, 

microfinance 

institutions, 

WORLD OF ICTS 
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Machines, 

Cheque 

Scanners 

software 

(QuickBooks, 

Tally, Xero), E-

Payment Systems 

(Pesapal, 

Flutterwave, 

PayWay) 

Networks 

(MTN MoMo, 

Airtel Money) 

SACCOs, and 

retail 

businesses for 

transactions. 

Health  

&  

Medicine 

Medical 

Wearables, 

Digital 

Thermometers, 

X-ray & MRI 

Machines, 

Blood Pressure 

Monitors 

Electronic Health 

Records (EHRs), 

AI Diagnosis 

Systems, 

Telemedicine Apps 

(Rocket Health 

Uganda, Babylon 

Health) 

Hospital 

Intranet 

Networks, 

Remote 

Patient 

Monitoring 

Networks, 

Health Data 

Servers 

Used in 

hospitals and 

clinics for 

patient 

management, 

diagnosis, and 

telemedicine. 

Security Surveillance 

cameras 

(CCTV), 

Biometric 

scanners 

(Fingerprint, 

Facial 

Recognition), 

Metal Detectors 

Cybersecurity 

software 

(Firewalls, 

Antivirus, 

Encryption tools), 

Crime Data 

Analysis Software 

Security 

Control 

Networks, 

VPNs for Data 

Protection, 

Forensic Data 

Networks 

Used by 

government 

agencies, 

police, and 

private 

security firms 

for 

monitoring 

and threat 

detection. 

Agriculture Smart Irrigation 

Systems, 

Drones for 

Crop 

Monitoring, 

Soil Sensors, 

Weather 

Monitoring 

Devices 

Market Price 

Monitoring Apps 

(M-Omulimisa, 

AgroMarketDay), 

Mobile Advisory 

Apps (Farmerline, 

WeFarm) 

Rural Internet 

Networks, IoT 

Networks for 

Smart 

Farming, 

Satellite Data 

for Weather 

Forecasting 

Used in 

commercial 

farming and 

agricultural 

research to 

improve 

productivity. 

Entertainment Smart TVs, 

Cameras 

(DSLR, 4K 

Video 

Cameras), 

Microphones & 

Streaming 

platforms 

(YouTube, Netflix, 

Showmax), Music 

Production 

Software 

High-Speed 

Fiber Internet, 

Content 

Delivery 

Networks 

(CDN), Live 

Used by 

content 

creators, 

musicians, 

journalists, 

and 
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Audio Mixers, 

Gaming 

Consoles 

(PlayStation, 

Xbox, VR 

Headsets) 

(Audacity, FL 

Studio), Video 

Editing Software 

(Adobe Premiere, 

Final Cut Pro) 

Streaming 

Servers 

filmmakers 

for 

production 

and 

distribution. 

Communication Mobile Phones, 

Teleconference 

Equipment, 

VoIP Handsets 

Instant Messaging 

Apps (WhatsApp, 

Telegram, Signal), 

Email Services 

(Gmail, Outlook, 

Yahoo Mail), VoIP 

Software (Skype, 

Zoom, Google 

Duo) 

Cellular 

Networks 

(MTN, Airtel, 

LycaMobile), 

Wi-Fi 

Networks, 5G 

& Fiber Optic 

Networks 

Used in 

corporate, 

government, 

and personal 

communicatio

n. 

Transport  

&  

Logistics 

GPS Tracking 

Devices, Fleet 

Management 

Hardware, 

Vehicle On-

Board 

Diagnostics 

(OBD) 

Scanners 

Ride-Hailing Apps 

(SafeBoda, Uber, 

Bolt), Logistics 

Software (DHL 

SmartShip, Fleet 

Management 

Systems) 

Vehicle-to-

Network 

(V2N) 

Communicatio

n, Traffic 

Monitoring 

Systems, IoT-

based Smart 

Road 

Networks 

Used by 

logistics 

companies, 

transport 

authorities, 

and ride-

hailing 

businesses. 

Construction  

&  

Engineering 

Drones for Site 

Inspections, 3D 

Printers, 

Surveying 

Equipment, 

Cement Mixers 

with Digital 

Controls 

AutoCAD, 

Building 

Information 

Modeling (BIM) 

Software, 

Structural Analysis 

Software 

Cloud 

Networks for 

Architectural 

Collaboration, 

IoT Networks 

in Smart 

Buildings 

Used by 

engineers, 

architects, 

and real estate 

developers 

for planning 

and 

execution. 

Retail  

& 

E-commerce 

Barcode 

Scanners, Self-

Checkout 

Machines, 

RFID Tags & 

Readers 

E-commerce 

Websites (Jumia, 

Kilimall, Shopify, 

WooCommerce), 

Inventory 

Management 

Software 

Payment 

Processing 

Networks, QR 

Code Payment 

Systems, 

Retail Data 

Analytics 

Networks 

Used in 

supermarkets, 

malls, and 

online stores 

for managing 

sales and 

inventory. 
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          Practical Task – Class Brainstorming Discussion 
 

Task: In groups, identify ICT tools commonly used in: 

• Your school 

• Your local health center 

• A nearby business 

• A government office 

Discuss: 

• What are these tools? 

• What do they help people do? 

• How do they make tasks easier or faster? 

          Record your findings and present to the class. 

 

 

Figure 2: A mobile money agent processing transaction 
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          Activity1.1.1: Identifying ICT Tools in Your Community 

1. Visit or interview someone in your community (teacher, nurse, business owner). 

2. Ask them which ICT tools they use every day.  

3. Write a short report explaining:  

o The ICT tools identified 

o Their purpose 

o The benefits and challenges experienced 

 
1.1.2 Role-playing the Use of ICT Tools in Different Sectors 
 

One of the best ways to understand how ICT tools are used in real life is to act out 

situations where people apply them in different workplaces. This method is called 

role-playing — it helps you visualize how ICT is used in sectors like health, 

education, business, agriculture, and government. 

Examples of Real-Life Role-Playing Scenarios 

Sector Role-Play Scenario ICT Tools Used 

Education A teacher delivering a digital lesson 

using a projector and PowerPoint 

Projector, Laptop, PowerPoint, 

E-learning platforms 

Health A nurse registering patients and 

checking records in a hospital 

Computer, Patient database, 

Barcode scanner 

Business A cashier selling products and issuing 

receipts using a POS system 

POS machine, Receipt printer, 

Inventory software 

Agriculture A farmer checking weather updates 

before planting crops 

Mobile phone, Weather 

forecast app, SMS alert system 

Government A civil servant helping a citizen apply 

for an online birth certificate 

e-Government portal, 

Computer, Internet browser 

      Example: In a classroom role-play, one student acts as a shopkeeper, another 

as a customer, and another as a cashier operating a POS system to demonstrate 

how digital tools speed up business processes. 
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          Activity 1.1.2: Role-Playing ICT Use in Real Life 
 
1. Form small groups, and each group will select a sector (Education, Health, 

Business, Agriculture, or Government). 

2. Design a role-play skit where group members take roles (e.g., teacher, 

patient, customer, business manager). 

3. Demonstrate how ICT tools are used in that scenario to perform tasks. 

4. Perform your role-play in front of the class. 

5. After the performance, explain:  

o The ICT tools used 

o Their purpose in the sector 

o Benefits and challenges in using them 

 

Figure 3: A student acting as professional using ICT tools 

 
     Guidelines for Role-Playing 

  Use real or improvised ICT tools (e.g., printed icons, mock laptops) 

  Keep your role-play short but realistic (3–5 minutes) 

  Focus on explaining what the ICT tools do, not just acting 

  Reflect on how ICT makes tasks easier 

 

   Reflection Questions 

• Which sector did you find most interesting during role-play? 

• How do you think ICT has changed that sector in your community? 

• What did you learn about teamwork from this Activity? 
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1.1.3 Exploring ICT Usage in a School System 
 

A school is one of the most important places where ICT is used every day — not 

just for teaching and learning, but also for administration, communication, and 

record keeping. 

      Example: Some schools in Uganda use digital attendance systems and SMS 

alerts to keep parents informed about student attendance and performance. 

  
Table 2:Ways ICT is Used in Schools 

School Area ICT Application Example of Use 

Teaching & 

Learning 

Smartboards, E-learning 

platforms, Virtual Labs 

Teachers use Kolibri, U-Learn, 

and Moodle to conduct digital 

lessons. 

Classroom 

Engagement 

Zoom, Google Meet, 

Interactive Whiteboards 

Used for virtual lessons and 

remote learning support. 

Administration Student Databases, Biometric 

Attendance Systems, School 

Management Software 

Schools use digital student 

records and attendance 

tracking systems to manage 

learners. 

Library Services Digital Libraries, E-books, 

Online Research Tools 

Students access digital books 

and journals using online 

libraries and research 

platforms. 

Security CCTV Cameras, Digital ID 

Cards, Visitor Management 

Systems 

Schools use CCTV surveillance 

and biometric ID systems for 

security. 

National Exam & 

Student Data 

Management 

UNEB Portal, Student 

Registration Systems, EMIS 

(Education Management 

Information System) 

Used to upload student data 

for registration, access national 

results, and manage continuous 

assessment scores. 
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Benefits of ICT in a School System 

  Makes teaching more interactive and enjoyable 

  Simplifies storage and retrieval of student information 

  Supports distance learning and self-paced revision 

  Enhances communication between teachers, learners, and parents 

  Improves efficiency in administrative tasks 

 
Figure 4:Students using computers in a school ICT lab 

 
          Activity 1.1.3: Investigating ICT Use in Your School 

 

1. Walk around your school (in pairs or groups) and identify places where ICT 

is used. 

2. Observe or interview users of ICT tools (e.g., teacher using a projector, 

librarian using a computer). 

3. Write a short report or create a table showing:  

o Where ICT is used 

o What tools are used 

o What tasks they help accomplish 
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ICT literacy is the ability to effectively use digital technologies, communication 

tools, and networks to access, manage, integrate, evaluate, create, and 

communicate information, enabling individuals to function in an information 

society. 
 

1.2 Use Digital Tools to Solve Day-to-Day Life Challenges 

Digital tools are part of your everyday life — whether you're using a mobile phone 

to send money, a computer to write a report, or a search engine to find information 

online. These tools help you solve real-life problems faster, more accurately, and 

more efficiently.  

Key Questions to Think About 
 

• What digital tools do you use every day? 

• What problems do they help you solve? 

• How do you make sure those tools are working correctly? 

 

Figure 5: Parts of a computer System/laptop 

      Example: A student uses a laptop to type a school report, research on the 

internet, and send it via email to the teacher. All these actions involve multiple 

digital tools — a computer system, word processor, browser, and email platform 

working together to solve an everyday academic challenge. 

ICT LITERACY 
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          Activity: Discussion on Digital Tools You Use in Daily Life 
 

1. In pairs, list all the digital tools or software you use at school or at home. 

2. Discuss:  

o What tasks you use them for 

o What problems they help you solve 

o What challenges you face when using them 

3. Share your list with the class. 

 
1.2.1 Exploring How ICT Components Form a Working System 

Every digital tool you use — whether it's a computer, smartphone, or ATM machine 

— is made up of several ICT components that must work together as a system. 

Each part performs a specific role to make sure data is entered, processed, stored, 

and shared correctly. 

What is an ICT System? 
 

An ICT system is a collection of interconnected components that work together 

to: 

1. Input data (e.g., typing using a keyboard), 

2. Process data (e.g., calculations by the CPU), 

3. Store data (e.g., saving files on a hard disk), 

4. Output results (e.g., displaying on a monitor), and 

5. Communicate information (e.g., sending via email or Wi-Fi). 
 

Components That Form a Working ICT System 
 

Component Type Examples Function in the System 

Input Devices Keyboard, Mouse, 

Scanner, Webcam 

Allow you to enter data 

Processing Unit Central Processing Unit 

(CPU) 

Carries out instructions and 

calculations 

Storage Devices Hard Drive, SSD, USB 

Flash Disk 

Save and retrieve data 

Output Devices Monitor, Printer, Speaker Display or produce processed data 

Communication Devices Network Interface Card, 

Router, Modem 

Transmit data between systems 

Software (System + 

Application) 

Operating System, Word 

Processor, Browser 

Manage the system and help 

perform specific tasks 
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          Activity 1.2.1: Demonstrating a Working ICT System 

1. In groups, collect ICT components available in your school (keyboard, CPU, 

mouse, monitor, printer, etc.). 

2. Connect the power cables, monitor, keyboard, and mouse properly, 

Assemble them into a working system. 

3. Turn on the system and check if it functions correctly. 

4. Label each component and explain its role. 

5. Discuss what happens if one component fails (e.g., no monitor = no visual 

output). 

 

   Reflection Questions 

• Which part of an ICT system do you interact with most often? 

• Why is software important even when all hardware components are 

connected? 

• What would happen if the processing unit was missing? 

 

1.2.2 Understanding the Booting Process 
 

Before you can use a computer or any digital device, it must first go through a 

process called booting. This is the starting process that loads the operating system 

(OS) and prepares the computer to work. 

What is Booting? 
 

Booting is the process of starting a computer and loading the operating system so 

you can begin using it. When you press the power button, several steps take place 

to check that everything is working and to prepare the computer for use. 

Types of Booting 

Type of 

Booting 

Description When It Happens 

Cold Booting Starting the computer from a 

completely off state 

When you power on a computer 

for the first time 

Warm Booting Restarting a computer that is 

already on 

When you click "Restart" or press 

Ctrl + Alt + Del 
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Step-by-Step: Booting Process Explained 
 

1. Power Supply Starts  

o Power is sent to all components. 

2. POST (Power-On Self-Test)  

o Computer checks if RAM, keyboard, monitor, and other parts are 

working. 

3. BIOS/UEFI Loads  

o Basic software in the motherboard starts first before the operating 

system. 

4. Boot Loader Searches for OS  

o BIOS/UEFI checks storage drives to find the operating system. 

5. Operating System Loads  

o The OS (e.g., Windows, Linux) starts and displays the desktop. 

6. User Login Interface Appears  

o You can now log in and start using the computer. 

 

      Example: When you press the power button on a school desktop computer, 

you may see a company logo or “Press F2 to enter setup”. This is part of the BIOS 

loading stage before the Windows login screen appears. 

 

WATCH THIS VIDEO AND UNDERSTAND MORE ON THE BOOTING PROCESS 

SCAN THIS QR CODE TYPE THIS LINK 🔗 IN THE BROWSER 

 

https://youtu.be/PSnGuvylWBI 

 

 

 

 

 

 

https://youtu.be/PSnGuvylWBI
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          Activity 1.2.2: Observing the Booting Process 
 
1. In pairs, observe and describe the booting process of a desktop or laptop in 

your school lab. 

2. Identify each stage (Power, POST, BIOS, OS loading, Login screen). 

3. Record how long each stage takes and discuss any messages or beeps you 

see or hear. 

 

Figure 6:Steps illustrating the booting process 

   Reflection Questions 

 
• What happens if one stage of booting fails (e.g., POST fails)? 

• Why is the BIOS important during booting? 

• What signs tell you that a computer has completed booting successfully? 
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1.2.3 Presenting the Booting Process Using Multimedia 
 
You can improve your understanding of the booting process by using multimedia 

tools to explain and present what happens when a computer starts up. Multimedia 

helps you to visualize steps, communicate clearly, and engage your audience more 

effectively. 

Why Use Multimedia for Presentations? 
 

  Makes learning more visual and interactive 

  Helps others understand complex concepts easily 

  Builds your digital communication and ICT skills 

  Allows you to combine text, images, sounds, and videos 

      Example: A student creates a PowerPoint presentation with images and 

animation to show the sequence of the booting process in a classroom discussion. 

 
Creating a Multimedia Presentation on Booting 
 
➤ Using Microsoft PowerPoint or Google Slides: 

1. Open your presentation software (PowerPoint or Google Slides). 

2. Create a Title Slide – e.g., “Understanding the Booting Process”. 

3. Add slides for each stage of the booting process: 

o Slide 1: Power supply activation 

o Slide 2: POST 

o Slide 3: BIOS/UEFI loading 

o Slide 4: Boot Loader and OS loading 

o Slide 5: Login screen 

4. Insert Images/Icons for each stage: 

o Use downloaded icons like power button, BIOS chip, operating 

system logo, etc. 

5. Add Animations: 

o Animate each stage to appear one by one as you explain. 

6. Add Speaker Notes or Voice Narration (optional): 

o Prepare short explanations for each stage in your notes section. 

7. Save or export your presentation as a PDF or video file for sharing. 
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          Activity 1.2.3: Creating a Multimedia Booting Process Presentation 
 
1. In groups, create a multimedia presentation showing the booting stages 

using PowerPoint or Google Slides. 

2. Each group member takes responsibility for one slide or one stage of the 

process.  

3. Include images, short texts, and animations to enhance your explanation. 

4. Present your work to the class in 5–10 minutes, explaining each stage 

clearly. 

 
Extension Task: Using Video or Audio to Present the Booting Process 

1. Record a short video or voice explanation describing the booting process. 

2. Use screen recording tools like:  

o Gilisoft Screen Recorder 

o OBS Studio 

3. Combine your audio or video with slides or real computer footage. 

 
      This helps you practice digital storytelling using multiple media formats. 

 
   Reflection Questions 

• How did multimedia help you explain the booting process better? 

• What challenges did you face while designing your presentation? 

• What other topics can be explained using multimedia tools? 

 
1.2.4 Starting and Shutting Down ICT Devices Under Different Scenarios 
 

Knowing how to properly start and shut down ICT devices like computers, laptops, 

printers, or projectors is an important skill. Doing it correctly protects your data, 

prevents system damage, and ensures your devices last longer. 

Why Proper Start-Up and Shutdown Are Important 
 

  Prevents loss of unsaved data 

  Protects hardware and software from damage 
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  Allows updates and processes to complete 

  Saves power and reduces wear on components 

      Example: A teacher shuts down the projector and laptop correctly after a 

lesson to avoid overheating and extend battery life. 

 
Step-by-Step: How to Start a Computer Properly 

1. Check power source – Ensure the socket and power cable are working. 

2. Press the power button on the system unit or laptop. 

3. Wait for booting to complete (see login screen). 

4. Log in with your user account (if required). 

5. Wait for background processes to load before opening applications. 

Step-by-Step: How to Shut Down a Computer Properly (Normal Conditions) 
 

1. Save your work and close all open applications. 

2. Click Start Menu → Power Icon → Shut Down (in Windows). 

3. Wait for the screen to go off completely before switching off power from 

the wall socket. 

4. Disconnect cables safely if needed. 
 

     Tip: Avoid turning off a computer using the power button directly, unless in 

emergencies. 
 

Starting and Shutting Down Under Different Scenarios 

 

Scenario Start-Up Tips Shutdown Procedure 

Normal Use Follow standard booting 

steps 

Use Start Menu → Shut Down 

During Power Outage 

(if using UPS) 

Start the system once power 

stabilizes 

Save your work quickly and 

shut down using the OS 

Emergency Shutdown Use Ctrl + Alt + Del → 

Restart or power button 

only if system freezes 

Hold the power button only if 

the system is unresponsive 

After System 

Error/Crash 

Let system reboot and 

check for errors 

Use safe shutdown 

procedures and scan for 

issues afterward 

Networked Computer 

Lab 

Ensure network connection 

is active during start-up 

Log off or shut down without 

interrupting shared services 
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          Activity 1.2.4: Practicing Start-Up and Shutdown Scenarios 
 
1. In groups, simulate starting and shutting down a desktop or laptop under 

different scenarios:  

o Normal use 

o After a power outage 

o In an emergency 

2. Record:  

o What steps you followed 

o What challenges you encountered 

o What you learned from each scenario 

 
Extension Task: ICT Device Start-Up/Shutdown Manual 
 
1. Create a short guidebook/manual titled “How to Start and Shut Down ICT 

Devices Safely”. 

2. Include illustrations, icons, and tips for:  

o Computers 

o Projectors 

o Printers 

o Scanners 

      Share this manual with your school lab or class noticeboard for others to 

learn. 

 

   Reflection Questions 

• What happens if you shut down a device without saving your work? 

• Why is emergency shutdown risky if done frequently? 

• How does proper shutdown extend the life of ICT equipment? 
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Figure 7: A UPS protecting a computer from sudden shutdowns 

 
     Why Is the Shut Down Option Used When Turning Off a Computer System? 

 
The Shut Down option allows the operating system to safely close all running 

applications, save necessary data, and turn off the hardware properly. Shutting 

down the computer correctly: 

 

Figure 8:Why Is the Shut Down Option Used When Turning Off a Computer System 
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     Best Practice: Always first Save your work, click "Start" → "Shut Down" to 

properly power off a computer instead of directly unplugging or using the power 

button. 

 
     How Does the Restart Option of the Shut Down Menu Function? 

 
The Restart option closes all running programs and reboots the computer 

automatically without turning it off completely. It is commonly used to: 

  Apply software updates and system changes – Many installations 

require a restart to take effect. 

  Fix minor system errors – Clears temporary memory and reloads system 

processes. 

  Recover from system slowdowns – Refreshes system operations without 

losing saved data. 

  Reconnect devices – Helps in recognizing new hardware or 

reconfiguring network settings. 

 

 

     Best Practice: Use Restart when updating software, troubleshooting software 

issues, or refreshing the system. 

 

Figure 9:Restart Option of the Shut Down Menu 
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     Advantages of Switching the Computer into Sleep Mode 

 
The Sleep Mode function temporarily pauses all system activities while keeping 

them in memory, allowing the user to resume work quickly without shutting down 

completely. 

 Saves power – Uses minimal electricity while keeping work intact. 

 Faster resume time – Boots up instantly without restarting all programs. 

 Maintains open files and applications – No need to reload documents and 
software. 

 Ideal for short breaks – Useful when stepping away from the computer for a 
short period. 

 
     Best Practice: Use Sleep Mode if you plan to return to work soon but want to 

save power without closing everything. 

 

              Activity  : Finding 

Out the difference Between 

Hibernate, Sleep Mode and 

Standby 

1. In groups carryout a 

Library or internet 

research about the 

three above 

2. Present the findings to 

the entire class. 

 

 
1.2.5 Troubleshooting Startup and Shutdown Issues 
 

Sometimes, your ICT devices may fail to start or shut down properly. These 

problems can be caused by hardware faults, software errors, or incorrect handling. 

Knowing how to identify and solve such issues helps you maintain device 

performance and prevent damage. 
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Common Startup Issues and Solutions 
 

Issue Possible Cause Solution 

Computer does not 

power on 

Power cable not connected 

properly, faulty power 

supply, dead battery (for 

laptops) 

Check if the power cable is 

securely plugged in, replace the 

power supply if needed, or 

charge the laptop. 

No display on 

monitor 

Loose cable connections, 

faulty graphics card, or 

damaged monitor 

Ensure the monitor cable is 

properly connected, try a 

different monitor or check the 

graphics card. 

Computer gets stuck 

on boot screen (fails 

to load the OS) 

Corrupt operating system 

files, faulty hard drive, or 

incorrect BIOS settings 

Try booting into Safe Mode, 

repairing the OS, or checking for 

hard drive issues. 

Continuous beeping 

sound on startup 

Faulty RAM, loose 

components inside the 

system unit 

Open the system unit, reseat the 

RAM, or replace faulty 

hardware. 

Operating System 

not found 

Hard drive not detected, 

corrupt boot files, wrong 

boot sequence in BIOS 

Check if the hard drive is 

properly connected, set the 

correct boot device in BIOS, or 

reinstall the OS. 

Computer restarts 

repeatedly (Boot 

Loop) 

Software updates failure, 

hardware malfunction, or 

overheating 

Try system recovery, check for 

faulty RAM or overheating, and 

reset the BIOS if necessary. 

Keyboard or Mouse 

not detected 

Loose or faulty connection, 

driver issues 

Ensure peripherals are properly 

plugged in, update or reinstall 

drivers. 

 

Step-by-Step: Troubleshooting Startup Problems 
 

1. Check power source and connections – Confirm the device is plugged in and 

power is flowing. 

2. Observe screen and LED indicators – Do lights come on? Is there any display? 

3. Listen for unusual sounds – Beeping or fan noise can indicate hardware errors. 

4. Try Safe Mode or BIOS settings – If booting fails, restart in Safe Mode or check 

settings in BIOS. 

5. Use another monitor or cable – To rule out display problems. 
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Common Shutdown Issues and Solutions 
 

Issue Possible Cause Solution 

Computer does 

not shut down 

Background processes 

preventing shutdown, OS 

errors 

Close all running applications, use 

Task Manager to end unresponsive 

programs, or restart and attempt 

shutdown again. 

Shutdown is very 

slow 

Too many startup 

programs, pending 

updates 

Disable unnecessary startup 

programs, install pending updates, 

and run system cleanup. 

Computer 

restarts instead of 

shutting down 

Power settings 

misconfiguration, faulty 

OS updates 

Adjust power settings in BIOS and 

update drivers and OS patches. 

Error messages 

during shutdown 

Corrupt system files, 

software conflicts 

Run System File Checker (sfc 

/scannow) to fix corrupt files. 

Blue screen 

(BSOD) before 

shutdown 

Driver conflicts, hardware 

failure 

Update or reinstall drivers, check for 

hardware issues, and ensure proper 

ventilation. 

 

 Step-by-Step: Troubleshooting Shutdown Problems 

 
1. Close all running applications manually before clicking Shutdown. 

2. Wait for pending updates to finish. 

3. Open Task Manager (Ctrl + Shift + Esc) to check background apps. 

4. Scan for viruses or malware that may be interfering with shutdown. 

5. Check system settings – In some cases, improper system configuration 

delays shutdown. 
 

      Example: A computer lab assistant in a secondary school notices that the 

computers are shutting down slowly. After investigation, it is discovered that too 

many programs are running in the background. Closing these before shutdown 

speeds up the process. 
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Figure 10:A screenshot of a BIOS settings page 

 
          Activity 1.2.5: Hands-on Troubleshooting 

 
1. Work in pairs and simulate or observe startup/shutdown problems on a 

device. 

2. Record the symptoms, identify the likely cause, and apply one or more 

troubleshooting steps. 

3. Write a short Troubleshooting Log Sheet capturing:  

o The problem 

o What was done 

o Whether the problem was solved 

 

Extension Task: Troubleshooting Flowchart 

1. Design a flowchart that shows how to respond to common 

startup/shutdown issues.  

o Example path: Computer not powering on → Check power → 

Replace cable → Still no power → Call technician. 

2. Present your flowchart to the class. 
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Troubleshooting Tools, You Can Use 
 

Tool Purpose 

Task Manager View and close running apps 

Disk Cleanup Remove unnecessary files slowing down the system 

Antivirus Software Scan and remove harmful files 

BIOS/UEFI Settings Check hardware status 

Event Viewer View detailed error messages in Windows 

 

   Reflection Questions 
 

• Have you ever encountered a startup or shutdown problem before? 

• What troubleshooting step would you try first in such a situation? 

• When should you escalate the issue to a technician? 

 
1.2.6 Documenting Best Practices for Troubleshooting 
 
When you troubleshoot ICT devices, it is important not only to solve the problem 

but also to keep a record of the steps taken, tools used, and lessons learned. This 

is called documenting best practices. It helps you and others to improve future 

troubleshooting and avoid repeating mistakes. 

      Example: A student in the ICT club documents how they fixed a printing 

problem by checking printer connections and re-installing drivers. Their notes help 

another student solve the same problem later. 

Why Document Troubleshooting Practices? 
 

  Helps you keep track of problems and solutions 

  Makes it easier to fix similar problems in the future 

  Guides others who may face the same issue 

  Promotes professionalism and responsibility in ICT usage 

  Encourages teamwork and learning from experience 
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What Should Be Included in a Troubleshooting Record? 

 

Element Details to Include 

Problem Identified Describe what went wrong (e.g., “Computer not booting”) 

Symptoms Observed What did you see or hear? (e.g., “No display on screen”) 

Cause of Problem What you found to be the issue (e.g., “Loose cable”) 

Solution Applied Steps taken to fix it (e.g., “Reconnected monitor cable”) 

Tools Used Hardware or software tools (e.g., Task Manager, Antivirus) 

Results Was the problem fixed? How did you confirm? 

Recommendations What to do if the problem happens again 

 
Sample Troubleshooting Log Sheet 
 

Date Problem Symptoms Cause Solution Result Recommendation 

26/04/2025 PC won’t 

power on 

No lights or 

sound 

Power cable 

disconnected 

Reconnected 

cable 

Working Check power 

connections before 

calling help 

 
           Activity 1.2.6: Creating a Troubleshooting Log Book 
 
1. In your group, create a Troubleshooting Log Book or digital template using 

Word or Excel. 

2. Record real or simulated ICT problems you encountered in class or at home. 

3. Fill in each part: problem → symptoms → cause → solution → results. 

4. Keep updating your log every time you solve a new ICT problem. 

 
Extension Task: Sharing and Comparing Troubleshooting Practices 
 
1. In groups, exchange your troubleshooting logs. 

2. Compare:  

o How similar or different your problems were 

o What troubleshooting steps were most effective 

3. Share best practices and create a class summary of top troubleshooting tips. 
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Best Practice Guidelines Summary 

  Always check physical connections first 

  Observe error messages and note them down 

  Use the right tools (e.g., antivirus, disk cleanup) 

  Don’t rush—follow a logical step-by-step method 

  Keep records in a simple and clear format 

  Share solutions with others to build teamwork 

 
   Reflection Questions 

• What is the value of keeping a troubleshooting record? 

• Which troubleshooting method worked best in your experience? 

• How can your logbook help other ICT users in your school? 

 
1.2.7 Understanding the Significance of Proper Start-Up and Shutdown 
 
Starting and shutting down ICT devices properly is not just a routine — it is a critical 

practice that ensures the health, safety, and long-term performance of your 

devices. Many ICT problems occur because people ignore the correct start-up or 

shutdown procedures. 

      Example: A student switches off a desktop directly from the socket without 

shutting down through the system, and later the computer fails to boot. This 

happened because system files were corrupted during abrupt shutdown. 

Why Is Proper Start-Up and Shutdown Important? 
 

Reason Explanation 

Prevents Data Loss Improper shutdown can cause unsaved work to be lost 

Avoids System Errors Sudden power-off can damage system files 

Protects Hardware Prevents power surges and overheating 

Improves System 

Performance 

Allows updates and system settings to be applied 

correctly 

Saves Energy Prevents unnecessary power consumption 

Extends Device Lifespan Reduces wear and tear on hardware components 
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Risks of Improper Start-Up and Shutdown 

  Data corruption or loss 

  Slow performance on next use 

  Frequent system crashes or errors 

  Software updates failing to install 

  Shortened battery or hardware life (especially on laptops) 
 

          Activity 1.2.7: Exploring the Impact of Improper Shutdown 

1. In groups, simulate two scenarios: 

o Proper shutdown (using system menu) 

o Improper shutdown (using power button or switch off from socket) 

2. Observe the differences during the next start-up: 

o Was the system faster or slower? 

o Were there error messages? 

o Did any files get lost? 

3. Document your observations and discuss with the class. 
 

Extension Task: Creating a “Device Usage Code of Conduct” 

1. In pairs, draft a “Safe ICT Use Poster” that outlines rules for proper:  

o Start-up and shutdown 

o Charging and power management 

o General care of ICT devices 

2. Display your poster in the classroom or ICT lab. 
 

Best Practices Summary Checklist 

✔ Practice 

☐ Always save your work before shutting down 

☐ Use the system’s “Shut Down” or “Restart” options 

☐ Wait for updates to finish before switching off 

☐ Do not force shutdown unless necessary 

☐ Turn off power supply only after full shutdown is complete 

 
   Reflection Questions 

• What could happen if you always shut down your computer improperly? 

• Why is it important to wait for the booting process to complete before using 

a device? 

• What role do you play in protecting the ICT devices at your school? 
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As you continue using ICT tools, you will create more documents, presentations, 

images, and data files. Without proper organization, it becomes difficult to locate, 

share, or manage your work. Learning how to create and manage files and folders 

effectively helps you become an efficient digital user. 
 

1.3 Create and Organize Electronic Files and Folders for Efficient Data Management 

Computer file management involves organizing, storing, and controlling digital 

files to ensure efficient access, retrieval, and maintenance, enabling users to create, 

edit, delete, and locate data seamlessly. 

      Example: A student who organizes schoolwork into folders like Assignments, Notes, 

and Projects can easily access documents during revision or presentations. 

 
1.3.1 Organizing Files into Folders and Subfolders 
 

As you create more digital content — such as documents, presentations, images, 

or data files — it is important to keep them organized in a structured way. You do 

this by creating folders and subfolders, which act like digital cabinets and drawers 

to help you manage your files. 

 

Figure 11:Structured file system showing nested folders 

COMPUTER FILE MANAGEMENT 
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 Example: A School File Organization System 

 
A school administrator managing student records can organize them as follows: 

   Student Records 

       Senior One 

           Term 1 →      Assignments,      Report Cards 

           Term 2 →      Assignments,      Report Cards 

           Term 3 →      Assignments,      Report Cards 

This structure ensures that records are easy to access by class, term, and file type. 

 

What Are Folders and Subfolders? 

 
• A folder is a digital storage space that contains one or more files. 

• A subfolder is a folder created inside another folder to further group 

related files. 

 
      Example: You may have a main folder called “S5 ICT”, which contains 

subfolders like: 

• “Notes” 

• “Assignments” 

• “Projects” 

• “Images” 

Each subfolder contains only related files, making it easy to locate and manage 

your content. 

 
Step-by-Step: Creating Folders and Subfolders in Windows 
 

1. Right-click on your desktop or inside a drive (e.g., Local Disk D:). 

2. Select New → Folder. 

3. Type a name (e.g., S5 ICT) and press Enter. 

4. To create a subfolder:  
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o Open your main folder (S5 ICT), 

o Right-click → New → Folder, 

o Name it (e.g., Notes, Projects, Images, etc.). 

   Tip: Use clear and meaningful folder names to avoid confusion later. 

 
   Guidelines for Naming Files and Folders 
 

  Keep names short and specific 

  Use dates, subjects, or project titles 

  Avoid special characters (* / : ? < > | ) 

  Use hyphens or underscores for clarity (e.g., Project_Term1_2025) 

 

Poor Name Better Name 

New Folder S5_Assignments 

Document1.docx Term1_English_Essay.docx 

Notes.pdf Geography_Notes_Climate.pdf 

 
   Benefits of Using Folders and Subfolders 
 

  Easier file access and search 

  Better organization for personal and group projects 

  Reduced file duplication 

  Improved file-sharing during teamwork 
 

      Real-Life Example: A teacher in Uganda saves all classwork, lesson plans, and 

test papers in well-named folders by term and subject, making it easier to plan 

lessons. 

 
          Activity 1.3.1: Creating and Organizing Folders 
 

1. Open your computer or school lab device. 

2. Create a main folder called “S5 Student Portfolio”. 

3. Inside it, create the following subfolders: 

o Class Notes 
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o Assignments 

o Project Work 

o Images & Graphics 

4. Move related files into the correct subfolders. 

5. Rename the files for clarity and organization. 

 
Extension Task: Designing a Folder Structure for a School Club 
 

1. In groups, design a folder and subfolder structure for a school club (e.g., 

ICT Club or Debate Club). 

2. Consider folders for Minutes, Events, Reports, Photos, and Budgets. 

3. Present your structure to the class using a flow diagram or screenshot. 

 

   Reflection Questions 

• Why is it better to group files by folders than to save everything on the 

desktop? 

• How does good file organization save time and improve productivity? 

• What challenges do you face when trying to manage many digital files? 

 
1.3.2 Choosing Appropriate File Formats 
 

When you save a file, you must choose a file format — this determines how the file 

is stored, what software can open it, and how it will be shared or used. 
 

What Is a File Format? 
 

A file format refers to the structure or type of a digital file, usually identified by 

the file extension, such as: 

• .docx for Word documents 

• .xlsx for Excel spreadsheets 

• .jpg for images 

• .mp4 for videos 
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      Example: A teacher preparing a test paper saves it as a .docx file, but when 

sharing it with students who only need to read it, saves a non-editable version in 

.pdf format. 

 
Step-by-Step: Saving a File in a Different Format 

 
1. Create or open your file in Word, Excel, or PowerPoint. 

2. Click File → Save As. 

3. Choose the destination (e.g., Desktop or USB Drive). 

4. In the “Save as type” dropdown list, select your desired format (e.g., PDF, 

RTF, TXT). 

5. Click Save. 

   Bonus Tip: You can also export your file as PDF by clicking File → Export → 

Create PDF/XPS Document in newer Office versions. 

 
Common File Formats and Their Uses 
 

File Format Type Purpose / When to Use 

.docx Document Editable text document (Microsoft Word) 

.pdf Document Final, non-editable version for printing or sharing 

.xlsx Spreadsheet Data analysis and calculations (Microsoft Excel) 

.pptx Presentation Slideshow presentations (Microsoft PowerPoint) 

.jpg / .png Image Photos and illustrations (for websites or documents) 

.mp3 / .wav Audio Voice recordings or music files 

.mp4 Video Multimedia lessons or tutorials 

.zip Compressed Used to send multiple files as one compressed package 

.txt Text Plain text files (no formatting) 

.html Web Page Files used to create web content 

   Tip: Use .pdf when you want others to view your document but not edit it. 
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Figure 12: A screenshot showing file format options in a "Save As Type" menu 

 
Step-by-Step: Saving a File in a Different Format 
 

6. Create or open your file in Word, Excel, or PowerPoint. 

7. Click File → Save As. 

8. Choose the destination (e.g., Desktop or USB Drive). 

9. In the “Save as type” dropdown list, select your desired format (e.g., PDF, 

RTF, TXT). 

10. Click Save. 

   Bonus Tip: You can also export your file as PDF by clicking File → Export → 

Create PDF/XPS Document in newer Office versions. 

Choosing the Right Format Based on Need 
 

If you want to… Use this format 

Edit and update later .docx or .xlsx 

Share for reading only .pdf 

Use on a website .jpg, .png, or .html 

Store large documents with images .zip 

Share meeting recordings .mp3 or .mp4 
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          Activity 1.3.2: Choosing and Saving Files in Appropriate Formats 
 

1. Open a Word document and save it as both .docx and .pdf formats. 

2. Create a simple spreadsheet and save it as .xlsx and .csv. 

3. Insert an image in PowerPoint and export it as a presentation and as a 

video or PDF. 

4. Discuss in groups:  

o Which format was best for editing? 

o Which format is best for sharing? 

o Which format reduces file size? 

Extension Task: Format Matching Challenge 
 

1. In pairs, receive a list of ICT tasks (e.g., printing a report, creating a poster, 

sharing a photo). 

2. Match each task with the most appropriate file format. 

3. Justify your choices and present them to the class. 
 

   Reflection Questions 

• Why is it important to choose the correct file format? 

• What happens if someone cannot open your file because of the format? 

• Which formats do you use most often, and why? 

 
1.3.3 Comparing Local and Cloud Storage Solutions 
 

Once you have created and 

organized your files, you 

need to decide where to 

store them — either on your 

own device (local storage) 

or on the internet (cloud 

storage). Understanding the 

difference between these 

two storage options helps 

you make better decisions 

about file safety, accessibility, and convenience. Users store files either locally (on 

physical devices) or in the cloud (online storage services). 
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What is Local Storage? 
 
Local storage means saving files directly on your device — such as your: 

• Hard Drive (HDD or SSD) 

• Flash Disk/USB Drive 

• Memory Card (SD card) 

• External Hard Drive 

      Example: A student saves class notes on a USB flash disk so they can access 

them without internet. 

 
What is Cloud Storage? 
 
Cloud storage means saving files on the internet, where you can access them from 

any device with an internet connection. Files are stored on remote servers owned 

by service providers. 

Popular Cloud Storage Platforms Free Storage Capacity 

Google Drive 15 GB 

Dropbox 2 GB 

OneDrive 5 GB 

iCloud 5 GB 

      Example: A teacher uploads class notes to Google Drive, so students can 

access them from their phones at home. 

 
 Comparison Between Local and Cloud Storage 
 

Feature Local Storage Cloud Storage 

Access Only on the device Any device with internet 

Internet Needed Not required Required for upload/download 

Cost One-time purchase (e.g., 

flash disk) 

Free or subscription-based 

Portability Must carry physical 

storage 

Accessible online anywhere 

Security Risks Can be lost or damaged Can be hacked or data leaked if not 

secured 

Storage Capacity Limited to device size Expandable (buy more space) 

Backup Option Manual Automatic cloud sync 
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   Tip: You can use both local and cloud storage together — store important files 

locally and backup to the cloud for safety. 

 

 
          Activity 1.3.3: Comparing Storage Options 
 
1. In groups, list the devices or services you use to store your files. 

2. Create a table comparing your local and cloud storage experiences based 

on: 

o Accessibility 

o Cost 

o File safety 

o Internet dependence 

3. Share your group’s findings with the class. 

 
Extension Task: Try Out a Cloud Storage Platform 
 
1. Create a Google Drive or OneDrive account (if not already available). 

2. Upload a Word document or photo. 

3. Share the file link with a classmate. 

4. Discuss how the process compares to saving and sharing via USB flash disk. 
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   Reflection Questions 

• Which storage method is more reliable in your daily life — and why? 

• What challenges have you faced using flash disks or cloud storage? 

• How can cloud storage help in your school projects or group assignments? 

 
1.3.4 Practical Hands-on File Management Activity  

 

You have learned about organizing files, choosing appropriate formats, and storing 

them safely. Now it’s time to put that knowledge into practice through a hands-on 

file management Activity  that will help you demonstrate your real-life ICT skills. 

 

Figure 13: A screenshot of a file management window showing renamed and 

moved files 

 
Step-by-Step File Management Task Instructions 
 
1. Create a Main Folder 

o Right-click on your desktop or in a specific drive. 

o Select New → Folder. 

o Name it “S5 ICT Portfolio – Your Name”. 

2. Create Subfolders 
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o Inside the main folder, create at least four subfolders:  

▪ Assignments 

▪ Notes 

▪ Projects 

▪ Images 

3. Create and Save Sample Files 

o Create the following sample documents:  

▪ A Word document named Term1_EnglishEssay.docx and save it 

in Assignments. 

▪ A PowerPoint file named ICT_Presentation.pptx and save it in 

Projects. 

▪ A text file named ClassNotes.txt and save it in Notes. 

▪ Download or insert an image and save it in Images. 

4. Rename and Organize Files 

o Use appropriate file names. 

o Add dates to some filenames (e.g., ProjectReport_March2025.docx). 

5. Save a File in Another Format 

o Open any document and save it again as PDF (File → Save As → Select 

PDF). 

6. Transfer a File to USB Drive or Google Drive 

o Copy one file to a USB flash disk. 

o If internet is available, upload a file to your Google Drive or OneDrive. 
 

 
          Activity (a) 1.3.4: Hands-On Practice 
 

Task Expected Outcome 

Create folders and subfolders Well-organized folder structure 

Save files in multiple formats .docx, .pdf, .pptx, .txt, .jpg 

Rename and organize files properly Clear, descriptive filenames 

Transfer file to USB/cloud storage File successfully moved or uploaded 
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Extension Task: Peer Review and File Organization Challenge 
 
1. Exchange your folder with a classmate. 

2. Review each other’s file organization and naming style. 

3. Suggest improvements and discuss best practices. 

4. Vote on the “Most Well-Organized Digital Portfolio”. 

 
   Reflection Questions 

• How did this Activity help you apply file management knowledge? 

• What challenges did you face while naming or arranging files? 

• Why is it important to organize files and folders in real life? 

 
               Activity (b) 1.3.4: Practicing File Management Skills 
 

1. Create a structured folder system for a class project. 

2. Rename five files using descriptive names (e.g., "Math_Assignment1.docx" 

instead of "New Document"). 

3. Move a file from one folder to another and observe how organization 

improves access. 

4. Delete a file, then restore it from the Recycle Bin. 

 

Sample Activity of Integration 
 

     Scenario: A small business startup is struggling with manual record-keeping, 

slow communication, and inefficient marketing strategies. The business owner is 

unaware of how ICT tools can improve operations. 

Task: 

As an ICT specialist, prepare a digital report explaining how various ICT tools (e.g., 

spreadsheets, email, social media, cloud storage) can enhance business 

productivity and customer engagement. 
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Self-Assessment Questions 

 
1. Define ICT and explain its impact on three key industries. 

2. Differentiate between Cold Booting and Warm Booting. 

3. List five file formats and describe their use cases. 

4. Explain the importance of organizing files into directories. 

5. Describe three common startup issues and how to troubleshoot them. 

6. Compare cloud storage with physical storage devices. 

7. How would you explain the importance of ICT to someone unfamiliar with 

technology? Give an example from daily life. 

 

 
 
 
 
 
 
 
 
 
 

In this topic you have learnt about: 

 Explore the utilization of various ICT tools in day to-

day life. 

 Use digital tools to solve day to-day life challenges. 

 Create directories and use them to manage electronic 

files. 
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Figure 14: ICT Tools Needed for a successful Presentation 

 

 

TOPIC ELECTRONIC PRESENTATION 

Key Words 

Slide  

Template 

Slide Layout 

Animation 

Transition 

Multimedia 

Speaker notes 

Slide Master 

The Content of this topic and the activities 

will enable you to; 

1. Create Electronic Presentations and Use 

Them to Communicate Ideas 

2. Format Presentations to Make Them 

Visually Appealing 

3. Collaborate, Automate, and Deliver 

Presentations Effectively 
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Introduction 
 

Imagine attending a school assembly or a business meeting where 

the presenter shows well-organized slides with clear headings, 

images, charts, and animations. The message becomes easier to 

understand and more interesting. This is the power of an electronic 

presentation. 

In this topic, you will learn how to use presentation software tools such as Microsoft 

PowerPoint, Google Slides, or Canva to design and deliver clear, engaging, and 

professional presentations. You will also explore how to enhance your 

presentations using visual objects, multimedia elements, transitions, and 

animations. 

Whether you're a student presenting a class project or a professional speaking at 

a seminar, mastering presentation skills helps you: 

 Communicate your ideas clearly, 

 Capture and hold the attention of your audience, 

 Share information in a structured and organized way. 
 

Why Are Electronic Presentation Skills Important? 

Purpose Application Area ICT Tools Used 

Communicating ideas Education, business, 

public speaking 

PowerPoint, Google Slides, 

Canva 

Training and 

instruction 

School lessons, staff 

training 

Multimedia presentations, 

projectors 

Marketing and 

promotion 

Product demos, business 

proposals 

Visual slideshows, 

promotional videos 

Reporting and 

feedback 

Meetings, school projects Slide decks, graphs, charts 

 

      Example: A student in a certain secondary school creates a PowerPoint 

presentation to explain the effects of climate change in a geography project. The 

presentation includes headings, images, graphs, and speaker notes. 
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Quick Activity : Class Discussion 
 

1. Think of a time when you saw a presentation (in class, church, seminar, 

etc.). 

2. What made it good or bad? 

3. What ICT tools were used? 

4. What would you do differently to improve it? 

 
2.1 Create Electronic Presentations and Use Them to Communicate Ideas 
 

Creating electronic presentations helps you share your ideas in a structured, visual, 

and interactive way. Whether you are preparing a class project, business pitch, or 

public speech, presentation tools such as Microsoft PowerPoint, Google Slides, or 

Canva allow you to organize content into slides and present it clearly to your 

audience. 

   Why Are Presentation Skills Important? 
 

  Help you communicate your ideas clearly and professionally 

  Make lessons, meetings, and projects more engaging 

  Allow you to summarize large information into simple visual formats 

  Enhance your digital literacy and public speaking skills 
 

      Example: A student in S5 Arts class uses PowerPoint to present a literature 

project on “Themes in African Poetry,” using text, images, and headings to keep 

the audience engaged. 

 
Real-Life Applications of Presentation Skills 
 

Scenario Application ICT Tools Used 

Student presenting a project Visual explanation of 

research 

PowerPoint or 

Google Slides 

Teacher delivering a lesson Structured teaching 

material 

Laptop + Projector 

Business manager pitching a 

proposal 

Professional reporting Canva, Prezi, 

PowerPoint 

Peer education or public 

awareness campaigns 

Sharing information with 

community 

Slides + Multimedia 

content 

 



46 

 

 
Quick Activity: Brainstorming Discussion 
 

1. In pairs, list five places or events where electronic presentations are used in 

your community (e.g., school assembly, church event, village meeting, 

business seminar, etc.). 

2. Discuss:  

o What tools were used? 

o What made the presentation effective or poor? 

 
2.1.1 Exploring Different Presentation Software 

There are different types of presentation software that allow you to create and 

display digital slideshows. Each software tool offers various features depending on 

your needs, whether for academic presentations, business pitches, training 

sessions, or public speaking. 

What is Presentation Software? 

 
Presentation software is a computer application used to design and organize 

information into slides that include text, images, charts, audio, video, and 

animations, which are then presented to an audience using a projector, screen, or 

online platform. 

Comparison of Common Presentation Software 
 

Software Key Features Best Used For 

Microsoft 

PowerPoint 

Slide templates, SmartArt, 

transitions, speaker notes, offline 

use 

Business reports, class lessons, 

formal presentations 

Google Slides Online editing, real-time 

collaboration, auto-saving 

Group projects, remote 

presentations, shared lessons 

Canva 

Presentations 

Stylish templates, drag-and-drop 

interface, design tools 

Marketing content, creative 

storytelling, posters 

Prezi Zooming transitions, dynamic flow 

of content 

Interactive and engaging 

storytelling 

LibreOffice 

Impress 

Free, offline alternative to 

PowerPoint 

General use in schools with 

limited budgets 
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      Example: A teacher at a secondary school uses Microsoft PowerPoint to prepare 

structured lesson notes with headings, bullet points, images, and speaker notes. 

 

 

Figure 15: Best Presentation Design Software 

 
Advantages of Using Presentation Software 
 

  Simplifies information delivery 

  Supports multiple media formats (audio, video, images) 

  Enhances learner engagement and participation 

  Promotes teamwork and collaboration (especially with online tools) 

  Allows flexible editing and presentation design 

 
          Activity 2.1.1: Research and Compare Presentation Software 
 

1. In groups, explore at least three presentation software tools (e.g., 

PowerPoint, Google Slides, Canva). 

2. Identify:  

o What features they offer 

o What types of content can be inserted 

o What makes each software unique 

3. Create a comparison table summarizing your findings. 

4. Present your analysis to the class. 
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   Extension Task: Class Demonstration 

• Each group selects one software and creates a 1–3 slide mini presentation 

on any school-related topic. 

• Present to the class using projector or screen, explaining:  

o Why you chose that software 

o What features you used 

o What challenges you faced 
 

Read More here: https://www.inkppt.com/post/best-presentation-design-software  

   Reflection Questions 

• Which presentation software do you feel most comfortable using? 

• Why is it important to choose the right tool for your audience and message? 

• What challenges do learners in Ugandan schools face in accessing and using 

presentation tools? 

 

 

Working with presentation software involves planning your content, choosing 

effective templates, incorporating high-quality visuals, keeping text minimal, and 

using animations and transitions sparingly to create engaging and impactful 

presentations. 
 

2.1.2 Using Presentation Templates and Layouts 
 
When creating a presentation, you don’t need to start from scratch every time. 

Most presentation software provides templates and layouts that help you structure 

your content in a clear, professional, and visually appealing way. 

What Are Templates and Layouts? 
 

• A template is a pre-designed set of slides with a consistent design, color 

scheme, and formatting — ideal for saving time and ensuring a professional 

look. 

WORKING WITH PRESENTATION SOFTWARE 

https://www.inkppt.com/post/best-presentation-design-software
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• A layout refers to the arrangement of elements on a slide, such as title, text, 

images, charts, or bullet points. 

      Example: When creating a class presentation about Climate Change, you can 

use a "Nature" or "Environmental" template with layout options like Title Slide, 

Content Slide, or Image with Caption Slide. 

 

Figure 16: Different Slide Designs in MS PowerPoint 

Common Types of Slide Layouts 
 

Layout Type Purpose Typical Use Case 

Title Slide Introduces the presentation Presentation title and presenter 

name 

Title and 

Content 

Adds bullet points, text, 

images 

Main content slides 

Two Content 

Layout 

Compares two ideas side by 

side 

Comparing advantages and 

disadvantages 

Section Header Begins a new section or 

topic 

Dividing themes or chapters 

Picture with 

Caption 

Highlights visuals with 

explanation 

Image-based explanations 

Title Only Focuses on main heading Transition or emphasis slide 
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   Tip: Using the right layout for the right content makes your presentation 

clearer and easier to follow. 

 
Step-by-Step: Applying a Template in Microsoft PowerPoint 
 

1. Open PowerPoint and select File → New. 

2. Choose from the list of available templates (e.g., Business, Education, 

Simple, Modern). 

3. Select a template → Click Create. 

4. Replace sample content with your own text and images. 

In Google Slides, go to File → New → From template gallery to select a design. 

 
Step-by-Step: Changing a Slide Layout 
 

1. Select the slide you want to edit. 

2. On the Home tab, click Layout. 

3. Choose a layout from the list (e.g., Title and Content, Two Content, Picture 

with Caption). 

4. The content boxes on your slide will change according to the layout you 

select. 

 
Benefits of Using Templates and Layouts 
 

  Saves time and effort 

  Keeps your presentation consistent and professional 

  Helps organize content clearly 

  Improves audience understanding 

 

      Example: A Head Girl candidate preparing a campaign presentation uses a 

Simple Professional Template to organize her manifesto into clear bullet points 

with images. 
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          Activity 2.1.2: Exploring and Applying Templates and Layouts 
 

1. Open PowerPoint or Google Slides. 

2. Select a template that fits your topic (e.g., Business, Academic, Nature, 

Creative). 

3. Create a 4-slide presentation using different layouts: 

o Slide 1: Title Slide 

o Slide 2: Title and Content 

o Slide 3: Picture with Caption 

o Slide 4: Two Content layout 

4. Discuss with your classmates: 

o Which template was easiest to use? 

o Which layout helped you organize ideas best? 

 
Extension Task: Matching Content with Layouts 
 

1. Each group receives a list of presentation content types (e.g., image 

description, topic comparison, title slide, summary). 

2. Match each content type with the most appropriate slide layout. 

3. Present your matching choices and explain why you chose those layouts. 

 

   Reflection Questions 

• Why is layout selection important in presentations? 

• How does a template improve the visual appeal of your slides? 

• Which layout would you use to present a table or graph? Why? 
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2.1.3 Developing a Basic Presentation 
 

Once you have chosen a template and appropriate slide layouts, the next step is 

to develop your presentation content slide by slide. A good presentation is not just 

about appearance—it must be well-organized, clear, and focused on your 

message. 

 

Figure 17: A group of students collaborating on a Google Slides presentation 

 

   Key Elements of a Good Presentation 
 

Slide Element Purpose 

Title Slide Introduces the topic and presenter 

Bullet Points Present key ideas in short form 

Images and Charts Support your message visually 

Headings/Subheadings Show structure and flow 

Consistent Font and Color Scheme Keep presentation professional and readable 

Conclusion Slide Summarizes main points or provides a call to 

action 
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      Example: A student preparing a presentation on "The Benefits of ICT in 

Agriculture" includes a: 

• Title slide 

• Slide with bullet points on benefits 

• Slide with a chart showing crop yield improvement 

• Summary slide with a concluding message 

 
   Best Practices When Developing Slides 
 

  Keep text short and direct 

  Use 5–7 lines per slide, 3–5 words per bullet point 

  Use large font sizes (minimum 24pt) 

  Include one idea per slide 

  Use images, charts, or diagrams where possible 

  Ensure good contrast between text and background 

 
Step-by-Step: Developing a Basic Presentation in PowerPoint or Google Slides 
 

1. Open presentation software (PowerPoint/Google Slides). 

2. Choose a template (as covered in Section 2.1.2). 

3. Start with a Title Slide: Include title, name, and date. 

4. Add new slides with relevant layouts (e.g., Title and Content, Picture with 

Caption). 

5. Add your content:  

o Use bullet points instead of long paragraphs. 

o Add images or charts to support your text. 

6. Maintain visual consistency:  

o Use the same font size, colors, and style across all slides. 

7. Add a Conclusion Slide with a summary or key message. 

   Tip: Avoid overcrowding slides. Use few words per point and high-

quality visuals. 
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          Activity 2.1.3: Creating a 5-Slide Basic Presentation 
 

1. Choose a topic of your interest (e.g., Importance of Education, Causes of 

Climate Change, Youth in Business). 

2. Develop a presentation with the following structure: 

o Slide 1: Title Slide 

o Slide 2: Introduction 

o Slide 3: Main Ideas (bullet points) 

o Slide 4: Supporting Visual (image or chart) 

o Slide 5: Conclusion 

3. Share your presentation with a partner and give feedback. 

 

 
   Extension Task: Improving an Existing Presentation 
 

1. Your teacher provides a sample presentation. 

2. In pairs, review the presentation and identify: 

o Poor slide structure 

o Overcrowded text 

o Missing visuals or weak layout 

3. Make improvements based on what you’ve learned: 

o Reorganize slides 

o Add visuals 

o Adjust formatting for clarity 

 

   Reflection Questions 

• How does slide structure affect audience understanding? 

• What are the dangers of using too much text in a slide? 

• What will you do differently the next time you develop a presentation? 

 

 



55 

 

 
2.1.4 Presenting Ideas Using a Slide Show 
 
Creating a presentation is only part of the process — you must also present it 

effectively to your audience. A good presentation delivery involves clear speech, 

proper slide navigation, use of speaker notes, and audience engagement. 

 

Figure 18: A student confidently delivering a PowerPoint presentation to a classroom 

What Is a Slide Show? 
 

A Slide Show is a full-screen view of your presentation that displays one slide at a 

time, allowing you to communicate your message in a structured and visually 

engaging way. 

      Example: A student presenting their ICT project in class uses Slide Show mode 

in PowerPoint to guide the audience slide by slide, while referring to speaker notes. 

 
Key Elements of a Successful Slide Show Presentation 

 

Element Purpose 

Slide Show View Presents the slides one by one in full-screen 

Speaker Notes Help you remember key points while presenting 

Navigation Tools Move from one slide to another using keyboard or mouse 

Timing & Pacing Control how fast or slow your slides appear 

Audience Interaction Maintain eye contact, ask questions, and answer queries 
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Step-by-Step: Presenting Using Slide Show in PowerPoint 
 

1. Open your presentation file. 

2. Click Slide Show tab on the Ribbon. 

3. Choose:  

o From Beginning to start the slideshow from the first slide 

o From Current Slide to continue from a specific slide 

4. Use your keyboard arrows (→ or ↓) or mouse click to move forward. 

5. Press Esc to exit Slide Show mode. 

 

 

Figure 19: Example: A structured slideshow with smooth transitions and speaker 

notes 

 
Using Speaker Notes Effectively 
 

• Add short notes under each slide to guide your speech. 

• Go to View → Notes to type your speaker notes. 

• Use these as memory aids, not as a script. 

 

      Example: A teacher presenting a lesson uses Speaker Notes to remind herself 

of key examples and explanations while students focus on the slides. 
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Timing Your Presentation 
 

• Practice your presentation in Slide Show mode. 

• Use Rehearse Timings feature in PowerPoint to time how long you spend on 

each slide. 

• Aim for 1–2 minutes per slide, depending on the content. 

 
          Activity 2.1.4: Slide Show Presentation Practice 

 

1. Finalize your 5-slide presentation (from Activity 2.1.3). 

2. Practice presenting it using Slide Show view. 

3. Use Speaker Notes for each slide. 

4. Present to your classmates in 3–5 minutes. 

5. Receive feedback on:  

o Clarity of speech 

o Flow of ideas 

o Use of slides and notes 

o Confidence and audience engagement 

 
Extension Task: Peer Evaluation of Presentations 

1. In pairs or groups, observe each other's presentations. 

2. Use a Presentation Feedback Checklist like the one below: 

Criteria Yes/No Comments 

Used Slide Show view effectively 
  

Speaker Notes were used appropriately 
  

Ideas were presented clearly 
  

Visual elements supported the message 
  

Presenter maintained audience engagement 
  

3. Provide constructive feedback and suggestions for improvement. 
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   Reflection Questions 
 

• How does Slide Show mode help improve communication? 

• Why are speaker notes useful during presentations? 

• What will you do differently to improve your next presentation? 

 
2.1.5 Customizing the Theme and Visual Consistency 
 

A good presentation is not only about what you say — it’s also about how your 

slides look and feel. When your slides have a consistent visual appearance, they 

become easier to read, more professional, and more engaging to your audience. 

 

What Is a Presentation Theme? 

 
A theme is a set of predefined design elements including:  

  Background color 

  Fonts 

  Slide layouts 

  Color schemes 

  Effects 

Themes help your presentation appear neat, coordinated, and visually appealing. 
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      Example: A student creating a presentation about Tourism in Uganda uses a 

green-and-gold nature theme, which matches the topic and enhances visual 

appeal. 

 
Visual Consistency: What Does It Mean? 
 

Visual consistency means that all slides:  

  Use the same font type and size 

  Have uniform spacing and alignment 

  Share the same color scheme and background 

  Follow a standard layout structure 

 

     Tip: Avoid mixing too many fonts, colors, or slide designs — it distracts your 

audience. 

 
Step-by-Step: Changing and Customizing a Theme in PowerPoint 
 

1. Open your presentation. 

2. Click on the Design tab on the Ribbon. 

3. Choose a theme from the gallery (hover over each to preview). 

4. Click Variants to customize colors, fonts, or effects. 

5. Use Customize Fonts or Customize Colors for advanced adjustments. 

     In Google Slides, go to Slide → Change Theme to access and apply theme 

options. 

 
Step-by-Step: Ensuring Visual Consistency 
 

  Use the same font type and size on all slides 

  Use bullet points consistently 

  Align text and images properly 

  Avoid mixing too many styles or decorations 

  Apply the same layout format for similar slides 
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Figure 20: Customize Colors and Fonts from this section 

 
          Activity 2.1.5: Customizing Your Presentation Theme 
 

1. Open your previous presentation (from Activity 2.1.3). 

2. Apply a suitable theme that matches your topic. 

3. Customize the following elements: 

o Font (e.g., Calibri, Arial, Verdana) 

o Background color or image 

o Slide layout structure 

o Header and footer design 

4. Review your slides for consistency in font size, bullet points, alignment, and 

image placement. 

 

Figure 21: Screenshot showing Design tab with selected themes 
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Extension Task: Theme Design Challenge 
 

1. In groups, create two presentations on the same topic using different 

themes. 

2. Compare how design affects message delivery and audience interest. 

3. Present both versions and allow your classmates to vote for the most 

visually consistent one. 

 
Best Practices for Visual Consistency 

 
  Choose a theme appropriate to your topic 

  Keep fonts large and readable (at least 24pt) 

  Use light text on dark background (or vice versa) 

  Limit color choices to 2–3 main colors 

  Keep image size and placement uniform 

 

   Reflection Questions 

• Why is it important for your slides to look visually consistent? 

• How does a customized theme improve your presentation? 

• What mistakes should be avoided when choosing fonts and colors? 

 
2.1.6 Delivering a Presentation Using Interactive Tools 
 

Delivering a presentation is more than just reading slides. To capture your 

audience’s attention, you need to use interactive tools and techniques that make 

your message clear, engaging, and memorable. 

What Are Interactive Presentation Tools? 

 
These are features that enhance delivery and audience engagement. They help 

you:  

  Communicate ideas smoothly 

  Emphasize key points 

  Keep the audience interested 

  Support two-way interaction 
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      Example: A student delivering a presentation on “The Impact of Climate 

Change” uses speaker notes for guidance, animations to introduce points, and 

transition effects between slides to make the delivery lively. 

 
Common Interactive Tools in Presentation Software 

 

Tool/Feature Purpose Example Use 

Speaker Notes Provide cues for presenter 

without showing on screen 

Help you explain content 

confidently 

Slide Show View Display slides full-screen for 

the audience 

Professional presentation 

delivery 

Animations Add motion effects to text 

and objects 

Emphasize key points (e.g., 

bullet-by-bullet entry) 

Transitions Apply effects between slides Smooth change from one slide 

to the next 

Pointer 

Tools/Highlighting 

Focus attention on specific 

parts 

Show where a graph or chart is 

being discussed 

Q&A Sessions Engage audience through 

questions 

Ask learners to share opinions 

or answer quiz questions 

 

Figure 22: A guest speaker at a business conference uses a wireless clicker and speaker 

notes to navigate slides smoothly 
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Step-by-Step: Using Interactive Tools in PowerPoint 
 

1. Add Speaker Notes 

o Click View → Notes pane. 

o Type your notes for each slide. 

2. Apply Animations 

o Select an object or text box → Click Animations tab. 

o Choose an animation style (e.g., Appear, Fade, Fly In). 

o Set animation order for multiple objects. 

3. Apply Slide Transitions 

o Click Transitions tab. 

o Select a transition effect (e.g., Push, Wipe, Split). 

o Adjust timing or apply to all slides. 

4. Deliver Using Slide Show View 

o Click Slide Show → From Beginning. 

o Use keyboard or mouse to navigate slides. 

5. Use Pointer Tools During Presentation 

o Press Ctrl + P to activate pen tool. 

o Use to underline or highlight parts of a slide. 

 
          Activity 2.1.6: Delivering a Presentation with Interactive Tools 

 

1. Finalize your group presentation (from previous activities). 

2. Add speaker notes, transitions, and animations where appropriate. 

3. Practice presenting using Slide Show view. 

4. During presentation:  

o Use pointer tool to emphasize points 

o Ask your classmates a question or give a short quiz 

o Invite comments or feedback 
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Figure 23: Screenshot showing PowerPoint animations panel 

 
Extension Task: Interactive Presentation Challenge 
 

1. In small groups, prepare a mini-presentation on a chosen topic. 

2. Your presentation must include: 

o Speaker notes 

o At least two animations 

o Slide transitions 

o One moment of audience interaction (e.g., question, voting, short 

discussion) 

3. Present and rate each group based on creativity, interactivity, and clarity. 

 
Best Practices for Interactive Delivery 
 

  Don’t overuse animations — keep it simple 

  Time your transitions and effects smoothly 

  Practice with speaker notes before presenting 

  Engage the audience with questions or examples 

  Maintain eye contact and confident posture 

 
   Reflection Questions 

• Which interactive tool did you enjoy using most? 

• How did animations and transitions help your delivery? 

• What can you do next time to make your presentation more engaging? 
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A good presentation is not just about the information it’s also about how you 

present it visually. Even strong content can lose impact if slides are cluttered, dull, 

or poorly designed. Formatting improves the way your message is received and 

helps your audience stay interested. 
 

2.2 Format Presentations to Make Them Visually Appealing and Engaging 

Presentation formatting involves arranging slides and layouts to be visually 

appealing and easy to follow, ensuring a positive first impression and engaging 

your audience, ultimately conveying your message effectively. 

Why Formatting Matters in a Presentation 
 

  Grabs the audience’s attention 

  Makes your slides easy to read and understand 

  Creates a professional and consistent appearance 

  Helps emphasize important points 

  Supports storytelling and flow 

      Example: A student presenting a project on Renewable Energy uses a green 

color theme, bold headings, icons, and animated images, making the presentation 

more lively and easier to follow. 

 
Quick Brainstorming Activity: What Makes a Presentation Visually Appealing? 

• What visual elements do you enjoy in a presentation? 

• What makes a slide boring or hard to understand? 

• What formatting techniques have you used before? 

 
2.2.1 Applying Text Formatting for Visual Appeal 

Text is one of the most important elements in your presentation, but if it’s poorly 

formatted, your audience may lose interest or struggle to read your content. 

Applying proper text formatting makes your slides clear, attractive, and engaging. 

      Example: A student preparing a presentation on “Causes of Teenage 

Pregnancy” uses bold headings, clear bullet points, and highlighted keywords to 

emphasize key ideas and make the content easier to follow. 

PRESENTATION FORMATING 
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What Is Text Formatting? 
 

Text formatting refers to the way you change the appearance of text to make it 

easier to read and more attractive. This includes:  

  Font type and size 

  Font color and style (bold, italics, underline) 

  Bullet points and numbering 

  Word Art and SmartArt 

  Text alignment and spacing 

 
Key Text Formatting Features 
 

Formatting Tool Purpose Example Use 

Font Type Sets text appearance Arial, Calibri, Verdana for clean, 

readable slides 

Font Size Controls readability Titles (28–44 pt), Body Text (20–

28 pt) 

Bold, Italics, Underline Emphasizes important 

words 

Bold for headings, italics for 

quotes 

Font Color Adds visual contrast 

and appeal 

Use dark text on light 

backgrounds 

Bullet Points Organizes content in 

lists 

Points under each subtopic 

WordArt/SmartArt Adds design flair Highlight slide titles or concepts 

Alignment (Left, Center, 

Right) 

Improves layout 

structure 

Center-aligned titles, left-aligned 

body text 

Line and Paragraph 

Spacing 

Improves text clarity 1.5 spacing between lines for 

readability 

   Tip: Use contrast wisely. A light font on a white background is hard to read. 

 
   Step-by-Step: Applying Text Formatting in PowerPoint 
 

1. Select the text box or text you want to format. 

2. Use the Home tab to:  

o Change font type and size 

o Apply bold, italics, underline 
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o Change font color 

o Add bullet points or numbering 

3. Use Paragraph tools to adjust alignment and spacing. 

4. For headings, apply WordArt from the Insert tab → WordArt. 

In Google Slides, use the Format and Toolbar options for similar effects. 

 
   Best Practices for Text Formatting 
 

        Use legible fonts (avoid decorative or cursive fonts) 

        Avoid using too many colors or font styles in one slide 

        Stick to 2–3 font sizes per presentation 

        Keep bullet points short and simple 

        Don’t overload slides with too much text 

        Highlight only the key terms for emphasis 

 
          Activity 2.2.1: Formatting Slides for Visual Appeal 
 

1. Open your previous presentation. 

2. Review and improve the text formatting: 

o Adjust fonts and sizes for readability 

o Use bullets for long sentences 

o Add WordArt for headings 

o Highlight keywords in color or bold 

3. Present before-and-after slides to a partner or class and explain the 

changes made. 

 
Extension Task: Slide Design Challenge 
 

1. In groups, each learner formats one slide using different styles. 

2. Combine all slides into one presentation. 

3. Discuss which formatting works best for clarity and attractiveness. 

 

   Reflection Questions 

• Why is font size important when presenting to an audience? 

• What makes some slides hard to read? 

• How can bold and color help emphasize ideas? 
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2.2.2 Incorporating Multimedia Elements into Presentations 
 
A great presentation is not just about text and bullet points it should also include 

multimedia elements like images, audio, video, charts, and animations. These 

elements help make your slides more interactive, engaging, and easier to 

understand. 

What Are Multimedia Elements? 
 

Multimedia refers to digital content that combines text with other media such as: 

        Images (Photos, Clip Art, Icons) 

        Audio (Music, Narration, Sound Effects) 

        Video (Demonstrations, Tutorials, Interviews) 

        Charts (Data Visualization: Bar, Pie, Line) 

        Shapes and Graphics 

 

      Example: A student presenting on “The Causes of Water Pollution” inserts 

images of polluted rivers, a short video of a documentary clip, and a bar chart 

showing statistics from Uganda. 

 
Step-by-Step: Inserting Multimedia Elements in PowerPoint 
 

➤ To Insert an Image: 

1. Click Insert → Pictures → This Device 

2. Select the image from your computer and click Insert 

3. Resize and position the image on the slide 

➤ To Insert an Online Picture (PowerPoint 2013 and above): 

1. Click Insert → Online Pictures 

2. Search using keywords (e.g., “education icons”) 

3. Select and insert 

➤ To Insert Audio: 

1. Click Insert → Audio → Audio on My PC 

2. Choose your audio file and click Insert 

3. Choose Play Automatically or When Clicked 
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➤ To Insert Video: 

1. Click Insert → Video → Video on My PC 

2. Select and insert the video file 

3. Adjust size and choose Playback options 

➤ To Insert a Chart: 

1. Click Insert → Chart 

2. Choose chart type (Bar, Pie, Line, etc.) 

3. Enter your data in the spreadsheet that appears 

   Tip: Use multimedia elements that support your message, not just for 

decoration. 

 
   Benefits of Using Multimedia in Presentations 
 

  Makes information easier to understand 

  Increases interest and attention 

  Explains concepts more effectively 

  Supports storytelling through visuals and sound 

  Makes your presentation more professional 

 

 

     Note: Always check file size and compatibility when using audio and video in 

presentations to avoid playback errors. 
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          Activity 2.2.2: Enhancing a Presentation with Multimedia Elements 
 

1. Open your existing presentation. 

2. Insert at least one of each of the following:  

o An image 

o A chart 

o An audio clip or short video 

3. Format and position each element for visual balance. 

4. Present to a partner and explain how the multimedia elements enhanced 

your presentation. 

 
Extension Task: Multimedia Integration Challenge 
 

1. In small groups, choose a topic (e.g., HIV awareness, digital marketing, 

climate change). 

2. Create a multimedia-enhanced presentation using:  

o Text and bullet points 

o Images and charts 

o A short video or audio file 

3. Present it in class and discuss what worked well and what can be improved. 

 

   Best Practices When Using Multimedia 

        Use clear, high-quality visuals 

        Keep charts simple and easy to interpret 

        Avoid too many multimedia elements on one slide 

        Test your video and audio before presenting 

        Make sure your content is relevant and meaningful 

 

   Reflection Questions 

• Which multimedia element did you enjoy using most? 

• How did it help your audience understand your presentation better? 

• What challenges can arise when using multimedia? 
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2.2.3 Using Slide Transitions and Animations Effectively 
 

Adding transitions and animations to your presentation makes it dynamic and 

engaging. However, these tools must be used carefully and consistently — not just 

for decoration, but to emphasize ideas, control the flow of content, and hold 

audience attention. 

What Are Transitions and Animations? 
 

Feature Purpose Example 

Slide 

Transitions 

Control how one slide moves to the next Fade, Push, Wipe, Split 

Animations Add motion effects to text, images, or 

objects on a slide 

Bullet points appear one 

by one 

      Example: A student presenting on "Digital Entrepreneurship" uses Fade 

transitions between slides and Fly-In animation for key bullet points, allowing ideas 

to appear gradually. 

 

 

Figure 24: A PowerPoint settings panel showing animation effects. 
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Step-by-Step: Applying Transitions in PowerPoint 
 

1. Select the slide where you want to add a transition. 

2. Click on the Transitions tab. 

3. Choose a transition effect (e.g., Fade, Push, Wipe). 

4. Use Effect Options to customize the direction. 

5. Adjust Duration (e.g., 01.00 seconds). 

6. Click “Apply to All” if you want the same effect on all slides. 

7. Use Preview to test the transition. 

 
Step-by-Step: Applying Animations in PowerPoint 
 

1. Select the text or object (image, shape, chart) you want to animate. 

2. Click on the Animations tab. 

3. Choose an animation (e.g., Appear, Fly In, Fade). 

4. Use Animation Pane to control the order and timing. 

5. Set how the animation starts: 

o On Click 

o With Previous 

o After Previous 

6. Apply Exit Animations to remove objects gracefully (optional). 

   Tip: Use Entrance animations for bullet points and Emphasis 

animations for highlighting key ideas. 

 
Common Types of Animations and When to Use Them 
 

Animation Type Purpose Use Case 

Entrance (Appear, Fly In) Introduce text or 

images 

Bullet points, slide titles 

Emphasis (Grow/Shrink, 

Color Change) 

Highlight key items Drawing attention to a statistic 

Exit (Fade Out, Fly Out) Remove objects 

smoothly 

End of a section or idea 

Motion Path Move an object 

along a path 

Interactive storytelling or 

diagram explanation 
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Best Practices When Using Transitions and Animations 
 

        Keep it simple — don’t overdo it 

        Use consistent effects throughout the presentation 

        Choose professional and smooth effects (Fade, Wipe, Appear) 

        Avoid distracting effects (e.g., Bounce, Spiral, Random Bars) 

        Time your animations to match your explanation 

     Less is more — Your audience should focus on your message, not be distracted 

by flashy effects. 

 
          Activity 2.2.3: Enhancing a Presentation with Transitions and Animations 
 

1. Open your existing presentation. 

2. Apply a slide transition effect to each slide. 

3. Add entrance animation to bullet points or images. 

4. Use the Animation Pane to adjust timing and order. 

5. Present your work to a classmate and get feedback on flow and 

effectiveness. 

 
Extension Task: Animation and Transition Demo Presentation 
 

1. Create a short 3-slide presentation (any topic). 

2. Slide 1: Use a transition + animation for title 

3. Slide 2: Animate bullet points to appear one at a time 

4. Slide 3: Add an exit animation for summary points 

5. Present and explain the purpose of each effect used. 

 

   Reflection Questions 

• How can transitions and animations improve your presentation delivery? 

• What are some common mistakes learners make when using animations? 

• What rules will you follow when adding transitions to your next 

presentation? 

 

 



74 

 

 
2.2.4 Formatting a Presentation to Tell a Compelling Story 
 
A compelling presentation is more than just slides with information — it should 

take your audience on a journey from introduction to conclusion in a logical, 

engaging, and impactful way. The way you format your slides, arrange your 

content, and use visual design can help your message feel like a story — not just a 

list of facts. 

What Is a Storytelling Format in a Presentation? 

 

Storytelling in a presentation means arranging your content so that it:  

  Has a beginning (introduction) 

  Has a middle (key content and message) 

  Has an end (conclusion or call to action) 

      Example: A student presents a topic on “Waste Management in Kampala” 

using a storytelling format: 

• Slide 1: The problem (uncleared garbage) 

• Slide 2: Causes (poor disposal habits) 

• Slide 3: Impact (health and environment risks) 

• Slide 4: Solutions (recycling, public awareness) 

• Slide 5: Conclusion (Call to action: “Let’s keep our communities clean!”) 

 
Elements of a Compelling Story Format 
 

Slide Element Purpose in Storytelling Example 

Title Slide Sets the topic and grabs attention “The Power of Clean Water” 

Problem Slide Describes what the issue is “Water scarcity in rural Uganda” 

Cause Slide Explains why the issue exists “Overuse and poor 

management” 

Impact Slide Shows the effect on 

people/community 

“Poor sanitation, disease” 

Solution Slide Offers ideas or answers “Rainwater harvesting, 

awareness” 

Conclusion 

Slide 

Final message or summary “Together, we can make a 

difference!” 
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   Tip: Each slide should build on the previous one, just like scenes in a story. 

 
Step-by-Step: Structuring a Presentation as a Story 
 

1. Start with a strong introduction (Title, background, importance of the 

topic). 

2. Identify the problem or issue your presentation is addressing. 

3. Show evidence or examples (statistics, images, videos). 

4. Propose solutions or ideas to solve the issue. 

5. End with a clear summary or call to action (what you want your audience to 

do or remember). 

 
   Formatting Tips to Support Your Story 
 

        Use headings and subheadings to guide your audience 

        Keep bullet points short and focused 

        Use visuals (images, charts, icons) to support the message 

        Apply consistent slide layout and design 

        Use animations and transitions to emphasize flow and sequence 

        Highlight key words or phrases to keep focus 

     Avoid cramming too much on one slide — each idea deserves its own space. 

 

Figure 25: A presentation slide with a structured storytelling flow 
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          Activity 2.2.4: Designing a Story-Based Presentation 
 

1. Choose a topic (e.g., “The Effects of Drug Abuse”, “The Value of Trees”, 

“Empowering the Girl/Boy Child”). 

2. Design a 5–6 slide presentation following storytelling format: 

o Slide 1: Title and Introduction 

o Slide 2: The Problem 

o Slide 3: Causes or Background 

o Slide 4: Impact or Consequences 

o Slide 5: Solutions or Interventions 

o Slide 6: Conclusion or Call to Action 

3. Apply formatting tools such as: 

o Clear headings and bullets 

o Consistent theme and layout 

o Visual elements and animations 

 
Extension Task: Group Storytelling Presentation Challenge 
 

1. In groups, choose a real issue in your community. 

2. Create a story-based digital presentation explaining:  

o What the issue is 

o Who it affects 

o Why it matters 

o How it can be solved 

3. Present it to your class as a story, not a lecture. 

 

   Reflection Questions 

• What makes a presentation feel like a story rather than a list of points? 

• Why is it important to guide your audience through a flow of ideas? 

• How can formatting support storytelling in presentations? 
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2.2.5 Designing a Professional Presentation for an Event 
 

When preparing a presentation for a formal event — such as a school assembly, 

business seminar, project exhibition, academic conference, or a club meeting — 

your slides must not only inform, but also impress and influence your audience. 

What Makes a Presentation Professional? 

 
  Visually consistent and clean design 

  Well-structured content flow 

  Proper use of fonts, colors, and layouts 

  Multimedia elements that support the message 

  Clear call to action or takeaway message 

  Prepared and confident presenter 

      Example: A group of S5 students preparing for the Uganda Schools ICT 

Exhibition use PowerPoint with a blue-and-white theme, charts, minimal text, and 

high-quality images to demonstrate their community water filtration project. 

 
Steps for Designing a Professional Presentation 
 

1. Identify the Purpose of the Event  

o Is it to inform, persuade, entertain, or report? 

2. Know Your Audience  

o Who will be watching? (Students, teachers, parents, business 

people?) 

3. Choose a Suitable Theme and Layout  

o Use simple, modern, and professional templates (e.g., Formal, 

Business, Clean). 

4. Plan Your Slide Sequence  

o Start with title → introduction → content → evidence → conclusion → 

call to action. 

5. Limit Text per Slide  

o Use bullet points, keywords, and visuals to avoid clutter. 
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6. Use High-Quality Multimedia  

o Charts, photos, icons, and short videos — keep them relevant and 

sharp. 

7. Add Branding if Needed  

o Include logos, school name, team name, date, etc. 

8. Proofread for Errors  

o Spelling, grammar, and formatting must be clean. 

9. Practice Your Delivery  

o Rehearse timing, tone, and gestures. 

 
   Key Formatting and Design Tips 
 

Design Element Best Practice 

Fonts Use clean fonts like Calibri, Arial; Title: 36–44pt, Text: 24–32pt 

Colors Use 2–3 consistent colors; avoid bright combinations 

Alignment Keep text and images well-aligned 

Visual Balance Don’t overcrowd slides with too many elements 

Slide Transitions Use smooth effects like Fade or Wipe 

Multimedia Use only if it strengthens your message 

 

Figure 26: A well-designed PowerPoint slide for a zoom session 
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          Activity 2.2.5: Designing a Professional Event Presentation 
 

1. In groups, select a presentation scenario: 

o Product Launch 

o School Club Meeting 

o Business Proposal 

o Health Awareness Campaign 

o Education Seminar 

2. Plan your presentation using the steps above. 

3. Create a 6–8 slide presentation, including: 

o Title Slide with event name 

o Introduction and Purpose 

o Main Points 

o Visual Data or Multimedia 

o Conclusion and Call to Action 

o Branding elements (e.g., logos, footer) 

4. Present your slides in class and receive peer feedback on: 

o Content quality 

o Slide formatting 

o Professional appearance 

 
Extension Task: Event Presentation Poster & Handouts 
 

• Create a digital poster or slide handout summarizing your presentation. 

• Include key takeaways, contact information, or resources shared during the 

event. 

 
   Reflection Questions 

• What elements made your presentation professional? 

• How would you change your design for a different audience (e.g., children 

vs. business people)? 

• What challenges did you face in keeping your slides formal and clear? 
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Today’s presentations are no longer created in isolation. In many learning and work 

environments, people collaborate remotely, use automation features to make their 

work easier, and deliver presentations through digital tools such as projectors, 

video conferencing apps, or shared online platforms. 

 
2.3 Collaborate, Automate, and Deliver Presentations Effectively 

Why Are Collaboration, Automation, and Delivery Skills Important? 

 
  Improve teamwork and productivity 

  Make slide presentations smooth and hands-free 

  Build confidence in public speaking 

  Prepare learners for modern digital workplaces 

  Enable remote learning and digital communication 

      Example: A group of S5 students working on a class project collaborate in 

Google Slides, automate slide timings, and later deliver their presentation using 

Zoom during an online inter-school ICT event. 

 
2.3.1 Collaborating on a Presentation Using Cloud-Based Tools 
 
In the modern digital world, presentations are often created together by teams, 

not just by one person. Collaboration allows different people to contribute ideas, 

design slides, and edit content in real time, even when they are not in the same 

place. 

With cloud-based presentation tools, learners and professionals can work on the 

same presentation at the same time using the internet. 

What is Cloud-Based Collaboration? 

 
Cloud-based collaboration means working together on a presentation over the 

internet using tools that allow:  

COLLABORATION, AUTOMATION AND  

PRESENTATION DELIVERYY  



81 

 

  Real-time editing 

  Commenting and feedback 

  Automatic saving 

  Access from anywhere and any device 

      Example: A team of learners preparing a group project presentation on “The 

Impact of ICT on Society” use Google Slides. Each member edits different slides at 

the same time, while leaving comments for each other in the margins. 

 

Popular Cloud-Based Presentation Tools 

Tool Key Features Best Use 

Google Slides Real-time editing, comments, 

revision history 

Group school projects, 

remote learning 

Microsoft 

PowerPoint Online 

Similar to traditional 

PowerPoint, but cloud-based 

Collaborative work in 

Microsoft environments 

Canva Presentations Visual design templates, real-

time team collaboration 

Marketing pitches, creative 

content 

Zoho Show Team editing and cloud storage 

integration 

Corporate and business 

presentations 

   Tip: All these tools require a stable internet connection and a user account 

(e.g., Gmail or Microsoft account). 

 

Figure 27: A Google Slides document being co-edited by multiple users. 
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Step-by-Step: Collaborating Using Google Slides 
 

1. Go to https://slides.google.com. 

2. Click Blank Presentation or choose a template. 

3. Rename the presentation. 

4. Click Share → Add email addresses of team members. 

5. Assign editing roles (Editor, Viewer, Commenter). 

6. Each person works on their assigned slides in real time. 

7. Use the Comment button (speech bubble icon) to give feedback. 

8. Changes are automatically saved and everyone sees updates instantly. 
 

   In PowerPoint Online: Upload your file to OneDrive, open it in 

PowerPoint Online, and click Share to collaborate. 

 
   Benefits of Cloud-Based Collaboration 

 

     Saves time — multiple users work simultaneously 

     Enhances team creativity and contribution 

     Reduces version errors (everyone works on the same file) 

     Enables remote work and learning 

     Encourages shared responsibility and peer review 

 
          Activity 2.3.1: Collaborative Presentation Task 
 

1. Form a group of 3–5 learners. 

2. Choose a topic (e.g., “Digital Communication”, “Climate Action”, “Smart 

Farming”). 

3. Open Google Slides or PowerPoint Online and start a group presentation. 

4. Assign slides among group members. 

5. Each member contributes content and provides comments. 

6. Review the presentation together and improve formatting and structure. 

7. Present your collaborative presentation to the class. 

https://slides.google.com/
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   Extension Task: Peer Review and Feedback 

1. Exchange your collaborative presentation with another group. 

2. Use the commenting feature to suggest improvements. 

3. Revise your work based on peer feedback. 

 

   Reflection Questions 

• What was the easiest or hardest part of working in a group online? 

• How did cloud collaboration improve your presentation? 

• What skills did you build through collaborative editing and feedback? 

 
2.3.2 Preparing and Delivering an Individual Presentation 
 

After learning how to create and format presentations, it’s important to also learn 

how to present individually with confidence. Preparing and delivering your own 

presentation helps you build skills in communication, organization, creativity, and 

audience engagement. 

Why Individual Presentation Skills Matter 
 

     Improve public speaking and communication 

     Build self-confidence in academic and professional life 

     Help you express ideas clearly and persuasively 

     Prepare you for interviews, seminars, and leadership roles 

     Enable you to educate or influence others with structured messaging 

      Example: A student in S5 prepares a solo presentation on “The Role of ICT in E-

Government Services in Uganda”, using structured slides, multimedia support, and 

a confident delivery style during a classroom session. 

 
Key Steps for Preparing an Individual Presentation 
 

   Tip: Practice makes perfect! Rehearse multiple times before your actual 

presentation. 
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Step Activity  Purpose 

1. Choose a topic Pick a subject you are familiar 

with or passionate about 

Builds confidence and 

clarity 

2. Plan your content Outline your key points Ensures structure and flow 

3. Design your slides Apply visual consistency, bullet 

points, images, and charts 

Enhances understanding 

and engagement 

4. Add speaker 

notes 

Prepare key messages for each 

slide 

Helps you remember what 

to say 

5. Rehearse your 

presentation 

Practice timing and flow Reduces nervousness and 

improves delivery 

6. Present to 

audience 

Use slide show view and speak 

clearly 

Demonstrate your skills and 

message 

 
   Best Practices During Delivery 
 

  Greet and introduce yourself confidently 

  Maintain eye contact with the audience 

  Avoid reading slides word-for-word — speak naturally 

  Use gestures and voice modulation to emphasize points 

  Engage the audience with a question or story 

  Stay calm and manage time well (2–5 minutes) 

 

Figure 28: A student confidently presenting in front of a class with slides 

projected on a screen 
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          Activity 2.3.2: Individual Presentation Practice 
 

1. Choose a topic from your course or personal interest (e.g., “Social Media 

and Teenagers”, “My Career Goals”, “ICT in Agriculture”). 

2. Create a 5-slide presentation with:  

o Title and Introduction 

o Main ideas (bullet points and visuals) 

o Conclusion or recommendation 

3. Add speaker notes for each slide. 

4. Rehearse individually for 3–5 minutes. 

5. Deliver your presentation to the class. 

6. Receive feedback from classmates and your teacher. 

 

   Extension Task: Peer Feedback Form 

Prepare a simple peer assessment form with criteria such as: 

• Clarity of speech 

• Slide organization 

• Eye contact and confidence 

• Use of interactive tools (e.g., pointer, speaker notes) 

• Overall impact 

Each student uses the form to give feedback to classmates after their 

presentation. 

 

   Reflection Questions 

• What made you feel confident or nervous during your presentation? 

• How did using speaker notes and practice help your performance? 

• What will you do differently next time to improve your delivery? 
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2.3.3 Virtual Presentation Rehearsals Using Video Conferencing Tools 
 
In today’s digital world, presentations are not limited to physical classrooms or 

halls. With tools like Zoom, Microsoft Teams, and Google Meet, you can deliver 

presentations remotely and interact with your audience in real-time. 

Why Are Virtual Presentation Skills Important? 
 

  Enable remote learning and communication 

  Prepare you for online interviews, webinars, and digital meetings 

  Build confidence in using modern digital platforms 

  Enhance collaboration beyond the classroom 

  Encourage peer learning through feedback 

      Example: A group of students in S5 rehearse their ICT project presentation on 

Google Meet, receive feedback from their classmates in another school, and 

improve their final delivery. 

 

Figure 29: A virtual meeting where participants are reviewing a shared 

presentation 
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Common Video Conferencing Tools for Presentations 
 

Tool Features Best Use 

Zoom Screen sharing, recording, 

breakout rooms 

Online classes, peer review, 

club meetings 

Microsoft 

Teams 

Slide sharing, collaboration, 

integrated chat 

Group presentations in 

institutions 

Google Meet Real-time presentation, simple 

interface, easy access 

Class activities, virtual 

rehearsals 

   Tip: Most tools require a Gmail or Microsoft account, a stable internet 

connection, and presentation file ready for screen sharing. 

 
Step-by-Step: Rehearsing a Presentation Virtually 
 

1. Choose your platform (Zoom, Teams, or Google Meet). 

2. Schedule a meeting or start an instant session. 

3. Invite classmates to join using the link or code. 

4. Share your screen (Click “Share Screen” or “Present Now”). 

5. Navigate through slides using Slide Show mode. 

6. Use speaker notes as your guide. 

7. Record the session (optional) to review your performance. 

8. Ask classmates to give feedback using chat or audio. 

     Remember to check your camera, microphone, and internet connection 

before you start. 

 
   Best Practices During Virtual Presentations 
 

  Choose a quiet environment with good lighting 

  Test your equipment before starting 

  Speak clearly and at a moderate pace 

  Engage your audience by asking questions 

  Avoid reading from the slides 

  Look at the camera for eye contact 
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          Activity 2.3.3: Conducting a Virtual Presentation Rehearsal 
 

1. Choose a topic for your individual or group presentation. 

2. Prepare your slides and speaker notes. 

3. Conduct a virtual rehearsal on Zoom/Teams/Google Meet: 

o Share your screen 

o Present slides clearly 

o Use speaker notes effectively 

o Interact with your audience 

4. Record your rehearsal (if possible) and replay to assess: 

o Confidence and fluency 

o Slide transition and timing 

o Voice clarity and body language 

 

   Extension Task: Peer Review in Virtual Sessions 

1. In groups, schedule virtual presentation sessions. 

2. Assign roles:  

o Presenter 

o Feedback giver 

o Timekeeper 

3. After each presentation, discuss strengths and areas for improvement. 

 

   Reflection Questions 

• What challenges did you face during your virtual rehearsal? 

• How did the feedback help you improve? 

• How can these skills help you beyond the classroom? 
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Sample Activity of Integration 
 

     Scenario: A tourism company is planning an international marketing campaign 

to attract tourists. They need a professional, visually appealing electronic 

presentation to showcase Uganda’s tourist attractions. 

Task: 

Create a five-slide PowerPoint presentation highlighting Uganda’s top tourist 

destinations, ensuring it includes images, animations, and transitions to engage 

the audience. 
 

Self-Assessment Questions 
 

1. Define electronic presentation software and give two examples. 

2. Explain the difference between slide layouts and slide transitions. 

3. List three best practices for making an effective PowerPoint presentation. 

4. How does multimedia enhance an electronic presentation? Provide an 

example. 

5. Compare Google Slides and Microsoft PowerPoint in terms of functionality. 

6. Explain how a collaborative presentation tool can be used in remote 

meetings. 

 

 

In this topic you have learnt about: 

 Create Electronic Presentations and Use Them to 

Communicate Ideas 

 Format Presentations to Make Them Visually 

Appealing 

 Collaborate, Automate, and Deliver Presentations 

Effectively 

To
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TOPIC COMPUTER HARDWARE 

Key Words 

 Hardware  

 Input Devices 

 Output Devices 

 Processing Unit 

 Storage Devices 

 Peripheral Devices 

Troubleshooting 

The Content of this topic and the activities 

will enable you to; 

a) Classify computer hardware components 

and explain their functions. 

b) Assemble a complete computer system. 

c) Perform routine hardware maintenance 

and troubleshoot common hardware 

problems. 
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Introduction 
 
Every digital task you perform — typing a document, 

browsing the internet, printing a report, or watching a 

video — involves physical parts of a computer working 

together. These parts are called computer hardware. 

Computer hardware refers to all the physical 

components of a computer system that you can touch, 

see, or connect. These include the keyboard, mouse, system unit, monitor, printer, 

speakers, and internal parts such as the processor, memory, and storage devices. 

 

In this topic, you will explore how hardware components work, how to classify 

them, how to assemble a computer system correctly, and how to maintain the 

hardware for safe and efficient use. 

Why Is It Important to Learn About Computer Hardware? 

 

Reason Benefit 

Understand how computers function Helps you troubleshoot and solve 

problems 

Know how to assemble and use hardware 

safely 

Prevents damage and promotes safety 

Build hands-on technical skills Prepares you for ICT-related careers 

Make informed purchasing decisions Helps you choose the right hardware for 

tasks 

Maintain hardware properly Increases device lifespan and 

performance 

      Example: A student in Uganda working on a group project connects a projector, 

mouse, flash drive, and speakers to the school computer to make a presentation. 

Knowing how these hardware components work together makes it easier to deliver 

the task efficiently. 
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Common Real-World Applications of Hardware Knowledge 

Application Area Examples 

School ICT Labs Setting up and maintaining computer systems for learning 

Small Businesses Installing printers, routers, or POS systems 

Repair Shops Diagnosing and replacing faulty components 

Personal Use Setting up a home computer for assignments and internet 

browsing 

 

Figure 30: A labeled diagram of a computer system with all five categories of 

hardware components 

 
Quick Activity: Class Brainstorming 
 

1. In pairs, list all hardware devices you have used or seen in school, at home, 

or in a café. 

2. Identify their roles (input, output, processing, storage, etc.). 

3. Share your findings with the class. 
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Every computer system is made up of different hardware components that perform 

specific functions. To operate efficiently, these components must work together as 

a system — some receive data, others process it, some store it, while others display 

the results. 

 
3.1 Classify Hardware Components and Explain Their Functions 

Hardware can be classified into several categories based on its function, including 

input devices (like keyboards and mice), output devices (like monitors and printers), 

storage devices (like hard drives and SSDs), processing units (like CPUs), and 

memory (like RAM). 

 

Figure 31: Input and Output devices 

      Example: A student working on a science project uses a keyboard (input) to 

type content, CPU (processing) to run the application, hard disk (storage) to save 

the file, and printer (output) to print the report. 

 
3.1.1 Identifying and Labelling Various Hardware Components 
 
Before you can use or assemble a computer system, you need to know the names 

and functions of each physical component. In this section, you will learn how to 

recognize and label different hardware devices, both internal and external, based 

on their appearance and purpose. 

HARDWARE CLASSIFICATION 
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Types of Hardware Components to Identify 
 

Component Type Examples Where Found 

Input Devices Keyboard, Mouse, Scanner, Webcam, 

Microphone 

On/near computer 

desk 

Output Devices Monitor, Printer, Projector, Speakers Connected to the 

system unit 

Storage Devices Hard Disk Drive (HDD), Solid State 

Drive (SSD), Flash Drive, Memory Card 

Inside or plugged into 

the computer 

Processing Devices CPU (Central Processing Unit), 

Motherboard 

Inside the system unit 

Communication 

Devices 

Modem, Router, Network Interface 

Card (NIC) 

Network setup or 

attached to system 

      Example: A student working in the ICT lab observes that the keyboard is used 

to type notes, the monitor displays what is typed, and the USB flash drive stores 

the final document. 

 
Step-by-Step: Identifying and Labelling Hardware 
 

1. Visit the ICT Lab or view sample images of hardware components. 

2. Observe each device and note its physical appearance, location, and port 

connection. 

3. Label each device using printed tags (e.g., Input Device – Keyboard). 

4. Match each component with its function in the system. 

 
          Activity 3.1.1: Hands-On Hardware Identification and Labelling 
 

1. Work in small groups. 

2. Collect real or printed images of hardware components. 

3. Create a hardware classification chart with the following columns: 

Device Name Category Function Where It Is Used 

    

4. Use colored labels or flashcards to tag actual components in the ICT lab. 

5. Present your chart to the class and explain each component’s role. 
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Extension Task: Hardware Scavenger Hunt 
 

1. Your teacher hides labels on different hardware around the classroom/lab. 

2. You search, identify, and place correct device labels in their proper 

positions (e.g., “Input Device: Scanner” on a scanner). 

3. The group that completes labelling correctly and fastest wins. 

 
   Special Note: Internal vs. External Hardware 

Internal Components External Components 

CPU, RAM, Hard Disk, Motherboard Monitor, Keyboard, Mouse, Printer, Flash Drive 

     Internal components are mostly found inside the system unit, while external 

components are visible and connected from the outside. 

 
   Reflection Questions 

• Why is it important to correctly identify each hardware component? 

• Which hardware components are used most in your daily ICT work? 

• What challenges do learners face when identifying internal hardware? 

 
3.1.2 Reflecting on the Importance of Hardware Components 
 

Each hardware component in a computer system plays a unique role. When one 

part fails, the whole system may not work properly. It is therefore important to 

reflect on how these components function together and why they are essential to 

the performance, reliability, and usability of any ICT system. 

Why Is It Important to Understand Hardware Components? 

 
  Helps you operate a computer system confidently 

  Enables you to troubleshoot common hardware problems 

  Guides you in making informed decisions when buying or upgrading 

ICT tools 

  Builds your technical knowledge for real-life applications or ICT careers 

  Promotes safe handling and better maintenance of devices 

      Example: A school computer fails to display content because the monitor 

cable is loose. A learner who understands the importance of the monitor and its 

connection is able to solve the problem quickly without waiting for a technician. 
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Key Reflections on the Importance of Hardware Categories 

Component 

Category 

Why It Matters What Happens Without It 

Input Devices Allow users to enter data You cannot type, scan, or give 

commands 

Output Devices Show/display processed 

results 

You cannot see, print, or hear the 

output 

Storage Devices Keep data and files for 

future use 

No place to save your work or 

retrieve it later 

Processing Devices 

(CPU) 

Perform tasks and run 

programs 

System cannot process data or 

execute commands 

Communication 

Devices 

Send/receive data over 

networks 

No internet access or device-to-

device connection 
 

 
 

          Activity 3.1.2: Group Reflection Exercise 
 

1. In groups, choose one hardware category (e.g., Input Devices). 

2. Discuss:  

o Why that category is important 

o What tasks would not be possible without it 

o How it supports the whole ICT system 

3. Write your reflections on a chart paper or digital slide. 

4. Share your reflections in a class discussion. 

 
Extension Task: "What If It’s Missing?" Role-Play 
 

1. Choose a task (e.g., printing a report). 

2. Role-play a scenario where one hardware component is missing (e.g., 

printer, mouse, CPU). 

3. Discuss:  

o What challenges arise 

o What alternative solutions exist (if any) 

o How this reflects the importance of each part 
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      Example: A learner tries to print a report but realizes the printer is disconnected 

or damaged. The role-play highlights how essential output devices are in 

completing tasks. 

 

 

Figure 32: A group of students seated in pairs, discussing and writing notes on the 

importance of different hardware components. 

 
   Reflection Questions 

• What do you think is the most important hardware component? Why? 

• How do the components in a computer system depend on each other? 

• How can knowledge of hardware components help you solve everyday ICT 

problems? 

 
3.1.3: Classifying Hardware Devices 
 
To fully understand how a computer system works, it’s important to know how 

each hardware device contributes to the overall system. Devices are classified into 

five main categories based on their roles: Input, Output, Storage, Communication, 

and Processing devices. 
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Why Is Classification Important? 

 
  Helps you understand how data moves through a system 

  Makes it easier to troubleshoot problems 

  Guides selection of the right tools for the right task 

  Supports planning for assembling or upgrading a computer system 

      Example: A student types an essay using a keyboard (input), the CPU 

(processing) edits it, the hard disk (storage) saves it, and the printer (output) 

produces a hard copy. 

 
Categories of Hardware Devices and Their Functions 
 

Category Function in the System Examples 

Input Devices Used to enter data and 

instructions 

Keyboard, Mouse, Scanner, 

Microphone, Webcam 

Output Devices Display or present processed 

data 

Monitor, Printer, Projector, 

Speakers 

Storage Devices Store data and files 

permanently or temporarily 

Hard Disk, USB Flash Drive, 

Memory Card, CD/DVD 

Processing Devices Interpret and execute 

instructions 

CPU (Central Processing Unit), 

Motherboard 

Communication 

Devices 

Transmit data between 

systems 

Modem, Network Interface 

Card (NIC), Router 

   Tip: Some modern devices may fall into more than one category. For example, 

a touchscreen is both an input and output device. 

 
Examples of Dual-Function Devices 

Device Input Role Output Role 

Touchscreen Detects finger/stylus input Displays content visually 

Headset (with microphone) Captures voice Plays back sound 

Modem Sends data to network Receives data from internet 
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          Activity 3.1.3: Hardware Classification Challenge 
 

1. In groups, write down at least 10 common ICT hardware devices. 

2. Classify each under:  

o Input 

o Output 

o Storage 

o Communication 

o Processing 

3. Present your classification using a table, chart, or digital slide. 
 

Extension Task: Device Sorting Game 

1. Your teacher provides flashcards with device names. 

2. In teams, sort the cards under correct headings on the board or a manila 

sheet. 

3. Discuss and correct any misclassifications. 

      Example: Sorting Activity where Keyboard → Input, Speaker → Output, Router 

→ Communication, etc. 

 
   Reflection Questions 

• How does classification help in understanding the flow of data in a 

computer? 

• Are there any devices you struggled to classify? Why? 

• Why are communication devices becoming more important in today’s 

world? 
 

3.1.4 Interactive Hardware Classification Game 
 

Learning becomes more fun and effective when done through games and 

interactive activities. In this section, you will play a hands-on classification game to 

reinforce your knowledge of hardware categories—Input, Output, Storage, 

Communication, and Processing devices. 
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      Example: During an ICT Club Activity, learners participate in a “Device Sort 

Challenge” where they group printed hardware flashcards under category labels. 

The fastest team to classify all items correctly wins. 

 
Digital Extension Activity: Online Hardware Classification Quiz 
 

In addition to classroom games, you can use online platforms like Kahoot or 

Quizizz to test your understanding of hardware categories and their functions. 

These platforms allow you to play fun quiz games, compete with classmates, and 

reinforce your knowledge in an interactive way — all from your phone, tablet, or 

computer. 

 
Figure 33: One of Popular Academic Games Platform: Kahoot 

 
How to Access the Online Game 
 

You can play a digital quiz game that helps you match hardware names with their 

correct functions. 

▶ Type this link while connected to the internet in your browser: 

   https://tinyurl.com/2n4t4d9e  

https://tinyurl.com/2n4t4d9e
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Instructions for Playing the Game 
 

1. Type the link above to open the game in your browser. 

2. Click on “Practice” to begin the quiz. 

3. Read each question carefully and select the correct category or function of 

the device shown. 

4. Try to answer as many questions correctly and as fast as possible. 

5. Review your results and try again to improve your score. 

 
Optional: Create Your Own Free Account 
 

      You can also sign up for an account by tapping Sign In at the top right 

corner. 

• Once signed in, you can:  

o Play more hardware quizzes 

o Challenge your classmates 

o Track your progress over time 

o Access other ICT-related quizzes 

 
          Activity: ICT Quiz Contest 
 

1. Divide learners into small groups. 

2. Let each group take turns playing the online quiz. 

3. Record each group’s average score and time. 

4. The group with the highest score in the shortest time wins. 
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3.1.5 Exploring Modern Devices with Multiple Functions  
 

As technology advances, many devices today are designed to perform multiple 

functions rather than just one. These are called multifunctional or hybrid hardware 

devices. They combine roles such as input, output, storage, and communication in 

one device, making them more efficient and user-friendly. 

What Are Multifunctional Devices? 

 

Multifunctional devices are hardware tools that combine two or more functions — 

such as printing, scanning, copying, communication, or input/output — within a 

single unit. 

 
      Example: A multifunction printer (MFP) can print, scan, photocopy, and 

sometimes fax — all in one machine. 

 

Examples of Modern Multifunction Devices 

Device Functions Category 

Touchscreen 

Laptop 

Input (touch), Output 

(display), Processing, Storage 

Input/Output/Processing 

Smartphone Input (keyboard/camera), 

Output (screen/sound), 

Communication, Storage 

Input/Output/Storage/Communication 

Multifunction 

Printer 

Printing, Scanning, Copying, 

Faxing 

Output/Input 
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Tablet with 

Stylus 

Input (writing), Output 

(display), Storage 

Input/Output/Storage 

Smart TV Output (display), Input 

(remote/mic), 

Communication (Wi-Fi), 

Streaming 

Output/Input/Communication 

All-in-One 

Desktop 

Computer 

Processing, Display, Input 

(touch), Storage 

Input/Output/Processing 

   Tip: Smartphones and tablets are the most common multifunctional devices 

in Uganda — used in learning, business, and communication. 

 

Figure 34: Most common multifunctional devices i.e. Smartphones and tablets  

 
Importance of Multifunctional Devices 
 

  Save space and cost (one device replaces many) 

  Improve work efficiency and flexibility 

  Suitable for both personal and professional use 

  Ideal for mobile learning and business on the go 

  Promote digital integration in classrooms, homes, and workplaces 

 

      Example: A businessperson uses a smartphone for communication, scanning 

documents, accessing mobile money, emailing, and storing customer records — 

all in one device. 
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          Activity 3.1.5: Exploring and Classifying Multifunctional Devices 
 

1. In groups, identify at least five multifunctional devices you use at school, 

home, or in the community. 

2. For each device, describe:  

o What functions it performs 

o The categories it belongs to (input, output, communication, etc.) 

3. Present your findings in a table like this: 

Device Functions Input/Output/Storage/Communication? 

Smartphone Call, Browse, Scan, Record 

Audio 

Input, Output, Storage, Communication 

   

4. Share your table with the class and explain the roles of each device. 

 
Extension Task: Future Devices Reflection 

1. Research online or in pairs: What are some emerging multifunctional ICT 

devices? 

2. Discuss how they may impact education, health, agriculture, or business in 

Uganda. 

3. Present your ideas creatively — in a poster, slide, or role-play. 
 

   Reflection Questions 

• Which multifunctional device do you use most often? Why? 

• How do such devices make learning or business easier? 

• What are the advantages and possible disadvantages of using one device 

for many purposes? 
 

 

Figure 35: A showing a tablet is used for drawing (input) and displaying visuals (output) 
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To use a computer effectively, you need to know how to set it up by connecting 

the right components properly. 

 

3.2 Assemble a Computer System and Ensure Correct Connections 
 

Assembling a computer system involves arranging and linking the input, output, 

processing, storage, and communication devices to ensure they work together as 

one system. 

Importance of Computer System Assembly Skills 
 

  Promotes confidence in ICT handling 

  Prepares you for careers in ICT support and maintenance 

  Enables better troubleshooting and safe handling of devices 

  Helps you understand how components work together in a system 

 
Main Components Required to Assemble a Computer System 

Component Function 

System Unit Houses internal parts like CPU, RAM, Hard Drive 

Monitor Displays visual output 

Keyboard Inputs text and commands 

Mouse Navigates the screen 

Power Cables Supply power to components 

Printer Outputs hard copies 

Speakers Produce sound output 

Network Cables / Router Enable internet connectivity 

   Tip: Always ensure power is off before connecting or disconnecting hardware. 

 
3.2.1 Connecting External Hardware Components 
 
Step-by-Step: Connecting External Hardware Components 

1. Place the system unit, monitor, keyboard, and mouse on a desk. 

2. Connect the monitor cable (VGA/HDMI) to the system unit. 

3. Plug the keyboard and mouse into USB or PS/2 ports. 

HANDS -ON-ASSEMBLY 



106 

 

4. Connect speakers/headphones to the audio port. 

5. Plug in the power cables to both the system unit and monitor. 

6. Turn on the main socket power supply. 

7. Press the power button on the system unit and monitor. 

8. Check if all devices are working properly (e.g., keyboard lights, monitor 

display). 

 

 

Figure 36: A computer workstation showing properly connected external devices 

 
          Activity 3.2.1: Connecting External Hardware Devices 
 
1. In pairs, assemble a complete desktop computer system in your school ICT 

lab. 

2. Ensure all external components are connected properly. 

3. Power on and test whether all devices respond correctly. 
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4. Complete a checklist for each device (Connected? Working? Lights on?). 

 
3.2.2 Virtual Computer Assembly Using Simulation Software 
 
You can now learn to assemble a computer virtually using simulation tools before 

working with real components. These tools provide step-by-step guidance and 

help you understand how hardware components are connected. 

Table 3: Popular Computer Assembly Simulation Tools 

Software Features 

PC Building Simulator Let’s you virtually assemble and repair computers 

Cisco Packet Tracer Simulates hardware connections and networking 

Build Your Own PC Online Web-based interactive PC assembly learning tool 

 
Figure 37: PC Building Simulator showing virtual hardware setup 

      Example: ICT students at Makerere University use PC Building Simulator to 

practice installing RAM, processors, and graphics cards before handling real 

computers. 
 

          Activity 3.2.2: Simulated Computer Assembly 
 
1. Use simulation software like PC Building Simulator, Cisco Packet Tracer, or 

online tools. 

2. Follow the step-by-step guide to assemble a virtual computer. 
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3. Verify that you have correctly placed components and troubleshoot 

connection errors. 

Students can also explore websites such as Corsair.com to research real hardware 

components, understand compatibility, and access step-by-step PC building 

tutorials. Although it is not a simulation tool, it offers useful interactive guides 

and product education to support practical learning. 
 

3.2.3 Connecting and Installing Internal Components 
 
To make a computer function, you must correctly install components inside the 

system unit. This section teaches you how to safely handle and install these internal 

parts. 

Internal Component **Function Connection 

CPU Processes instructions Mounted on motherboard 

RAM Temporary data storage Slotted into RAM sockets 

Hard Disk / SSD Permanent file storage Connected via SATA/Power cables 

Power Supply Unit Distributes power Connects to motherboard and drives 

Motherboard Main circuit board Connects all internal parts 

   Note: Handling internal components should be done carefully and under 

supervision, using anti-static precautions (e.g., wrist strap or grounded surface). 

      Example: A technician in installs a new SSD to improve a laptop’s boot speed and 

storage capacity. 
 

          Activity 3.2.3: Hands-On Internal Component Installation 
 
1. In small groups, observe or dismantle an old system unit under teacher 

supervision. 

2. Identify and label internal parts (CPU, RAM, HDD, Power Unit). 

3. Record the purpose and location of each part. 

4. Draw and label a diagram of the internal computer system. 
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Figure 38: Internal components of a computer 

 
3.2.4 Using System Diagnostic Tools to Verify Component Functionality 
 
After assembling a computer system, it is important to verify that all hardware 

components are working correctly. You can do this by using system diagnostic 

tools, which help identify hardware status, performance, and possible errors in 

devices like RAM, hard disk, processor, or network components. 

In this section, you will learn how to use basic diagnostic tools available in 

operating systems such as Task Manager, System Information, and other third-

party software to check the functionality of each component. 

What Are System Diagnostic Tools? 
 

System diagnostic tools are software utilities that help you:  

  Monitor hardware performance 

  Check system specifications 

  Detect errors or malfunctions 

  Ensure all components are functioning correctly 

 

      Example: A student connects a printer to the computer but it does not respond. 

Using Device Manager, the learner discovers the printer driver was not installed 

properly. 
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Common System Diagnostic Tools and Their Purpose 
 

Tool Function How to Access (Windows) 

Task Manager View real-time performance 

(CPU, RAM, Disk, Network) 

Ctrl + Shift + Esc or right-click 

taskbar → Task Manager 

System Information 

(msinfo32) 

View detailed specs of all 

hardware components 

Start → Search “System 

Information” 

Device Manager Check status of each device, 

update drivers 

Start → Search “Device 

Manager” 

Disk Check Tool 

(CHKDSK) 

Check for errors on hard drives Command Prompt → chkdsk 

Resource Monitor Track component usage (CPU, 

memory, disk) 

Start → Search “Resource 

Monitor” 

Third-party 

diagnostic tools 

Offer more advanced features Examples: Speccy, HWiNFO, 

CPU-Z 

 
Step-by-Step: Checking Component Functionality Using Task Manager 
 

1. Press Ctrl + Shift + Esc to open Task Manager. 

2. Click the Performance tab. 

3. View CPU, Memory (RAM), Disk, and Network usage. 

4. Confirm if components are functioning and responding. 

     Tip: High usage or “Not Responding” warnings may indicate a problem. 

 
Step-by-Step: Using Device Manager 
 

1. Press Windows Key + X → Device Manager. 

2. Check device categories (Disk Drives, Display Adapters, Network Adapters, 

etc.). 

3. A yellow triangle (!) symbol shows if a device has a problem. 

4. Right-click a device → Update driver or Check properties for 

troubleshooting. 
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          Activity 3.2.4: Verifying Component Functionality Using Diagnostic Tools 
 

1. On your computer, open Task Manager and Device Manager. 

2. Record the current status of: 

o CPU 

o RAM 

o Hard Disk 

o Display Adapter 

o Network Adapter 

3. Use System Information tool to note: 

o Processor type 

o Installed RAM 

o BIOS version 

o Storage capacity 

4. Present your findings in a summary table: 

Component Tool Used Status Notes 

CPU Task Manager Normal Usage ~20% 

RAM Task Manager Normal 3.5 GB in use 

 
Extension Task: Compare Diagnostic Tool Reports 
 

1. Use Task Manager and System Information on two different computers. 

2. Compare their specifications and performance. 

3. Discuss:  

o Which system is faster? 

o What hardware differences explain this? 

 
   Reflection Questions 

• How can diagnostic tools help in identifying faulty hardware? 

• Why should you check component functionality after system assembly? 

• What are the advantages of using third-party diagnostic software? 
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Figure 39: Task Manager interface displaying CPU and RAM usage graphs 

 
3.3 Demonstrate Safe Handling of Computer Hardware and 

Perform Routine Maintenance for Optimal Performance 
 

Just like any other equipment, computer hardware needs to be handled safely and 

maintained regularly to work effectively and last longer. Improper handling can 

damage components, while neglecting maintenance can reduce system 

performance. 

In this section, you will learn how to handle hardware safely, carry out routine 

cleaning and maintenance, and troubleshoot basic issues to ensure optimal 

performance and long hardware lifespan. 

Importance of Safe Handling and Maintenance 
 

  Prevents physical damage and accidents 

  Ensures computers perform efficiently 

  Increases the lifespan of ICT devices 

  Reduces repair and replacement costs 

  Promotes health and safety in ICT environments 

      Example: A school technician in Uganda cleans dust from desktop fans and 

replaces worn-out cables regularly to avoid overheating and short-circuits. 
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   Quick Brainstorming Task 

1. What practices can damage computer hardware? 

2. What routine activities can keep hardware working smoothly? 

      Examples: pulling out USB devices forcefully, leaving dust in system units, 

spilling water on the keyboard, ignoring loose cables, etc. 

 
3.3.1 Safe Handling of Hardware Components 
 

Computer hardware is delicate and sensitive, especially internal components like 

the CPU, RAM, and motherboard. Mishandling these components during setup, 

use, or maintenance can lead to serious damage or safety hazards. You must 

therefore apply safe handling techniques to protect both the device and yourself. 
 

      Example: A computer technician in uses anti-static gloves when installing a new 

RAM module in a laptop to avoid damaging it with static electricity. 
 

  Safe Handling Techniques (External Components) 

Component Safe Handling Technique 

Keyboard/Mouse Avoid pulling cables; store neatly when not in use 

Monitor Carry with both hands; do not press the screen 

Printers Place on a stable surface; follow proper power-down procedures 

Flash Drives Eject safely before removing; avoid bending or exposing to water 

Headphones Store in cases; avoid twisting cables 

 

   Safe Handling Techniques (Internal Components) 

Component Safe Handling Technique 

CPU Handle by edges; do not touch pins or apply pressure 

RAM Chips Insert gently into slots; avoid bending 

Motherboard Hold from corners; do not scratch or flex 

Hard Disk Drive (HDD/SSD) Avoid dropping; do not shake or tilt during use 

Power Supply Unit Disconnect from power before touching; avoid moisture 

   Tip: Always power off and unplug devices before handling internal 

components. 
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   Tools for Safe Handling 

Tool Purpose 

Anti-static wrist strap Prevents damage from static electricity 

Anti-static mat Provides safe surface for working with components 

Screwdriver set For opening/closing system unit safely 

Brush and soft cloth For cleaning without scratching surfaces 

 

Figure 40: A technician wearing an anti-static wristband while installing RAM 

inside a desktop system 

 
          Activity 3.3.1: Demonstrating Safe Handling Techniques 
 
1. In small groups, choose one external or internal component. 

2. Demonstrate how to:  

o Safely carry it 

o Connect/disconnect it properly 

o Store it after use 

3. Record your demonstration in steps and present to the class. 

 
   Extension Task: Poster Design – “Safe ICT Handling Tips” 

1. Design a visual poster or digital slide showing do’s and don’ts of hardware 

handling. 

2. Include icons or images for better clarity. 

3. Display your poster in your school’s ICT room. 
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   Reflection Questions 

• Why is static electricity dangerous to computer components? 

• How can poor handling reduce the lifespan of devices? 

• What personal safety measures should you always follow in the ICT lab? 

 
3.3.2 Safety Measures When Assembling or Maintaining a Computer 
 
Assembling or maintaining a computer system involves working with delicate 

components and electric connections. If not done carefully, it can lead to hardware 

damage, electric shocks, or accidents. Following proper safety measures ensures 

that you protect yourself, the hardware, and the environment around you. 

Why Are Safety Measures Important? 
 

  Prevents physical injury (e.g., electric shock, cuts, burns) 

  Avoids permanent damage to hardware components 

  Reduces chances of data loss or component failure 

  Promotes professionalism and good lab practice 

      Example: A student in an ICT practical session forgot to switch off the power 

supply before opening the system unit, resulting in a small electric spark. Another 

student who followed the correct procedure avoided any hazard. 

 
General Safety Measures to Observe 

Safety Measure Explanation 

Power off all devices Always unplug computers before opening the case or 

connecting components 

Work in a clean, dry, well-lit 

space 

Prevents dust build-up, slipping hazards, or accidents 

Avoid liquids near equipment Prevents short circuits and corrosion 

Use proper tools (e.g., 

screwdriver, brush) 

Ensures you don’t damage components during 

assembly 

Wear an anti-static wrist strap Prevents damage from electrostatic discharge (ESD) 

Handle components by the 

edges 

Avoids touching pins or circuits that can be damaged 

by oils or static 

Avoid force when connecting 

parts 

Each part should fit smoothly; forcing may break 

delicate components 
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Special Precautions When Maintaining Internal Hardware 
 

  Ensure you discharge static electricity by touching grounded metal before 

touching internal parts 

  Label or document all cables and connectors before removing them 

  Never open the power supply unit — it holds charge even when unplugged 

  Use a soft brush or compressed air to remove dust — never use water or 

liquid cleaners inside the computer 

 
          Activity 3.3.2: Discussing and Implementing Safety Measures 
 

1. In pairs, list 10 safety measures to observe during:  

o Assembling a new computer 

o Opening the system unit for cleaning 

2. Use a Safety Checklist Table like the one below: 

Step Safety Measure Observed Yes/No Remarks 

Turned off power before 

disassembly 

  Yes Safe 

Used correct tools   No Used bare 

hands 

3. Compare your checklist with other groups and discuss any differences. 

 
Extension Task: Role-Play “Safe vs Unsafe Assembly” 
 

1. Prepare a short role-play with two students:  

o One demonstrates unsafe practices (e.g., handling RAM with bare 

hands, rushing connections). 

o The other demonstrates correct, safe practices. 

2. The class identifies mistakes and recommends correct steps. 

3. Discuss how small errors can lead to bigger damage or injury. 
 

   Classroom Poster Task: “Assembling ICT Devices Safely” 

1. Design a poster or digital slide with illustrated safety tips. 

2. Include slogans such as:  

o "Power Off Before You Plug In!" 

o "Static Kills – Wear a Strap!" 

o "Handle with Care – Your Future Depends on It" 
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   Reflection Questions 

• What safety steps must always be done before opening a computer? 

• What could happen if you use the wrong tools or apply too much force? 

• How do safe practices improve your learning experience in the ICT lab? 

 
 

Sometimes, computer hardware components may stop working, respond slowly, 

or show unusual behavior. These issues can be caused by loose connections, dust, 

power problems, or damaged parts. Learning how to identify and resolve 

hardware-related issues is an essential skill for maintaining ICT systems and 

ensuring uninterrupted learning or work. 
 

3.3.3 Troubleshooting and Resolving Hardware Issues 

What Is Hardware Troubleshooting? 
 

Troubleshooting is the process of identifying problems and finding solutions to 

restore proper functioning of a computer system. 

      Example: A computer in a school lab suddenly goes blank. A student follows 

the correct troubleshooting steps—checks the power supply, reconnects the 

monitor cable, and confirms the monitor is faulty—not the CPU. 

 
Common Hardware Problems and Their Likely Causes 

Problem Possible Cause Basic Solution 

Computer not turning on Power cable is loose or faulty Check and reconnect 

cable 

Mouse or keyboard not 

responding 

USB port issue or cable 

damage 

Try another port or 

replace device 

Monitor is blank Monitor cable unplugged or 

faulty 

Reconnect cable or test 

another monitor 

Printer not printing No paper, paper jam, driver 

issue 

Refill paper or reinstall 

printer driver 

Flash drive not detected Faulty port or damaged drive Try another port/device 

Strange noises from CPU Dust in fan or hard drive 

failing 

Clean fan or seek 

technical help 
 

HARDWARE TROUBLESHOOTING AND MAINTENANCE 
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Step-by-Step Troubleshooting Procedure 
 

1. Observe the problem – What symptoms do you see or hear? 

2. Identify the affected component – Is it input, output, storage, etc.? 

3. Check power supply and connections – Start with simple checks. 

4. Test the component on another system – Is the problem with the device or 

computer? 

5. Use diagnostic tools (e.g., Device Manager) – Check status and driver 

issues. 

6. Apply appropriate solution – Reconnect, clean, reset, or replace. 

7. Document your findings – Keep a record of the problem and how you 

solved it. 

 

Figure 41: A User Refixing the Internal Hard disk 

 
          Activity 3.3.3: Hands-On Hardware Troubleshooting Practice 
 

1. In pairs, simulate a hardware fault (e.g., unplug a mouse or monitor). 

2. Exchange computers and ask another pair to identify and fix the problem. 

3. Use a troubleshooting log to record the process: 

Step Action Taken Observation Result 

1 Checked mouse cable It was unplugged Reconnected and it worked 

4. Share your findings with the class and explain how you resolved the issue. 
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   Extension Task: Diagnostic Role-Play 

1. One learner acts as a "client with a problem" (e.g., “My screen is not 

displaying anything”). 

2. Another acts as a "hardware technician" following troubleshooting steps. 

3. The class observes and evaluates:  

o Problem-solving approach 

o Communication and explanation 

o Final resolution 
 

Quick Tips for Efficient Troubleshooting 

  Start with simple checks (power, cables, ports) 

  Work systematically – one step at a time 

  Use known working devices to test ports or components 

  Avoid guesswork – always observe and record 

  Know when to escalate to a technician (e.g., motherboard failure) 

 

   Reflection Questions 

• What steps do you follow first when a device fails to respond? 

• How do you decide whether to repair or replace a component? 

• What skills did you build during the troubleshooting Activity? 

 
3.3.4 Cleaning and Maintaining Internal and External Hardware 
 

Like any machine, a computer requires regular cleaning and care to remain in good 

condition. Dust, dirt, heat, and improper storage can reduce performance or even 

damage hardware. Regular maintenance ensures that ICT equipment remains 

efficient, safe, and long-lasting. 

In this section, you will learn how to clean and maintain both internal and external 

computer hardware components, using safe and effective methods. 

Why Cleaning and Maintenance Are Important 
 

  Prevents dust-related overheating and damage 

  Improves system performance and airflow 

  Increases the lifespan of hardware components 
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  Reduces risk of system failures or accidents 

  Saves on repair or replacement costs 

      Example: A school technician noticed that several computers were overheating 

and shutting down. After opening the system units, he found dust blocking the 

fans. Cleaning the units improved performance. 
 

Components That Need Regular Cleaning 
 

Component Type How to Clean It 

Monitor External Wipe gently with a soft microfiber cloth 

Keyboard External Blow dust with compressed air or brush between 

keys 

Mouse External Clean bottom sensor and surface with dry cloth 

System Unit (outer 

case) 

External Wipe with dry cloth; clean ventilation holes 

CPU fan and Heat Sink Internal Blow out dust using compressed air (under 

supervision) 

Motherboard Internal Light brush or air blowing; avoid touching sensitive 

parts 

Power Supply Unit Internal Blow air through vents; never open casing 

Hard Drive, RAM, 

Cables 

Internal Avoid touching; clean surroundings and ports only 

   Tip: Never use water, wet cloths, or spray liquids directly on any computer 

part. 

 
Tools for Cleaning Computer Components 
 

Tool Purpose 

Soft dry cloth Wipe screens and external cases 

Antistatic brush Remove dust from internal parts 

Compressed air can Blow dust from keyboards, fans, and ports 

Small hand vacuum Remove dust particles (external only) 

Screwdriver set Open system units safely for internal cleaning 
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   Maintenance Practices for Long-Term Performance 

  Keep the computer area clean and dust-free 

  Do not eat or drink near ICT equipment 

  Ensure proper ventilation for cooling 

  Shut down computers properly after use 

  Store devices safely when not in use 

  Update antivirus software and drivers regularly 

  Use power surge protectors or Uninterruptible Power Supply (UPS) 

 
          Activity 3.3.4: Cleaning and Maintenance Practical Task 
 

1. In small groups, choose a computer system for cleaning. 

2. Use soft cloths and brushes to clean: 

o Monitor 

o Keyboard and mouse 

o System unit vents 

3. With teacher supervision, open the system unit and: 

o Blow dust using compressed air 

o Brush gently around fan and motherboard 

4. Record your process in a Maintenance Log Sheet: 

Component Cleaned Tools Used Action Taken Remarks 

Keyboard Soft brush Removed dust 

between keys 

Improved 

responsiveness 

 

   Extension Task: Create a Maintenance Schedule 

1. Design a Monthly Maintenance Plan for your school’s ICT lab. 

2. Include cleaning tasks, tool checklist, responsible persons, and dates. 

3. Display it on the ICT lab notice board or keep it as a digital record. 
 

   Reflection Questions 

• What problems can occur if computers are not cleaned regularly? 

• What precautions should you take when cleaning internal hardware? 

• How does good maintenance improve your learning experience in the ICT 

lab? 
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Figure 42: blowing dust off computers using a blower 

 

 

Sample Activity of Integration 
 

     Scenario: A newly established computer training center receives 20 brand-new 

desktop computers. The administrator wants to set up, maintain, and troubleshoot 

hardware issues but lacks technical knowledge. 

Task: 

Prepare a user guide detailing how to assemble a desktop computer, troubleshoot 

common hardware issues, and maintain computer peripherals.  
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Self-Assessment Questions 

 
1. Identify four components found in a brand-new desktop computer package 

and explain their functions.  

2. What is the difference between volatile and non-volatile memory? 

3. List three common startup issues and describe how to troubleshoot them. 

4. Explain the role of a power supply unit (PSU) in a desktop computer. 

5. Describe the importance of regular hardware maintenance in a computer 

lab. 

6. How does overheating affect computer performance, and how can it be 

prevented? 

 

 
 

 

 

 

 

 

 

In this topic you have learnt about how to: 

 Classify computer hardware components and explain 

their functions. 

 Assemble a complete computer system. 

 Perform routine hardware maintenance and 

troubleshoot common hardware problems. 

To
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Senior Five – Term Two 
 

 

 

TOPIC COMPUTER SOFTWARE 

Key Words 

 Software  

 Operating System 

 Utility software 

 Installation 

 Driver 

 Malware 

Virtual Machine 

The Content of this topic and the activities 

will enable you to; 

a) evaluate software options based on user 

requirements and system capabilities. 

b) install operating systems and software 

applications for optimal performance. 

c) troubleshoot common software problems 

and implement effective solutions. 
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Introduction 
 
While hardware refers to the physical parts of a computer, it cannot function on its 

own. To perform meaningful tasks like typing, drawing, playing music, or browsing 

the internet, a computer needs instructions — this is where software comes in. 

Computer software refers to the programs and instructions that guide hardware 

on what to do. It acts as the invisible brain behind every task done on a computer 

or digital device. 

In this topic, you will explore different types of software, how to choose the right 

software based on user needs, how to install and configure software, and how to 

troubleshoot software-related problems. 

 

Why Is It Important to Learn About Software? 
 

  Helps you understand how digital tools work 

  Enables you to select the right software for different tasks 

  Builds your ability to install, configure, and update software 

  Supports critical thinking and decision-making in ICT use 

  Prepares you for personal, academic, and workplace digital tasks 

 

      Example: A student preparing a history assignment needs a word processor, a 

browser for research, and antivirus software to keep the computer secure — all of 

which are types of software working with hardware. 
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Real-Life Application of Software Knowledge 

Context Software Involved Example Task 

School ICT 

Lab 

Office suite, internet browser, 

antivirus 

Writing assignments, research, 

computer security 

Business Accounting software, 

database tools 

Managing finances, recording sales 

Healthcare Patient management system Updating records and scheduling 

appointments 

Government e-Government portals, email Service delivery and communication 

 

   Quick Class Activity: What Software Do You Use? 

1. In pairs, list at least five software applications you use or have seen others 

using (at school, home, or in business). 

2. Identify the task each software is used for. 

3. Discuss:  

o Which software do you use most often? 

o Why is it important for that task? 

 
4.1 Evaluate Software Options Based on User Requirements and 

System Capabilities 
 
Not all software is suitable for every user. Choosing the right software depends on 

the task to be done, the user’s needs, and the capability of the device it will run on. 

Some software may require more memory or a faster processor, while others may 

only work on a particular operating system. 

      Example: A small printing business in Kampala needs desktop publishing 

software. The owner compares Microsoft Publisher, Canva, and Adobe InDesign, 

considering cost, ease of use, internet needs, and computer speed. 

 
4.1.1 Exploring Different Software and Their Purposes 
 

Software is generally grouped into three main types, each with a different purpose in 

helping your computer function efficiently. 
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Software Type Purpose Examples 

System Software Runs the computer and manages 

hardware 

Windows, Linux, macOS 

Application Software Performs specific tasks MS Word, Excel, Zoom, 

VLC 

Utility Software Enhances performance and security Antivirus, Disk Cleanup 

Programming 

Software 

Helps developers write code Python, Java, Visual 

Studio 

 

Factors to Consider When Choosing Software 

Factor Explanation Example 

User 

Requirements 

What task must the software 

perform? 

A student needs typing software 

for assignments 

System 

Capabilities 

Can the computer handle the 

software? 

A low-RAM laptop may not 

support heavy video editing 

tools 

Cost Is the software free, paid, or 

subscription-based? 

MS Office vs. LibreOffice 

Ease of Use Is the software beginner-

friendly? 

Canva vs. Adobe InDesign 

Compatibility Can it run on the available OS 

and hardware? 

Some software runs only on 

Windows or macOS 

Support & 

Updates 

Does the software offer regular 

updates or customer support? 

Software with updates is more 

secure 
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          Activity 4.1.1: Software Evaluation Table 
 

1. In groups, choose a real-life task such as: 

o Typing and formatting a report 

o Making a poster 

o Managing business sales 

o Watching educational videos 

2. Research three software options for the chosen task. 

3. Complete a table like this: 

Software Task Suitability Hardware 

Requirements 

Cost Ease of 

Use 

Final 

Choice 

MS Word Excellent for 

typing 

Low specs needed Paid Easy   

Google 

Docs 

Good for online 

use 

Internet required Free Very easy    

4. Present your group’s choice and explain your decision. 

 
Extension Task: Role Play – Software Selection Consultation 

1. One learner acts as a user (e.g., teacher, farmer, shopkeeper) who wants 

software for a task. 

2. Another learner acts as an ICT advisor recommending software options. 

3. The “advisor” must:  

o Ask the user’s requirements 

o Evaluate system capability 

o Recommend the best software 

o Justify the choice 

      Example: A farmer needs a mobile app to record daily milk production. The 

advisor compares Excel, KoboCollect, and an agriculture record-keeping app. 
 

   Best Practices When Evaluating Software 

  Match software to the user’s exact task 

  Always check computer specifications before installing 

  Try free trial versions before buying 

  Choose software with community or technical support 

  Consider long-term affordability and licensing 
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   Reflection Questions 

• What software do you use most often and why? 

• What problems can occur if you choose the wrong software? 

• How can you support others in choosing appropriate software? 

 
4.1.2 Analyzing User Requirements and Comparing Software Options 
 
Before choosing any software, it is important to understand what the user needs 

and whether the available software can meet those needs. This process involves 

analyzing the user's goals, the tasks to be performed, and then comparing different 

software options based on features, performance, and suitability. 

Why Analyze User Requirements? 
 

  Helps you recommend the most suitable software 

  Prevents system failures and frustrations caused by incompatible software 

  Supports cost-effective decision-making 

  Improves user satisfaction and productivity 

      Example: A headteacher wants a system to manage student records. The ICT 

teacher must compare MS Access, Google Sheets, and school management 

software, considering cost, complexity, internet access, and storage. 

 

Key Questions to Ask When Analyzing User Requirements 

Question Why It’s Important 

What task does the user want to perform? To identify the right software category 

How often will the software be used? Determines the need for advanced 

features 

What is the user’s level of ICT knowledge? To ensure ease of use 

What is the available budget? To select free or affordable options 

What device and operating system is 

available? 

To check software compatibility 

Is internet access reliable? Some software works best online 
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How to Compare Software Options: When comparing software, consider: 

Criteria Explanation 

Features Does it support all required functions? 

Cost Is it free, one-time payment, or subscription? 

System Requirements Will it run smoothly on the user’s device? 

User Interface Is it user-friendly and easy to learn? 

Support & Documentation Are there tutorials or help tools? 

Security Is the software secure and regularly updated? 

 
          Activity 4.1.2: Comparing Software Options Based on User Needs 
 

1. In pairs, select one of these user scenarios: 

o A teacher wants to create lesson notes and tests. 

o A business owner wants to manage sales and expenses. 

o A student wants to design a class magazine. 

2. Identify at least three software options for the task. 

3. Analyze user needs and complete the following comparison table: 

User 

Requirement 

Software 

1 

Software 

2 

Software 3 Best Option (Why?) 

Easy to use ✔✔ ✔ ✔✔✔ Software 3 – Very user-

friendly 

Offline access ✔ ✘ ✔ Software 1 – Works without 

internet 

Affordable ✘ – Paid ✔ – Free ✔ – Free 

trial 

Software 2 – Budget-

friendly 

4. Share your group’s decision with the class and explain the reasoning. 

 

Extension Task: Software Comparison Report 

1. Choose a real user in your school or community (e.g., librarian, head of club, 

shop owner). 

2. Interview them to understand their ICT needs. 
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3. Prepare a short report recommending the most suitable software. 

4. Include reasons for your choice and a comparison table. 

 
   Reflection Questions 

• What are the most important things to consider when choosing software for 

someone else? 

• Have you ever used software that didn’t meet your needs? What was the 

experience like? 

• Why is user analysis important before recommending a digital solution? 

 
4.1.3 Assessing Software Performance and Compatibility 
 
Even after choosing software based on user requirements, it is important to assess 

whether that software performs well and is compatible with the available hardware 

and operating system. If software is too heavy for the computer or doesn’t support 

the operating system, it can cause slow performance, crashes, or even system 

failure. 

What Is Software Performance? 
 

Software performance refers to how well the software runs on a computer system. 

Good performance means the software:  

  Loads quickly 

  Runs smoothly without freezing 

  Responds quickly to commands 

  Uses system resources efficiently 

      Example: A school installs a video editing application, but it freezes often on 

low-RAM computers. The software performs well on newer systems with higher 

specifications. 

 

What Is Software Compatibility? 

Software compatibility means that the software can:  

  Run on the computer’s operating system 

  Work well with other software already installed 

  Match the hardware specifications of the system 

If software is not compatible, it may fail to install, work slowly, or crash frequently. 
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Key Factors to Consider in Software Performance Assessment 

Factor Explanation 

Loading Time How fast does the software open and run tasks? 

Responsiveness How quickly does it respond to user commands? 

Resource Usage How much CPU, RAM, or storage space does it consume? 

Error or Crash Frequency Does the software freeze or close unexpectedly? 

Update Efficiency Does it update easily without creating errors? 

 

How to Check Software Compatibility 

Aspect What to Check 

Operating System Windows, macOS, Linux, Android, etc. 

Processor Type & 

Speed 

Minimum GHz requirement for software 

Available RAM Some software requires 4GB, 8GB, or more 

Disk Space Ensure there's enough storage for installation 

Graphics Requirements Video editing and games may need high-end graphics 

cards 

   Tip: Always read "System Requirements" before installing software. 

 
          Activity 4.1.3: Software Performance Assessment Practice 
 

1. Select two different software programs (e.g., MS Word and Canva). 

2. Open both on your computer and perform basic tasks like typing, 

formatting, inserting images. 

3. Use Task Manager (Ctrl + Shift + Esc) to observe: 

o CPU Usage 

o RAM Usage 

o Loading speed 

4. Fill in a performance observation table: 

Software Loading 

Time 

RAM 

Usage 

CPU 

Usage 

Response 

Speed 

Comments 

MS 

Word 

Fast Low Low Very 

responsive 

Good for low-spec 

PCs 

5. Discuss: Which software performed better? Why? 
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   Extension Task: Compatibility Report 

1. Choose any software used in your school (e.g., MS Excel, VLC, Zoom). 

2. Assess its compatibility with the school computers: 

o Does it install and run smoothly? 

o Are there frequent errors or crashes? 

o Are system requirements met? 

3. Prepare a short report on software performance and compatibility 

including suggestions for improvements or upgrades. 

 

   Reflection Questions 

• Why is it important to check system requirements before installing 

software? 

• How can poor performance affect users’ experience? 

• What can be done if software is useful but not compatible with the current 

system? 

 

 

Figure 43: A student using Task Manager to observe resource usage of installed 

software. 
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4.1.4 Role-Playing as IT Consultants and Clients 
 
In real-life ICT environments, IT professionals (consultants) often help clients 

(individuals or organizations) choose the right software to meet their needs. To 

build your communication and problem-solving skills, you can practice this 

through role-playing activities, where one learner acts as the client and another as 

the IT consultant. 

      Example: A learner acts as a client running a community library and wants to 

digitize records. Another learner acts as an IT consultant, recommending free 

database software such as LibreOffice Base or MS Access, based on the client’s 

system and budget. 

 
Steps in the Role-Play Process 
 

1. Client explains their needs: 

o The task they want to perform 

o Their device and available budget 

o Experience with ICT tools 

2. Consultant asks probing questions: 

o How many users will use the software? 

o Do you need offline or online access? 

o What is your level of ICT skills? 

3. Consultant recommends software options: 

o Provide at least two software options 

o Explain why the recommended software is suitable 

4. Client asks questions or raises concerns 

o The consultant responds and justifies choices 

 

   Sample Scenarios for Role-Play Practice 

Client Scenario Suggested Software Options 

A teacher wants to create and organize lesson plans MS Word, Google Docs 

A small shop owner wants to record sales and 

expenses 

Excel, QuickBooks, Google 

Sheets 
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A health center wants to manage patient records MS Access, LibreOffice Base 

A school wants to design a newsletter MS Publisher, Canva 

A youth club wants to present a project proposal PowerPoint, Google Slides 

 
          Activity 4.1.4: IT Consultant–Client Role Play 
 

1. In pairs, one learner acts as Client, the other as IT Consultant. 

2. The client presents a realistic ICT need (e.g., “I want to track student 

attendance” or “I need software for my photography business”). 

3. The consultant: 

o Analyzes the requirements 

o Suggests at least two software options 

o Compares features, performance, cost, and compatibility 

o Recommends one and justifies the choice 

4. Switch roles and repeat the Activity. 

Extension Task: Create a Consultant Report 

1. After role-play, each "consultant" writes a short report: 

o Summary of client needs 

o Software options considered 

o Final recommendation with justification 

2. Submit and present the report in class. 

 

   Reflection Questions 

• What skills did you use most in the consultant role? 

• What challenges did you face analyzing client needs? 

• How can this Activity help you in a real-life ICT job or business? 

 
4.1.5 Discussing Critical Software for Different Scenarios 
 
Different users require different types of software depending on their needs, roles, 

and environments. Some software is considered critical or essential because it is 

central to performing daily tasks in education, business, healthcare, agriculture, and 

other sectors. 
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What Is Critical Software? 

 
Critical software refers to programs that are necessary to complete specific tasks 

efficiently and effectively. Without these, users may not be able to meet their goals 

or perform their duties. 

      Example: A school cannot type, store, or print exam papers without a word 

processor like Microsoft Word or Google Docs. 

 
Factors That Make Software Critical 

  It performs a core task 

  It is used frequently or daily 

  There is no effective alternative available 

  It supports productivity, safety, or service delivery 

 

Examples of Critical Software in Different Sectors 

Scenario / User Role Critical Software Why It Is Essential 

Teacher preparing notes 

and tests 

Microsoft Word, Google 

Docs 

For typing, editing, and 

printing materials 

Student creating a project 

presentation 

PowerPoint, Google Slides For organizing and 

presenting ideas visually 

School bursar recording 

financial data 

Excel, QuickBooks For calculations and 

financial record-keeping 

Graphic designer working 

on posters 

Canva, CorelDRAW, Adobe 

Illustrator 

For digital design and 

layout 

Medical records officer at a 

health center 

MS Access, LibreOffice 

Base 

For managing patient 

records securely 

Shopkeeper tracking daily 

sales 

Excel, SalesPoint, Point of 

Sale (POS) software 

For recording and 

reporting sales and 

expenses 

Government officer writing 

reports 

Microsoft Word, PDF 

readers 

For drafting formal 

documents and reports 

Youth entrepreneur 

promoting a product online 

Canva, Social Media 

Management Tools 

For content creation and 

advertising 
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          Activity 4.1.5: Software Selection Based on Scenarios 
 

1. In small groups, each group picks a real-life scenario from a list:  

o A teacher, student, farmer, shopkeeper, nurse, etc. 

2. Discuss the most critical software tools the person would need in that 

scenario. 

3. Create a table like this: 

Scenario Task Critical 

Software 

Justification 

Secondary School 

Teacher 

Preparing lesson 

plans 

MS Word Widely used, flexible, easy 

to print 

Retail Shop Sales tracking Excel Easy to use, supports 

calculations 

4. Present your table to the class. 

 
Extension Task: Real-Life Software Interview 
 

1. Interview someone in your school or community (e.g., teacher, secretary, 

businessperson). 

2. Ask:  

o What software do they use every day? 

o Why is it important to them? 

o What challenges do they face with it? 

3. Present your findings in a summary report or short presentation. 

 
Best Practices When Selecting Critical Software 

  Choose tools that are reliable and user-friendly 

  Ensure software is compatible with the user’s device 

  Prioritize affordable and accessible tools 

  Offer training or support if the user is unfamiliar with the tool 

 
   Reflection Questions 

• What software do you consider most critical in your daily life? Why? 

• How can choosing the right software improve productivity? 

• What problems could happen if a user lacks critical software? 
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4.2 Install Operating Systems and Software Applications for 

Optimal Performance 
 

For a computer to work properly, it must have the right software installed, 

especially the Operating System (OS) and application software. Installing software 

correctly ensures the system runs smoothly and performs its tasks effectively. 

Why Software Installation Skills Are Important 
 

  Helps users set up new computers or update old ones 

  Ensures software functions well without errors 

  Prepares learners for technical support roles 

  Builds confidence in maintaining ICT tools independently 

  Prevents problems caused by incompatible or incorrect installations 

      Example: A learner installs Windows 10 and Microsoft Office 2019 on a new 

school computer, ensuring it meets the minimum system requirements to avoid 

lagging or crashing. 

 
4.2.1 Analyzing Hardware Specifications for Suitable Software 
 
Before installing any software — especially operating systems or heavy 

applications — it is important to check if your computer has the necessary 

hardware capacity. Software that is too demanding for your system can cause 

slowness, freezing, or even failure to install. 

In this section, you will learn how to analyze a computer’s hardware specifications 

(such as RAM, processor speed, hard drive size, and graphics support) and use this 

information to determine whether it is suitable for a particular software application. 

 

Why Analyze Hardware Specifications? 

  Ensures software compatibility with the device 

  Prevents performance issues like freezing or lagging 

  Helps select software based on system strength 

  Enables smart decision-making when upgrading hardware or software 

      Example: A school receives laptops with only 2GB RAM and installs a heavy 

video editing tool. The system becomes too slow. A better choice would have been 

lighter applications like Windows Movie Maker or Canva. 
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Key Hardware Specifications to Check 

Specification What It Refers To Why It Matters 

RAM (Memory) Temporary storage used while 

software runs 

Affects speed and multitasking 

ability 

Processor Speed 

(CPU) 

The speed of instruction 

execution (GHz) 

Determines how fast software 

runs 

Hard Disk Size Storage capacity (in GB or TB) Determines how much 

data/software can be stored 

Graphics Card Handles visual display and 

media rendering 

Required for games, video 

editing, animations 

Operating 

System 

Platform where software runs 

(e.g., Windows, Linux) 

Software must match the OS 

version 

Ports and 

Connectivity 

USB, HDMI, Bluetooth, Wi-Fi, 

etc. 

Some software depends on 

device connectivity 

   Tip: Always check the Minimum and Recommended Requirements listed by 

the software developer. 

 

Figure 44: A computer screen showing system specifications 

 
How to Check Hardware Specifications in Windows 
 

1. Right-click "This PC" or "My Computer" → Click Properties  

o View installed RAM, processor, and OS version 

2. Press Windows + R → type “dxdiag” → Enter  

o Shows details about graphics, display, and sound 
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3. Use Task Manager → Performance Tab  

o View live usage of CPU, Memory, and Disk 
 

          Activity 4.2.1: Hardware and Software Matching Exercise 
 

1. Open System Properties on your computer and record these specs: 

o RAM 

o Processor type and speed 

o System type (32-bit or 64-bit) 

o Storage space available 

2. Choose three different software applications (e.g., MS Office, Zoom, 

Photoshop). 

3. Create a table to compare compatibility: 

Software Minimum Requirement 

(RAM/CPU) 

Available System 

Specs 

Compatible? 

(Yes/No) 

MS Office 2GB RAM, 1GHz CPU 4GB RAM, 2.3GHz 

CPU 

  Yes 

Photoshop 8GB RAM, 2GHz CPU 4GB RAM, 2.3GHz 

CPU 

✘ No – Needs more 

RAM 

4. Present your group findings to the class. 

 
   Extension Task: Software Recommendation Based on System Specs 

1. Your teacher gives you a system profile (e.g., 2GB RAM, 1.6GHz processor, 

128GB HDD). 

2. You analyze it and recommend: 

o Which software is suitable 

o Which software may not work well 

o What can be upgraded to support better software 

3. Share your software recommendations in a short report or presentation. 

 

Best Practices When Analyzing Hardware for Software Installation 

  Always match software requirements to system capacity 

  Avoid overloading low-spec machines with heavy programs 

  Upgrade RAM or storage if needed 

  Use lighter software alternatives when working with older systems 
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   Reflection Questions 

• What happens when you install software that is too heavy for your system? 

• Why is it important to compare actual system specs with software 

requirements? 

• What software tools or commands help you check system specifications? 

 
4.2.2 Installing an Operating System and Software Application 
 
Once your computer meets the requirements, you can go ahead with installation. 

Installing software correctly is a critical skill for anyone using or managing ICT tools. 

Before you can use any computer, you must install the Operating System (OS) that 

controls the hardware, and then install the application software for performing tasks 

such as typing, browsing, designing, or calculations. 

Why Is Software Installation Important? 

 

  Ensures the computer is usable 

  Allows customization based on user needs 

  Helps upgrade or repair existing systems 

  Enables access to the latest features and updates 

  Prepares learners for real-world ICT support roles 

      Example: A school in Uganda receives five new desktop computers without 

software. Learners are tasked with installing Windows 10 and Microsoft Office 

2016, enabling teachers to use the machines for lesson planning. 

 
Types of Installation Methods 
 

Method Description Example 

From Bootable Disk/USB Used to install the operating 

system 

Installing Windows 10 

from USB 

From CD/DVD Common for offline 

application software 

MS Office, antivirus 

software 

From Downloaded Setup File 

(.exe/.msi) 

Used for most modern 

applications 

Google Chrome, VLC, 

Zoom 

Online/Web Installation Installs directly from internet Google Docs Add-ons, 

Canva 
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Step-by-Step: Installing an Operating System (e.g., Windows 10) 
 

1. Insert the installation USB or DVD. 

2. Restart the computer and boot from USB/DVD. 

3. Select Language, Keyboard, and Time settings. 

4. Click “Install Now”. 

5. Choose the Drive/Partition where Windows will be installed. 

6. Wait for installation to complete. 

7. Set up username, password, and system preferences. 

8. Install device drivers and updates. 

   Tip: Always back up files before a fresh OS installation. 

 
Step-by-Step: Installing an Application Software (e.g., MS Office or VLC Media 

Player) 
 

1. Locate the setup file (e.g., setup.exe or installer.msi). 

2. Double-click to start the installer. 

3. Accept the license agreement. 

4. Choose installation type (Custom or Default). 

5. Select installation folder/location. 

6. Click “Install” and wait for process to complete. 

7. Restart your computer if required. 

   Tip: Always check minimum system requirements before installation. 

 

Post-Installation Configuration Tasks 

  Check if the software opens correctly 

  Create desktop shortcuts 

  Set up default file formats and folders 

  Perform initial software updates 

  Activate the software (if required) 
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Figure 45: Using a bootable USB drive to install Windows 

 
          Activity 4.2.2: Software Installation Practice 
 

1. In small groups, install a sample software application (e.g., VLC, Chrome, or 

MS Word). 

2. Follow the installation steps carefully. 

3. Document your process using a log table: 

Step Action Observation Result 

1 Launched installer Installation wizard opened Successful start 

2 Accepted terms Progress bar started Installation in progress 

 

Extension Task: Guided OS Installation Demonstration 

1. Watch a teacher-led or video-guided Windows/Linux installation demo. 

2. Record: 

o Each step taken 

o What went wrong (if any) 

o How issues were resolved 

3. Create a simplified guidebook or poster titled: "How to Install Windows 10" 

and display it in the ICT lab. 
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   Safety and Best Practices 

  Use genuine and licensed software only 

  Do not interrupt installation process 

  Ensure power supply is stable (use UPS if available) 

  Avoid installing too many unnecessary programs 

  Scan installation files for malware 

 
   Reflection Questions 

• Why is it important to install an operating system before application 

software? 

• What challenges can occur during software installation? 

• How can you ensure software is installed successfully and securely? 
 

4.2.3 Configuring Software Settings for Optimization 
 
After installing software, it is important to configure the settings to suit the user’s 

needs and to improve the performance and usability of the computer system. 

Proper configuration ensures that the software runs efficiently, saves time, and 

enhances the user experience. 

What Is Software Configuration? 
 

Software configuration means adjusting the settings or preferences of an 

application or operating system to improve performance, appearance, or 

functionality. 

      Example: After installing Microsoft Word, a student changes the default font to 

Calibri, sets the page size to A4, and enables auto-save every 5 minutes for better 

productivity and document safety. 

 
Why Is Configuration Important? 
 

  Improves software efficiency 

  Enhances user productivity and comfort 

  Prevents errors and data loss 

  Optimizes resource usage 

  Customizes software for specific tasks 
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Common Software Settings to Configure 

Software Setting Purpose Example 

Default Save Location Organize where files are 

saved 

Set default folder for Word 

documents 

Auto-Save/Backup 

Options 

Prevent data loss Enable autosave every 5 

minutes 

Font and Theme 

Preferences 

Improve appearance and 

readability 

Set font size, color scheme 

File Format Settings Ensure compatibility Save Word files as .docx or .pdf 

Language and Region 

Settings 

Localize software Set language to English 

(Uganda) 

Notification and Update 

Settings 

Control when updates or 

alerts appear 

Disable popup alerts during 

lessons 

Performance Options Adjust speed and visual 

effects 

Reduce visual animations to 

increase speed 

   Tip: For application software like MS Word, VLC, or browsers, most settings 

are found under Options, Preferences, or Settings Menu. 

 
Step-by-Step Example: Configuring MS Word Settings 
 

1. Open MS Word → Click File → Options 

2. Set:  

o Default font style and size (e.g., Calibri, 12pt) 

o Auto-save interval (e.g., every 5 minutes) 

o Default file location (e.g., Desktop or Documents) 

o Preferred view (e.g., Print Layout) 

   You can also add or remove toolbars, adjust language, and 

personalize the user interface. 
 

          Activity 4.2.3: Software Settings Optimization 
 

1. Open any software on your computer (MS Word, VLC, Chrome). 

2. Explore the settings/preferences. 

3. Change the following:  

o Font size or appearance 

o Save location, Auto-save or backup settings 
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o Language or regional settings 

4. Record the changes in this table: 

Software Setting Changed Original Value New Value Purpose of Change 

MS Word Auto-save time 10 mins 5 mins Prevent data loss 

 
Extension Task: System Performance Optimization 
 

1. Open Control Panel or System Settings. 

2. Adjust settings such as: 

o Power Options (Balanced/High Performance) 

o Visual Effects (Disable animations for speed) 

o Startup Programs (Disable unnecessary apps) 

3. Restart and compare system performance before and after optimization. 
 

   Best Practices for Configuration 

  Customize settings based on user needs 

  Use auto-save and backups to protect data 

  Reduce visual effects to improve speed on low-spec machines 

  Organize default folders for easy file management 

  Enable updates to keep software secure 

 
 

   Reflection Questions 

• What software settings have you changed before, and why? 

• How does configuring software settings improve your ICT experience? 

• What problems can happen if default settings are not changed? 
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4.3 Troubleshoot Common Software Problems and Implement Effective 
Solutions 
 
Even after installing and configuring software, problems can still occur during 

everyday use. These issues may include slow performance, freezing, software 

crashes, compatibility errors, or failed updates. Being able to identify, troubleshoot, 

and resolve such software problems is an essential ICT skill. 

In this section, you will learn how to diagnose common software problems, use 

troubleshooting tools, and apply effective solutions to ensure smooth operation 

of your system. 

 

      Example: A student opens Microsoft Word and it crashes repeatedly. By 

troubleshooting, they discover the file is corrupted or the system lacks memory. 

They repair the file and close background apps to fix the issue. 

 
4.3.1 Identifying and Resolving Common Software Issues 
 
In any ICT environment — school, business, or home — software problems are 

common. These can include slow loading, crashing applications, freezing screens, 

or unresponsive programs. Knowing how to identify the cause of the problem and 

fix it systematically is an essential skill in ensuring uninterrupted ICT use. 

 

Common Software Problems and Causes 

Problem Possible Cause Solution 

Software not 

opening 

Corrupted installation or 

missing files 

Reinstall or repair software 

System freezing or 

slow 

Too many background apps, 

low RAM 

Close apps, restart system, 

upgrade RAM 

Incompatible 

software 

Software does not match OS 

version 

Install compatible version 

Crashing or errors Bugs or outdated software Update software or patch files 

Update failure No internet or firewall block Check connection, adjust 

settings 

Application not 

responding 

System overload or software 

bug 

End task and restart 

application 
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Step-by-Step Software Troubleshooting Procedure 
 

1. Identify the problem – What is the error or behavior? 

2. Check recent changes – Any updates, new installations, or system changes? 

3. Restart the computer or software – Often fixes temporary issues. 

4. Check Task Manager (Ctrl + Shift + Esc) – End unresponsive programs. 

5. Look for error messages – Note error codes or pop-ups. 

6. Use troubleshooting tools – E.g., Event Viewer, Disk Cleanup, Antivirus. 

7. Reinstall or update the software – Fix corrupted or outdated files. 

8. Scan system for viruses or malware – May interfere with software. 
 

Tools for Troubleshooting Software Problems 
 

Tool Function 

Task Manager View running applications and end 

unresponsive tasks 

Disk Cleanup Free up space and improve system speed 

System Restore Undo recent changes that caused issues 

Control Panel → Programs & Features Repair or uninstall software 

Event Viewer Check error logs for software crashes 

Antivirus Software Scan and remove malware affecting software 

Windows Troubleshooter Built-in help tool for common issues 

 
          Activity 4.3.1: Troubleshooting Practice Task 
 

1. Simulate a software issue (e.g., install a buggy program or open multiple 

applications to slow down a system). 

2. In pairs, identify the problem and use troubleshooting tools to fix it. 

3. Record your findings in a troubleshooting log: 

Problem Tool Used Action Taken Outcome 

VLC not opening Control Panel Reinstalled software VLC working again 

 

Extension Task: Case Study Review 

1. Your teacher gives you a real or fictional case:  

o “A teacher’s PowerPoint freezes when inserting images.” 
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2. In groups:  

o Identify possible causes 

o Suggest multiple solutions 

o Create a report with steps followed to resolve the issue 

 
   Best Practices for Troubleshooting 

  Don’t panic—follow a logical step-by-step process 

  Document the issue and what was done 

  Always try simple solutions first (restart, close apps) 

  Use reputable software versions and updates 

  Consult user manuals, support forums, or a technician if needed 

 
   Reflection Questions 

• Have you ever experienced a software problem? How did you solve it? 

• Why is it important to know how to troubleshoot software? 

• What are the risks of applying random solutions without identifying the 

real problem? 

 
4.3.2 Exploring Diagnostic Tools for Software Troubleshooting 
 
When software problems occur, you can use diagnostic tools to help detect what 

went wrong and identify the best solution. These tools help you understand system 

performance, application errors, software crashes, and potential compatibility 

issues. 

What Are Diagnostic Tools? 
 

Diagnostic tools are built-in or third-party software utilities that help you monitor 

system behavior, track software errors, and suggest solutions to restore system 

stability. 

 

      Example: A learner uses Task Manager to check if an application is consuming 

too much memory, which is causing system slowdown. Another uses Event Viewer 

to investigate why an application keeps crashing. 
 
 
 
 



150 

 

 
   Common Diagnostic Tools and Their Functions 

Tool Purpose How to Access (Windows) 

Task Manager Monitor running programs and 

system performance 

Ctrl + Shift + Esc or right-

click taskbar 

Event Viewer View logs of software errors and 

warnings 

Start → Search “Event Viewer” 

Resource 

Monitor 

Analyze detailed CPU, memory, 

disk, and network usage 

Start → Search “Resource 

Monitor” 

Reliability 

Monitor 

See history of software failures Start → Search “Reliability 

Monitor” 

System File 

Checker (SFC) 

Scan and repair corrupted system 

files 

Run Command Prompt as 

Admin → sfc /scannow 

Check Disk 

(CHKDSK) 

Scan and fix disk-related errors Run Command Prompt → 

chkdsk 

Third-party tools Advanced performance and 

diagnostic reports 

Speccy, CCleaner, HWiNFO 

 
Step-by-Step: Using Task Manager for Diagnostics 
 

1. Press Ctrl + Shift + Esc to open Task Manager 

2. Click the Performance tab  

o Check CPU, Memory, Disk, and Network usage 

3. Click Processes tab  

o Identify apps consuming too many resources 

4. Right-click unresponsive software → End Task 

 

Figure 46: Event Viewer to analyze software error logs 
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Step-by-Step: Using Event Viewer 
 

1. Click Start → Search “Event Viewer” 

2. Navigate to Windows Logs → Application 

3. Look for Error or Warning events related to software 

4. Click to view details and search for solutions using error code 

   Tip: Event Viewer helps identify recurring software issues and their causes. 

 
          Activity 4.3.2: Hands-On Diagnostic Tool Exploration 
 

1. In small groups, open Task Manager and Event Viewer on a computer. 

2. Perform the following:  

o Monitor CPU and memory usage while running different apps 

o Check for recent application errors in Event Viewer 

3. Record findings in a table: 

Tool Used Observation Problem Detected Action Taken 

Task 

Manager 

RAM usage 

high 

Too many programs 

open 

Closed background 

apps 

 

Extension Task: Simulation Case Study 

1. Your teacher provides a simulated software error case (e.g., "Excel crashing 

repeatedly"). 

2. Use diagnostic tools to:  

o Investigate causes 

o Suggest solutions 

o Prepare a Diagnostic Report 

Example Diagnostic Report: 

• Problem: Excel crashes when opening files 

• Tool Used: Event Viewer 

• Cause: Add-in conflict 

• Solution: Disabled faulty add-in, Excel works well 
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   Best Practices When Using Diagnostic Tools 

  Combine multiple tools to cross-check problems 

  Always close apps you are not using to reduce system load 

  Interpret logs and error codes before jumping to conclusions 

  Apply changes only after confirming root cause 

  Keep a record of all issues and how they were resolved 

 
   Reflection Questions 

• Which diagnostic tool did you find most useful and why? 

• How do these tools improve software troubleshooting? 

• What challenges did you face while using diagnostic tools? 

 
4.3.3 Analyzing Real-World Software Case Studies 
 
One of the best ways to learn troubleshooting skills is by analyzing real-life 

situations where software problems have occurred. Through case studies, learners 

can practice problem identification, diagnosis, and solution implementation — just 

like ICT professionals do in workplaces, schools, and businesses. 

      Example: A school's antivirus software expired, exposing all computers to 

malware. The ICT teacher guides learners in analyzing the situation, identifying the 

cause, and recommending a new software solution with automated updates. 

 

Common Real-World Software Problem Scenarios 

Case Study Scenario Likely Problem Possible Solution 

School computers freeze 

during startup 

Too many programs 

starting automatically 

Disable unnecessary 

startup apps 

A cashier’s Excel file fails 

to open 

File corruption Use Open and Repair 

feature in MS Excel 

MS Word crashes when 

printing 

Printer driver conflict Reinstall printer driver or 

update MS Word 

Zoom disconnects during 

lessons 

Network lag or old version Check internet, update 

Zoom 

Browser too slow to load 

websites 

Clogged cache and 

extensions 

Clear browser cache and 

disable add-ons 
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Figure 47: Window Crashing 

 
 

Step-by-Step Case Analysis Approach 
 

1. Read the case carefully – Understand the scenario clearly 

2. Identify the main problem – What is not working? 

3. Analyze possible causes – Check user actions, system configuration, 

environment 

4. Suggest multiple solutions – Based on system tools or user knowledge 

5. Select the most practical solution – Consider cost, ease of use, and 

sustainability 

6. Document lessons learned – Write a summary of the analysis and findings 
 

          Activity 4.3.3: Case Study Group Discussions 
 

1. Your teacher provides case study cards (real or fictional). 

2. In groups:  

o Identify the software problem 

o Analyze causes and system factors 

o Suggest and record at least two solutions 

o Present your findings to the class 
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   Sample Case:  

"A teacher tries to type a test in MS Word, but the software keeps crashing 

whenever images are added." 

Step Finding 

Problem MS Word crashing with images 

Likely Cause Low RAM or incompatible image format 

Solutions Resize images or upgrade RAM 

Best Option Resize images to reduce load 

 

Extension Task: Write Your Own Case Study 

1. Think of a real ICT problem you experienced at school or at home. 

2. Write a short case study including: 

o Background 

o Problem 

o Cause 

o Troubleshooting steps 

o Solution applied 

o Result 

3. Exchange case studies with a partner and suggest alternative solutions. 

 

   Best Practices When Solving Case Study Problems 

  Always start with basic checks before advanced troubleshooting 

  Think logically and record each step 

  Avoid assumptions — test your diagnosis 

  Reflect on how each problem can be prevented in future 

  Practice documenting every solution applied 
 

   Reflection Questions 

• What did you learn from analyzing a real-life software problem? 

• Why is it helpful to explore multiple solutions? 

• How can such activities prepare you for ICT-related careers? 
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4.3.4 IT Technician–Client Role-Playing for Software Troubleshooting 
 
In real-life ICT work environments, users (clients) often face software issues they 

cannot solve on their own. They rely on IT support technicians to help diagnose 

and fix problems. Through role-playing, learners can develop skills in problem 

identification, effective communication, and software troubleshooting — just like 

in real-world ICT support situations. 

      Example: A teacher complains that PowerPoint won’t open on their computer. 

A learner acting as an IT technician asks questions, checks settings, and finds out 

the software needs an update. 

 
Roles in the Activity  

Role Responsibility 

Client Describe the problem clearly and answer technician’s questions 

IT Technician Ask relevant questions, analyze the issue, apply 

troubleshooting steps, and explain solutions 

Observer (optional) Evaluate the interaction and provide feedback 

 
Sample Client Scenarios for Role-Play 
 

Scenario Possible Problem Expected Action by Technician 

“I can’t install Zoom” Incompatible OS or 

blocked by antivirus 

Check system requirements or 

disable antivirus temporarily 

“My documents won’t 

save in MS Word” 

Wrong save location or 

permissions 

Change folder settings 

“My laptop is very slow 

when using Excel” 

Too many background 

apps or low RAM 

Close apps or advise upgrading 

RAM 

“Antivirus keeps 

showing pop-ups” 

Notifications enabled or 

malware threat 

Adjust settings or scan system 

“Browser crashes when 

watching videos” 

Corrupted browser 

cache 

Clear cache and reinstall browser 

 
          Activity 4.3.4: IT Technician–Client Role-Play Practice 
 

1. Form pairs or small groups. 

2. Select one of the scenarios above (or teacher provides more). 

3. One learner plays the client, the other plays the technician. 
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4. Conduct a 5–7-minute role-play, where: 

o The client explains the problem 

o The technician asks questions, investigates, and suggests solutions 

o The client confirms whether the solution worked 

5. Switch roles and repeat with a different scenario. 

   Suggested Tool: Use a checklist or role-play script template for consistency. 

 
Extension Task: Evaluation and Feedback Form 
 

Each pair evaluates each other using a checklist like this: 

Criteria Yes/No Comments 

Technician asked correct diagnostic 

questions 

  Asked about software version 

Technician applied logical 

troubleshooting steps 

  Used Task Manager and Event 

Viewer 

Communication was clear and respectful   Explained in simple terms 

Groups present a summary of their interaction, highlighting the problem and 

solution applied. 

 
   Best Practices in ICT Support Role-Play 

  Always remain polite and patient with users 

  Ask questions step by step 

  Explain solutions in simple language 

  Focus on root cause analysis — not just surface solutions 

  Encourage users to follow good ICT habits 

 
   Reflection Questions 

• How did you feel playing the role of an IT technician? 

• What skills did you use to help your client? 

• What lessons can you apply in real-life ICT support situations? 

 
4.3.5 Presenting Software Installation and Troubleshooting Experiences 
 
After learning how to install software and troubleshoot common problems, it is 

important to present and reflect on what you have learned and done. Sharing your 

experiences helps you deepen understanding, gain confidence, and learn from 

others’ challenges and solutions. 
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      Example: A student presents how they installed VLC Media Player, encountered 

an installation error, and resolved it by updating system drivers. The class discusses 

what could be done differently next time. 

 
Figure 48: Service Registration Missing Report: After Windows Update 

 
What to Include in Your Presentation 
 

Component Details to Share 

Task Overview What software did you install or troubleshoot? 

Steps Followed Describe each step in the process clearly 

Challenges Faced Any issues during installation or configuration 

Tools Used Task Manager, Event Viewer, Antivirus, etc. 

Solution Applied What actions resolved the problem 

Lesson Learned What skills or tips you gained from the experience 
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          Activity 4.3.5: Presenting ICT Experience Report 
 

1. In pairs or small groups, prepare a short experience report presentation. 

2. Include: 

o The software installed or troubleshooted 

o The steps followed (installation, configuration, troubleshooting) 

o Challenges encountered and how you solved them 

o Tools used during troubleshooting 

o Recommendations or lessons learned 

3. Present your report to the class using: 

o PowerPoint slides 

o Poster/chart 

o Oral explanation with demonstration (if possible) 
 

Extension Task: Software Skills Portfolio 

1. Create a digital ICT Portfolio folder. 

2. Include:  

o Completed activities (logs, screenshots, presentations) 

o Installation guides or step-by-step checklists you used 

o Diagnostic reports from troubleshooting practice 

3. Share your portfolio with your teacher for review and grading. 

 
   Best Practices When Presenting ICT Experiences 

  Be clear, step-by-step, and organized 

  Use visuals or examples to explain better 

  Share both successes and challenges 

  Encourage feedback and learn from your peers 

  Reflect on how you would do better next time 

 
   Reflection Questions 

• What was the most challenging part of your installation or troubleshooting 

experience? 

• What skills did you improve through this experience? 

• How can you use this experience in your future learning or career? 



159 

 

 

Sample Activity of Integration 
 

     Scenario: A high school ICT lab has outdated software and unlicensed 

applications, making it difficult for students to complete assignments efficiently. 

Task: 

As an ICT student, prepare a proposal for the school administration, detailing the 

importance of using updated, licensed software and recommending appropriate 

system, application, and utility software for the school.  

 
Self-Assessment Questions 

 
1. Differentiate between system software and application software. 

2. Identify three examples of utility software and explain their functions. 

3. Why is it important to use licensed software instead of pirated versions? 

4. Explain the role of an operating system in a computer. 

5. What are the advantages of using cloud-based applications over desktop 

applications? 

6. Compare the use of proprietary software vs. open-source software with 

examples. 

 

 

In this topic you have learnt about: 

 evaluate software options based on user requirements 

and system capabilities. 

 install operating systems and software applications for 

optimal performance. 

 troubleshoot common software problems and 

implement effective solutions. 
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Senior Five – Term Three 
 

 

 

TOPIC ELECTRONIC WORD 

PROCESSING 

Key Words 

 Word Processor  

 Mail Merge 

 Ribbon 

 Indentation 

 Spell Checker 

 Page Layout 

 Grammar Check 

The Content of this topic and the activities 

will enable you to; 

a) format and edit a Word document. 

b) apply document objects to enhance a 

Word document. 

c) use document referencing features. 
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Introduction 

In today’s digital world, the ability to create, format, and 

manage documents electronically is essential in both 

personal and professional life. Word processing software 

allows users to type, edit, organize, and present written 

information clearly and professionally. 

Electronic word processing refers to the use of computer software to create and 

format text-based documents, such as letters, reports, memos, newsletters, and 

application forms. Tools like Microsoft Word, Google Docs, and LibreOffice Writer 

help users improve document quality, readability, and presentation. 

This topic equips you with practical skills to use word processing applications for 

creating professional documents, inserting objects, applying advanced formatting, 

and collaborating on documents online. Mastering these skills will enhance 

productivity in education, business, and personal projects. 

 

Why is Word Processing Software Important? 
 

  Education: Used for writing assignments, research papers, and lesson plans. 

  Business: Essential for creating business proposals, contracts, and reports. 

  Government and Administration: Used in official documentation and 

correspondence. 

  Publishing and Marketing: Helps in designing newsletters, brochures, and 

advertisements. 

 

5.1 Format and Edit a Word Document 
 
Creating a document is just the first step—formatting and editing make it 

professional, easy to read, and visually appealing. Formatting refers to how the text 

and elements in the document look, while editing involves modifying content to 

improve clarity, accuracy, and structure. 

In this section, you will learn how to create, format, and edit a text document using 

word processing software, such as Microsoft Word, Google Docs, or LibreOffice 

Writer. 
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Why Formatting and Editing Skills Are Important 

  Improve document presentation and readability 

  Ensure clarity and professionalism 

  Correct spelling and grammar errors 

  Make documents easier to print, share, or publish 

  Prepare learners for academic and workplace documentation tasks 

      Example: A student preparing an assignment uses formatting features like bold 

headings, bullet points, and justified alignment to make the work organized and 

reader-friendly. 

Key Formatting and Editing Features in Word Processing Software 

Feature Purpose Example 

Font type and size Set the appearance and 

readability of text 

Calibri 12pt for body text 

Text alignment Position text on the page Justify for neat 

paragraphs 

Line and paragraph 

spacing 

Adjust space between 

lines/paragraphs 

1.5 spacing for school 

assignments 

Bold, italics, underline Emphasize key words or 

phrases 

Bold headings 

Bullet points and 

numbering 

Organize lists and steps Shopping list or steps in a 

process 

Text color and 

highlight 

Improve emphasis and visibility Highlight key points 

Spell check and 

grammar tools 

Correct errors Identify spelling mistakes 

instantly 

 

Step-by-Step: Formatting a Document in Microsoft Word 
 

1. Open a new or existing document 

2. Select the text you want to format 

3. Use the Home tab to apply:  

o Font style and size 
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o Bold, Italics, Underline 

o Bullets or numbering 

o Text color or highlight 

4. Use the Paragraph group to adjust:  

o Alignment (Left, Center, Right, Justify) 

o Line spacing (e.g., 1.5 or Double) 

5. Use Styles to apply consistent formatting for headings and titles 

6. Use Spelling and Grammar Check to review errors 

 
          Activity 5.1: Formatting a School Document 
 

1. Open Microsoft Word. 

2. Type the following sample heading and paragraph: 

Importance of Education 

Education empowers individuals to contribute positively to society. It enhances 

skills, promotes innovation, and reduces poverty. 

3. Apply the following formatting: 

o Heading: Bold, 16pt, Center-aligned 

o Body text: Calibri 12pt, Justified, Line spacing 1.5 

o Highlight the word innovation 

4. Save your document as “Formatted Document.docx” 

 

Extension Task: Peer Document Editing Challenge 

1. Exchange your document with a classmate. 

2. Review and suggest edits: spelling, grammar, formatting consistency. 

3. Make improvements based on peer feedback and resubmit. 

 

   Best Practices in Document Formatting and Editing 

  Use headings and subheadings to organize ideas 

  Avoid using too many fonts and colors 

  Check spelling and grammar before printing or sharing 

  Keep paragraphs short and readable 

  Save and back up your work regularly 
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   Reflection Questions 

• How does formatting affect the way people understand a document? 

• What editing tools do you use most when working on documents? 

• Why is consistent formatting important in professional writing? 

 
5.1.1 Exploring Word Processing Software 
 
Before you can start formatting and editing documents, you need to understand 

what word processing software is and how it works. Word processors are used to 

create, edit, format, and print text-based documents in a digital environment. They 

provide tools to improve the appearance, structure, and readability of your work. 

In this section, you will explore different word processing software, compare their 

features, and practice creating a simple document using one of them. 

 
What Is Word Processing Software? 
 

Word processing software is a computer application used to type, format, edit, and 

print text documents such as letters, assignments, reports, and notices. 

 

Figure 49: A screenshot of Microsoft Word’s ribbon toolbar 
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      Example: A school administrator uses Microsoft Word to write circulars, print 

staff lists, and prepare report templates. 

 
Commonly Used Word Processing Software 

Software Features Best Use Scenarios 

Microsoft 

Word 

Offline use, wide formatting tools, 

templates, mail merge 

Schools, businesses, 

offices 

Google Docs Cloud-based, real-time collaboration, 

auto-save 

Group projects, online 

editing 

LibreOffice 

Writer 

Free and open-source, basic formatting 

tools 

Budget-friendly 

institutions 

WPS Office 

Writer 

Free with basic features, PDF support Personal and school 

use 

   Tip: Most word processors allow you to create tables, insert images, and 

export to PDF format. 

 

Key Features of Word Processing Software 

  Typing and editing text 

  Formatting fonts, spacing, margins 

  Adding bullet points and numbered lists 

  Inserting tables, images, and charts 

  Saving and exporting documents in various formats 

  Using spell check and grammar correction tools 

  Applying styles and templates 

 
Step-by-Step: Creating a New Document in Microsoft Word 
 

1. Open Microsoft Word from the start menu or desktop icon 

2. Click “Blank Document” 

3. Type your content (e.g., “My First Document”) 

4. Use the Home tab to apply formatting (font, size, bold, bullets) 

5. Click File → Save As 

6. Choose a location and file name, then click Save 
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          Activity 5.1.1: Getting Started with Word Processing 
 

1. Open Microsoft Word or Google Docs 

2. Create a short document titled “My Profile”  

o Include your name, class, hobbies, and career goals 

3. Apply the following formatting:  

o Font: Calibri, Size: 12 

o Heading: Bold and Centered 

o Use a numbered list for hobbies 

4. Save the document in both .docx and .pdf formats 

 
Extension Task: Software Comparison Table 

1. In pairs, research two different word processing software options 

2. Complete the following table: 

Software 

Name 

Offline or 

Online 

Key Features Strengths Limitations 

MS Word Offline Mail Merge, 

Templates 

Professional 

layout 

Paid software 

Google Docs Online Real-time editing Free, 

collaborative 

Needs 

internet 

Present your findings in class. 

 
Best Practices When Using Word Processors 

  Save your work frequently 

  Use readable fonts and consistent formatting 

  Explore menus and tools to learn new features 

  Keep your documents organized in folders 

  Use help tools or tutorials when stuck 

 
   Reflection Questions 

• What word processor do you prefer and why? 

• What are the key differences between offline and online word processors? 

• How can you use word processing software beyond the classroom? 
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5.1.2 Understanding Key Features in Word Processing Software 
 
To use word processing software effectively, you need to understand its main 

features and tools. These features help you create documents that are not only 

informative but also well-organized, visually appealing, and professionally 

formatted. 

      Example: A student typing a report uses font formatting, bullet points, and 

page layout tools to improve the structure and flow of their work. 

 

 

Key Features of Word Processing Software 

Feature Category Description and Purpose Examples 

Text Formatting 

Tools 

Change the appearance 

of text 

Font type, size, bold, italics, underline, 

highlight 

Paragraph 

Formatting Tools 

Control spacing, 

alignment, and 

indentation 

Left/Center/Right/Justify alignment, 

line spacing 

Page Layout 

Tools 

Set the structure of the 

document 

Margins, page orientation 

(portrait/landscape), paper size 

Lists and 

Numbering 

Organize content in 

points or steps 

Bullets, Numbered lists, Multilevel 

lists 

Insert Tools Add different objects into 

the document 

Tables, Images, Charts, Symbols 

Review Tools Improve writing quality 

and accuracy 

Spell Check, Grammar Check, Word 

Count 

Styles and 

Templates 

Apply consistent design 

to documents 

Heading styles, Predefined templates 

Save and Export 

Options 

Store and share 

documents in various 

formats 

Save as .docx, .pdf, export or print 
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Step-by-Step: Applying Common Word Processing Features 
 

1. Open Microsoft Word or Google Docs 

2. Type a short paragraph 

3. Apply the following:  

o Font: Arial, Size 12, Bold title 

o Text alignment: Justify 

o Insert a bullet list of at least 3 points 

o Set line spacing to 1.5 

o Use Spell Check to correct errors 

 
          Activity 5.1.2: Feature Application Practice 
 

1. Create a sample document titled “My Dream Career” 

2. Include: 

o A paragraph introduction 

o A bullet list of required skills 

o A table showing different career options and expected qualifications 

3. Apply formatting features: 

o Bold heading 

o Justify text 

o 1.5 line spacing 

o Add a page border (if available) 

 
Extension Task: Feature Matching Exercise 

1. Your teacher provides a list of formatting tasks (e.g., change font size, 

insert a table). 

2. In pairs, match each task to the correct tool or menu option in your word 

processor. 

3. Demonstrate each task practically on your computer. 

Task Tool/Feature Used Menu Location 

Change text color Font color Home tab 

Insert a picture Insert Picture Insert tab 
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   Best Practices When Using Word Processing Features 

  Choose simple, readable fonts 

  Use consistent formatting styles across the document 

  Organize content using headings, bullets, and spacing 

  Explore help tools for unfamiliar features 

  Practice regularly to master different tools 

 
   Reflection Questions 

• Which word processing features do you find most useful? 

• How do these features improve your documents? 

• What challenges do you face when using formatting tools? 

 

 

 
5.1.3 Creating a Well-Formatted Document 
 

Creating a document is not just about typing content—it’s also about presenting 

that content clearly, neatly, and professionally. A well-formatted document is easier 

to read, looks more organized, and leaves a good impression on the reader. 

In this section, you will learn how to create a new document and apply essential 

formatting features, including font styles, alignment, spacing, bullet points, 

headings, and page layout settings, to improve your document presentation. 
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Why Good Formatting Matters 

  Enhances the visual appeal and readability of a document 

  Helps the reader follow the content more easily 

  Makes the document look professional and organized 

  Builds confidence in preparing assignments, letters, reports, or notices 

      Example: A student writing a class assignment uses a proper title heading, 

justified alignment, 1.5 line spacing, and bullet points to make the content clear 

and attractive. 

 
Key Elements of a Well-Formatted Document 

Element Purpose Example 

Title and Heading Introduce the topic Bold, Centered, Font Size 16 

Paragraph Text Present the content Calibri, Size 12, Justified alignment 

Line Spacing Improve text 

readability 

1.5 or Double spacing 

Margins and Indents Structure the page 

layout 

Standard 1-inch margins 

Bullets/Numbering Organize points or 

steps 

Shopping list, procedure steps 

Font and Color 

Choices 

Enhance 

appearance 

Dark text on light background 

Page Orientation Adjust layout Portrait for text documents, Landscape 

for tables/charts 

 
Step-by-Step: Creating and Formatting a New Document 
 

1. Open Microsoft Word / Google Docs 

2. Click Blank Document 

3. Type your content (e.g., title, introduction, list, paragraph) 

4. Apply formatting: 

o Title: Bold, Centered, Size 16 

o Text: Calibri, Size 12, Justify alignment 

o Line Spacing: 1.5 spacing 
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o Bullets: Apply for lists or steps 

o Page Layout: Check margins and orientation 

5. Save the document as Formatted_Document.docx 

 

Figure 50: Word document showing different formatting styles 

 

 
          Activity 5.1.3: Create a Well-Formatted Document 
 

1. Title: “The Role of ICT in Education” 

2. Add: 

o A paragraph introduction 

o A numbered list of benefits of ICT in schools 

o A table comparing traditional and digital learning methods 

3. Apply the following formatting: 

o Headings in Bold, Size 16, Centered 

o Body text in Calibri, Size 12, Justified 

o Line spacing: 1.5 

o Include borders for the table (if using MS Word) 

   Tip: Save your work in both .docx and .pdf formats for sharing and printing. 
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Extension Task: Peer Review – Formatting Feedback 

1. Exchange your document with a classmate. 

2. Review each other's document for formatting quality: headings, spacing, 

text alignment, table layout. 

3. Provide constructive feedback using a simple checklist. 

Checklist Item Yes/No Comments 

Title formatting clear   Well presented 

Text properly aligned   Try using justify 

List formatting applied ✘ Add bullets or numbers 

 
Best Practices for Document Formatting 

  Be consistent with font type and size throughout 

  Use spacing and alignment to improve clarity 

  Don’t overcrowd pages with too much text 

  Use tables or bullet lists to break complex information 

  Preview document before printing or exporting 

 
   Reflection Questions 

• What makes a document easy or difficult to read? 

• Which formatting features helped you most in improving your document? 

• How will you apply these formatting skills in real-life assignments or work? 

 
5.1.4 Editing and Reviewing Documents 
 
After creating and formatting a document, it is important to edit and review the 

content to ensure accuracy, clarity, and professionalism. Editing involves making 

changes to improve grammar, spelling, sentence structure, and word choice. 

Reviewing ensures that the document is well-organized and ready for sharing or 

printing. 

In this section, you will learn how to use editing tools such as spelling and grammar 

check, find and replace, word count, and track changes, and how to review your 

work or give feedback on others’ documents. 
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Figure 51: Document in Microsoft Word showing comments and tracked changes 

 

Why Editing and Reviewing Are Important 

  Ensures clarity and correctness of the content 

  Removes errors and repetition 

  Enhances language and structure 

  Helps prepare documents for official or academic use 

  Supports collaborative review and peer feedback 

      Example: A student typing an essay uses the spelling and grammar tool in MS 

Word to correct errors, uses Find and Replace to update repeated terms, and 

shares the document for peer review before final submission. 

 

Common Editing and Reviewing Tools in Word Processors 

Tool Purpose How It Helps 

Spelling & Grammar 

Check 

Identify language errors Improves accuracy 

Find and Replace Quickly change specific 

words/phrases 

Saves time during editing 

Word Count Show total words/pages Helps follow length limits 

Undo/Redo Reverse recent changes Fix mistakes instantly 

Comments and 

Suggestions 

Provide feedback during review Supports collaboration 

Track Changes Show edits by reviewers Useful in group editing 

tasks 
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   Tip: Most tools are found under the Review tab in Microsoft Word or Tools 

menu in Google Docs. 

 
Step-by-Step: Editing a Document in MS Word 
 

1. Open the document you want to edit 

2. Click Review → Spelling & Grammar 

3. Click “Find” or “Replace” to locate and change specific words 

4. Use Word Count under Review tab to check document length 

5. Enable Track Changes if editing someone else’s work 

6. Add Comments by selecting text → click New Comment 
 

          Activity 5.1.4: Document Editing Practice 
 

1. Type or open a sample document with deliberate spelling and grammar 

mistakes. 

2. Use the following tools to correct and improve it: 

o Spelling & Grammar 

o Find and Replace 

o Word Count 

o Track Changes (if editing a peer’s document) 

3. Save the corrected version as “Edited_Document.docx” 

   Example: Replace all instances of the word “teh” with “the.” 
 

Extension Task: Peer Editing & Feedback Exchange 

1. Exchange your document with a classmate. 

2. Review each other’s work using Track Changes and Comments. 

3. Discuss and apply the feedback to improve your documents. 

Peer Review Checklist Yes/No Comments 

Spelling and grammar corrected   Good use of the tool 

Suggestions clearly given   Add more comments on layout 

Document improved after review   Well done 
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Best Practices in Editing and Reviewing 

  Don’t rely only on spell check—read the document yourself 

  Always save a backup copy before making major edits 

  Review content structure, logic, and flow 

  Be polite and constructive when reviewing someone else's work 

  Always do a final read-through before printing or sharing 

 

   Reflection Questions 

• How do editing tools help you improve your writing? 

• What challenges do you face when reviewing a classmate’s work? 

• Why is peer review an important skill in professional environments? 

 
5.1.5 Importing External Data into a Document 
 
Sometimes when working on a document, you may need to include information 

from other sources such as tables from Excel, charts, images, or text from another 

file. This process is called importing external data. It helps you create 

comprehensive, informative, and visually rich documents. 

In this section, you will learn how to import different types of data from other 

sources into your word processing document and adjust them to suit your content 

layout. 

 

Why Import External Data? 

 

  Saves time by reusing existing content 

  Enhances the quality and appearance of documents 

  Supports integration of text, numbers, visuals, and multimedia 

  Makes documents more informative and interactive 

      Example: A student preparing a science report inserts a table from Excel 

showing experiment results, and adds an image of a microscope to support the 

content. 

 

 



176 

 

 

Types of External Data You Can Import 

Type of Data Examples Purpose 

Text Files Copy-pasting content from Notepad or 

another Word file 

Reuse written content 

Tables Import Excel tables Present statistical or 

numeric data 

Charts/Graphs Bar, pie, line charts from Excel Visualize information 

Images Pictures from folders, web, camera Enhance visual 

presentation 

Online 

Content 

Screenshots, embedded links, online 

pictures 

Reference or illustrate 

concepts 

 

Figure 52: A Word document showing a table and image. 

 
Step-by-Step: Importing Tables and Charts from Excel 

 
1. Open your Excel file 

2. Select the table or chart, then Copy (Ctrl + C) 

3. Open your Word document and place the cursor where you want to insert 

4. Click Paste (Ctrl + V) or choose Paste Special → Link/Embed (if you want 

live updates) 

   Tip: Use Paste Options to choose formatting—e.g., Keep Source Formatting 

or Match Destination Style. 
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Step-by-Step: Inserting Images from External Sources 
 

1. Click Insert → Pictures → This Device 

2. Browse and select the image file 

3. Click Insert 

4. Resize or position image as needed 

5. Use Wrap Text → Square or Tight for proper layout with text 

   Optional: Add a caption below the image for clarity (Insert → Caption) 
 

          Activity 5.1.5: Practice Importing External Data 
 

1. Open a new Word document titled “ICT in Daily Life” 

2. Insert: 

o A paragraph of text copied from another document 

o A table copied from an Excel file (e.g., Internet usage statistics) 

o A chart showing ICT tool usage 

o At least one image from your computer 

3. Format the document properly: 

o Align text and images 

o Apply headings and spacing 

o Wrap text around objects 
 

Extension Task: Create an Integrated Report 

1. Choose a topic (e.g., “Environmental Conservation,” “Youth Empowerment,” 

or “My School Project”) 

2. Collect: 

o Data in a table format from Excel 

o Relevant pictures from a folder or online 

o A chart representing data visually 

3. Compile a report with text + data + visuals using all features learned. 
 

   Best Practices When Importing Data 

  Ensure data is relevant and accurate 

  Resize objects properly for better layout 

  Use consistent formatting 
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  Label charts/tables/images for clarity 

  Save imported content with your document to avoid missing files 
 

   Reflection Questions 

• What types of data do you usually include in your documents? 

• How does importing external data improve document quality? 

• What challenges do you face when working with tables or images in Word? 
 

5.1.6 Saving, Exporting, and Sharing Documents 
 
After creating and formatting a document, the next important step is to save, 

export, and share your work. Saving ensures your work is not lost. Exporting helps 

you prepare the document in different formats (such as PDF), and sharing allows 

you to send the document to others for reading, review, or printing. 

In this section, you will learn how to properly save your work, export it in different 

formats, and share your document through digital means such as email or cloud 

storage. 

      Example: A teacher prepares exam papers in MS Word, saves a copy on a flash 

drive, exports a PDF for printing, and emails a backup to the school head. 

 
Why Saving and Sharing Documents Is Important 
 

  Protects your work from accidental loss 

  Allows easy access and editing later 

  Makes it easier to print or distribute digitally 

  Helps you collaborate with others 

  Enables sharing across platforms (school, workplace, social groups) 

 
Common File Formats for Word Documents 
 

File Format Extension Purpose 

Word Document .docx Editable format (default in MS Word) 

Portable Document Format .pdf Finalized, secure format for printing/sharing 

Rich Text Format .rtf Basic format compatible with many systems 

Web Page .html Used for publishing online 

   Tip: Use PDF when you don’t want others to easily edit your document. 
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Step-by-Step: Saving a Document in MS Word 
 

1. Click File → Save As 

2. Choose the storage location (e.g., Desktop, Documents, Flash Drive) 

3. Enter a file name (e.g., "Student_Application_Letter") 

4. Select file type: Word Document (.docx) or PDF (.pdf) 

5. Click Save 

 

Figure 53: Word “Save As” menu with file format options 
 

Exporting Documents to PDF 
 

1. Click File → Export → Create PDF/XPS Document 

2. Choose save location 

3. Click Publish 

In Google Docs, click File → Download → PDF Document (.pdf) 
 

Sharing Documents Digitally 
 

Method How It Works Example Use 

Flash Drive/External 

Storage 

Copy document to removable 

device 

Carrying files to school lab 

Email Attach and send via internet Sharing assignments with a 

teacher 

Cloud Storage Upload and share via internet 

(e.g., Google Drive, OneDrive) 

Real-time collaboration and 

backup 

Local Network 

Sharing 

Share across computers in the 

same network 

ICT lab file exchange 
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          Activity 5.1.6: Save, Export, and Share Task 
 

1. Create a document titled “Benefits of Tree Planting” 

2. Save it as:  

o .docx file in a folder 

o .pdf version for printing 

3. Share the document:  

o Using a flash drive with a partner 

o Email it to your teacher or friend 

o Upload to Google Drive and share link 

   Discuss: Which method was fastest and most convenient? 

 
Extension Task: Save and Backup Strategy 

1. Identify three storage options available in your school (e.g., flash drive, 

external hard drive, cloud). 

2. Design a backup strategy that ensures your work is protected from loss. 

3. Present your strategy in a short group discussion. 

 

Best Practices in Saving and Sharing 

  Save regularly while working to avoid losing changes 

  Use meaningful file names and folders for easy access 

  Create backups in different locations (e.g., local and cloud) 

  Use secure formats (e.g., PDF) when sharing important documents 

  Protect shared documents with passwords if necessary 

 
   Reflection Questions 

• What would happen if you forgot to save your document? 

• Why is it important to share documents in the correct format? 

• What methods do you use to store and protect your digital work? 
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5.1.7 Exchanging and Reviewing Documents for Peer Feedback 
 

Working alone is good, but collaborating with others and receiving feedback 

makes your documents even better. When you exchange documents with 

classmates, you get new perspectives that help you improve your formatting, 

grammar, structure, and clarity. 

In this section, you will learn how to share documents with peers, review each 

other’s work using tools such as comments and track changes, and provide 

constructive feedback that helps everyone improve. 

 

Why Peer Feedback Is Important 

  Helps identify errors you may have missed 

  Improves document structure and clarity 

  Encourages collaboration and teamwork 

  Builds communication and evaluation skills 

  Supports a culture of continuous improvement 

      Example: A student writes a class report and exchanges it with a peer. The peer 

uses Track Changes to correct sentence flow and adds comments suggesting 

better heading organization. 

 

Tools for Document Review in Word Processors 

Tool Purpose How It Helps 

Track Changes Highlight changes made during 

editing 

Keeps original text visible 

for comparison 

Comments Add feedback without editing 

main content 

Suggest improvements 

politely 

Compare 

Documents 

Check differences between 

original and revised versions 

Useful in revision 

Version History 

(Google Docs) 

View and revert to previous 

versions 

Monitors progress and 

edits 

   Tip: Use polite and specific comments such as: “Consider breaking this 

paragraph into two” instead of “This is wrong.” 
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Step-by-Step: Reviewing a Document Using Track Changes 
 

1. Open the document to review 

2. Click Review → Track Changes → Turn On 

3. Make corrections or suggestions  

o Inserted text appears in color 

o Deleted text is crossed out 

4. Click New Comment to give extra advice 

5. Save and return the document to the original author 
 

          Activity 5.1.7: Peer Review and Feedback Exchange 
 

1. Create a short document titled “The Role of ICT in Business” 

2. Exchange the document with a classmate 

3. Review their document using:  

o Track Changes for edits 

o Comments for suggestions 

4. Return the document and discuss the changes 

5. Update your own document based on the feedback received 

 

Extension Task: Peer Feedback Checklist 

1. In pairs, create a checklist for reviewing documents. 

Review Area Yes/No Comment 

Formatting is consistent   Try aligning the heading 

Grammar and spelling are correct ✘ Some errors in paragraph 2 

Use of images/tables is clear   Good table formatting 

2. Use this checklist while reviewing peers’ documents. 

 
Best Practices in Peer Review 

  Be respectful and supportive in your comments 

  Focus on improvement, not criticism 

  Use Track Changes and Comments clearly 

  Review spelling, formatting, structure, and clarity 

  Discuss and explain feedback after review 
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   Reflection Questions 

• What did you learn from reviewing someone else’s work? 

• How did peer feedback help improve your document? 

• What are the most useful features in document review tools? 

 

Figure 54: Workmates sitting in a group reviewing each other’s documents 

 

5.2 Apply Document Objects to Enhance a Word Document 
 
A document becomes more engaging, clear, and professional when it contains 

visual and structured elements, not just plain text. These elements are called 

document objects — such as tables, images, shapes, charts, WordArt, and 

SmartArt. They help to present information visually and make your document more 

interactive and easier to understand. 

Why Use Document Objects? 
 

  Improves visual appeal and presentation 

  Makes information easier to understand 

  Helps summarize and organize content effectively 

  Engages the reader through visual aids 

  Makes documents more professional and creative 

 

      Example: A student writing a report on ICT tools uses a table to compare 

features, an image of a computer lab, and WordArt for the title heading, making 

the document more engaging and structured. 
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Figure 55: A Word document showing a table, SmartArt, WordArt, and an image. 

 
5.2.1 Understanding the Role of Document Objects in Word Processing 
 
Document objects are elements that you insert into a word processing document 

to enhance its layout, clarity, and visual appeal. They go beyond plain text and help 

to organize, summarize, or highlight important information. Document objects 

include tables, images, charts, shapes, WordArt, SmartArt, and symbols. 

 

Common Roles of Document Objects 

Document 

Object 

Role in Word Processing Example Use 

Tables Organize large amounts of 

information 

Student performance records 

Images Provide visual representation Inserting photos or scanned 

diagrams 

Shapes Highlight or emphasize content Drawing arrows or boxes 

Charts Display numerical data graphically Showing exam pass rate 

trends 

WordArt Add decorative or stylish titles Making headings stand out 

SmartArt Present information in diagrams Showing a process or cycle 

Symbols Insert special characters not on the 

keyboard 

Degrees (°), currency (₵), 

arrows (→) 
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Step-by-Step: Inserting Document Objects 
 

1. Tables → Insert → Table → Select number of rows and columns 

2. Pictures → Insert → Pictures → This Device / Online Pictures 

3. Shapes → Insert → Shapes → Select desired shape 

4. Charts → Insert → Chart → Choose type (bar, pie, line) 

5. WordArt → Insert → WordArt → Choose style → Type text 

6. SmartArt → Insert → SmartArt → Select layout (List, Cycle, Process) 

   Tip: Use “Wrap Text” to position objects appropriately with text. 
 

          Activity 5.2.1: Exploring Document Objects 
 

1. Create a new document titled “Digital Devices in Schools” 

2. Insert the following: 

o A table comparing laptops, tablets, and desktops 

o An image of ICT tools 

o A WordArt heading 

o A SmartArt diagram showing how ICT supports education 

3. Format and align each object properly 

4. Save the document and present your work to the class 
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Extension Task: Document Object Observation Challenge 
 

1. Your teacher will show two documents:  

o One with plain text 

o One with objects included 

2. Compare both documents. 

3. Discuss:  

o Which one is easier to understand? 

o Which one is more appealing? 

o How do document objects make a difference? 
 

Best Practices When Using Document Objects 

  Insert objects only when they add value 

  Align and size objects properly 

  Avoid overcrowding pages with too many visuals 

  Add captions to explain tables, images, and charts 

  Maintain consistency in formatting 
 

   Reflection Questions 

• How do document objects improve your documents? 

• What are the risks of adding too many objects? 

• Which object do you use most and why? 
 

5.2.2 Creating and Formatting Tables in Word Documents 
 
Tables are used to organize information in rows and columns, making it easier to 

present and interpret data in a clear, structured format. In word processing 

software, you can insert tables to display lists, comparisons, schedules, or statistics 

in a professional way. 

 

Why Use Tables in Documents? 

  Organize information in a structured layout 

  Make data easier to compare and understand 

  Improve presentation and clarity 

  Support document types like reports, programs, forms, and records 
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      Example: A teacher preparing an exam timetable uses a table in Microsoft Word 

to display subjects, dates, and times in a simple format that is easy for students to 

read. 
 

Basic Components of a Table 

Component Description 

Rows Horizontal arrangements of data 

Columns Vertical arrangements of data 

Cells Individual boxes where rows and columns intersect 

Borders Lines that define the edges of cells 

Table Style Predefined formatting designs for tables 

 
Step-by-Step: Creating a Table in Microsoft Word 
 

1. Open your Word document 

2. Place the cursor where you want the table 

3. Click Insert → Table 

4. Select the number of rows and columns 

5. Type your data into the table 

6. Adjust table size using drag handles or AutoFit options 

 

Figure 56: Student Report Card Created in Microsoft Word Using Tables 
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Step-by-Step: Formatting a Table 
 

1. Select the entire table 

2. Go to Table Tools → Design / Layout tab 

3. Apply formatting:  

o Borders and Shading for cell appearance 

o Table Styles for professional layout 

o Merge/Split Cells for customization 

o Text Alignment (Top, Middle, Bottom) 

o Change Row Height / Column Width 

o Add or delete rows/columns 

   Tip: Use “AutoFit Contents” to automatically resize columns based on the 

content. 

 
          Activity 5.2.2: Creating and Formatting a Table 
 
a) Insert a table of 7 rows and 3 columns to design your class time table.  

b) Modify the table in (a) and make it appear like the one below.       

Timetable for Reading lessons 

 CLASS 2 CLASS 3 

B
R

E
A

K
 

Monday  

Tuesday   

Wednesday   

Thursday  

Friday    
 

KEY: 

 Teacher Kakuru  Teacher Benard 
 

c) Apply formatting like borders, shading, font styles, and alignment. 

d) Present your table and discuss how formatting improves readability. 

   Bonus: Add a heading in WordArt titled “Mid-Term Test Schedule” 
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Best Practices When Working with Tables 

  Choose the right number of rows and columns 

  Align text for clarity 

  Keep table formatting clean and consistent 

  Use styles and borders for better readability 

  Preview your document before printing or exporting 

 
   Reflection Questions 

• In what situations is a table more useful than plain text? 

• What formatting features improve the appearance of tables? 

• What challenges do you face when creating or editing tables? 

 
5.2.3 Using SmartArt to Visually Represent Data 

Sometimes, text and tables are not enough to explain ideas clearly. That’s where 

SmartArt comes in. SmartArt is a feature in word processing software (especially 

Microsoft Word) that allows you to present information in visual diagrams, making 

your document more engaging and easier to understand. 
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Why Use SmartArt in Documents?  

  Makes abstract or complex ideas easy to understand 

  Provides clear visual structure for concepts and processes 

  Adds professionalism and creativity to your work 

  Captures readers’ attention better than plain text 

      Example: A student preparing a project on “The Stages of the Writing Process” 

uses a SmartArt cycle diagram to show planning, drafting, editing, and publishing 

stages in a circular format. 
 

Common Types of SmartArt Graphics and Their Uses 

SmartArt Type Best Use Case Example 

List Presenting non-sequential 

information 

Features of ICT tools 

Process Showing step-by-step stages Steps in writing a report 

Cycle Repeating processes Life cycle of a plant or project 

Hierarchy Showing levels of authority or 

roles 

School administration 

structure 

Relationship Explaining connections between 

items 

Linking ICT devices and 

software 

Matrix Showing categories or groupings SWOT analysis table 

 
Step-by-Step: Inserting a SmartArt Graphic in Word 
 

1. Place the cursor in your document where you want to insert SmartArt 

2. Click Insert → SmartArt 

3. Choose a category from the left pane (e.g., Process, List, Cycle) 

4. Select a layout style 

5. Type your text directly into the diagram 

6. Use the SmartArt Tools → Design and Format tabs to:  

o Change colors and styles 

o Add more shapes or levels 

o Adjust layout and alignment 

   Tip: Keep the design simple and clear—avoid overcrowding your SmartArt 

with too much text. 
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          Activity 5.2.3: Creating a SmartArt Diagram 
 

1. Create a document titled “Stages of ICT Integration in Schools” 

2. Insert a Process SmartArt graphic 

3. Label the steps: 

o Planning 

o Training Teachers 

o Installing ICT Tools 

o Using ICT in Lessons 

o Evaluating Impact 

4. Customize your SmartArt: 

o Apply a professional color scheme 

o Center-align the diagram on the page 

o Use WordArt for the heading 

 
Extension Task: Visual Summary Using SmartArt 

1. Using the SmartArt, create a Venn diagram below and make it appear like 

this one 

 
2. Customize the layout and color schemes. 

3. Present your diagram and explain how it simplifies information. 
 
 
 
 

Only A

Only B

Only C

AB 

ABC 

AC BC 

Set A Set B 

Set C 
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Best Practices When Using SmartArt 

  Choose a layout that matches the message you want to convey 

  Keep text brief and clear within SmartArt shapes 

  Use consistent colors and styles 

  Don’t over-decorate—focus on clarity 

  Always align and space diagrams neatly 

 
   Reflection Questions 

• How does SmartArt make information easier to understand? 

• When should you use SmartArt instead of a table or plain text? 

• What challenges do you face when working with diagrams? 

 
5.2.4 Inserting and Manipulating Shapes in a Document 

Shapes are graphic elements that help make your documents more interactive, 

organized, and visually appealing. In word processing software like Microsoft 

Word, you can insert shapes such as arrows, boxes, circles, lines, stars, flowchart 

symbols, and more to highlight content, create diagrams, or decorate your 

document. 

      Example: A student designing a school event invitation uses a rectangle shape 

to draw a border, stars for decoration, and arrows to point to key information. 
 

Common Types of Shapes in Word Processing 

Shape Type Use Case Example 

Basic Shapes Decoration or emphasis Rectangle, Circle, Oval 

Arrows Show direction or flow Right arrow for process steps 

Callouts Add labels or remarks Speech bubbles, labels 

Stars and Banners Highlight content Star for attention 

Flowchart Symbols Represent processes Decision boxes, Start/End shapes 

 
Step-by-Step: Inserting a Shape in MS Word 
 

1. Open your Word document 

2. Click Insert → Shapes 
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3. Choose a shape from the menu 

4. Click and drag on the document to draw the shape 

5. Resize and move the shape as needed 

 
 

Step-by-Step: Formatting and Manipulating Shapes 
 

After inserting a shape: 

1. Resize: Drag corners or sides 

2. Reposition: Click and drag the shape to a new location 

3. Change Shape Fill: Format → Shape Fill → Choose color 

4. Add Text Inside a Shape: Right-click → Add Text 

5. Adjust Outline and Effects: Format → Shape Outline / Shape Effects 

6. Group Shapes: Select multiple shapes → Right-click → Group 

7. Arrange Shapes: Send to Back / Bring to Front / Align objects 

   Tip: Use Wrap Text → Tight/Square to position shapes beside text neatly. 

 
          Activity 5.2.4: Practical Task – Designing a Diagram Using Shapes 

1. Open a new document titled “My ICT Tools Flowchart” 

2. Insert the following shapes:  

o Rectangle for title header 

o Ovals for different ICT tools (e.g., Computer, Projector, Printer) 
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o Arrows to show how tools are connected 

o Text inside shapes describing each tool 

3. Arrange the shapes neatly and apply color formatting 

   Save your work and present it to your group or class. 

 
Extension Task: Creating Diagrams with Shapes 

1. Using shapes like circles, arrows, rectangles etc, create the flowchart below 

and make it appear like this one 

 

2. Customize the size, fill color, and position. 

3. Create a labeled diagram and explain how it improves clarity. 

  Format shapes using colors, outlines, and shadows. 

 
   Best Practices When Working with Shapes 

  Keep shapes simple and relevant to the content 

  Use consistent color schemes and alignment 

  Avoid using too many shapes that clutter the page 

  Label shapes clearly if they are part of a diagram 

  Preview layout before printing or sharing 

 
   Reflection Questions 

• How do shapes enhance the structure of a document? 

• What types of documents benefit most from using shapes? 

• What challenges do you face when formatting or positioning shapes? 
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5.2.5 Enhancing Text with WordArt and Visual Effects 
 
Sometimes, plain text may not be enough to attract attention or highlight 

important information in a document. That’s where WordArt and visual effects 

come in. These tools help you make your headings, titles, or key phrases stand out 

by applying decorative text styles, shadows, outlines, glow effects, and more. 

Why Use WordArt and Text Effects? 

 

  Make headings and titles more attractive and engaging 

  Draw attention to important content 

  Add creativity and style to professional documents 

  Improve the presentation quality of documents such as posters, flyers, 

certificates, and newsletters 

      Example: A student designing a school event invitation uses WordArt for the 

title “Welcome to ICT Day” and applies a glow effect to make it more appealing. 

 
What Is WordArt? 
 

WordArt is a text styling tool that lets you apply pre-designed artistic effects to 

text, including: 

• Bold outlines 

• Colorful fills 

• Curved or transformed text 

• Shadows and reflections 

 
Step-by-Step: Inserting WordArt in MS Word 
 

1. Open your document 

2. Click Insert → WordArt 

3. Choose a style (e.g., gradient-filled, outlined, shadowed) 

4. A text box appears — type your title or text inside it 

5. Resize and position the WordArt on the page 

6. Format it further using:  

o Text Fill (color inside text) 
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o Text Outline (border around text) 

o Text Effects (shadow, reflection, glow) 

   Tip: Use WordArt for titles only, not for body text—it can be hard to read in 

long passages. 

 

 
Figure 57: Colorful and stylized WordArt heading 

 
Other Text Enhancement Tools (Text Effects) 

Effect Purpose Where to Apply 

Shadow Creates depth and highlights text Titles or subheadings 

Reflection Adds a mirror effect under text Design documents 

Glow Makes text stand out with light outline Special labels 

Transform Changes shape or flow of text Posters or banners 

     Text effects can be applied to regular text or WordArt text using the Format 

→ Text Effects option. 
 

          Activity 5.2.5: Creating Decorative Headings with WordArt 

1. Open a new document titled “ICT Skills for Learners” 

2. Insert a WordArt title for the document heading 

3. Add a subheading with shadow and glow effect 

4. Insert a simple paragraph explaining ICT skills 

5. Save and present your document 

   Bonus: Use Text Wrapping options to place WordArt beside an image or 

shape. 
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Extension Task: Designing a Cover Page Using WordArt 

1. Create a cover page for a school magazine or report 

2. Use WordArt for the title, text effects for subheadings, and shapes or 

images to enhance design 

3. Apply consistent formatting, alignments, and colors 

4. Print or share your cover page for classroom display 

 
Best Practices When Using WordArt and Effects 

  Keep text styles readable and not too flashy 

  Apply effects only where necessary (don’t overuse) 

  Match colors and fonts to document theme 

  Use WordArt for emphasis, not for entire content 

  Combine text effects with good formatting for impact 

 
   Reflection Questions 

• How does WordArt improve document appearance? 

• What’s the difference between WordArt and regular text formatting? 

• When is it appropriate to use text effects in documents? 

 
5.2.6 Inserting and Formatting Images and Clip Art 
 
Images add visual appeal and clarity to documents. They help to illustrate ideas, 

support explanations, and engage readers more effectively than text alone. Word 

processing software like Microsoft Word, Google Docs, and LibreOffice Writer 

allows users to insert and format images from different sources, including pictures 

stored on your device, online images, or clip art. 

Why Insert Images in a Document? 

 

  Makes the document more attractive and engaging 

  Enhances understanding and explanation of content 

  Supports illustration of ideas or concepts 
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  Adds professional and creative presentation to reports, flyers, 

magazines, and newsletters 

      Example: A student creating a report on "Types of ICT Devices" inserts images 

of a computer, printer, and scanner, making the content easier to understand. 
 

Sources of Images for Word Documents 

Image Type Source How to Insert 

Pictures from 

this device 

Stored in computer for example 

from Support Files or flash drive 

Insert → Pictures → This 

Device 

Online Pictures Downloaded from the internet Insert → Online Pictures / 

Download and insert 

Clip Art (older 

Office versions) 

Pre-designed images (now replaced 

by Online Pictures in MS Word 2013 

and above) 

Insert → Pictures (Browse 

saved clip art) 

 
Step-by-Step: Inserting an Image in MS Word 

 
1. Place your cursor where you want the image 

2. Click Insert → Pictures → This Device 

3. Browse and select the image from your folder 

4. Click Insert 

5. Resize the image by dragging corners 

6. Use Wrap Text → Square or Tight to position image beside text 

7. Format the image using Picture Tools → Format tab:  

o Add borders, shadows, reflections 

o Adjust brightness and contrast 

 
     Tip: Supported file formats include .jpg, .png, .bmp, .gif. 



199 

 

 

 
Step-by-Step: Inserting Online Pictures in Word 2013 and Above 

 
1. Click on the “Insert” tab. 

2. Click on “Online Pictures.” 

3. In the “Insert Pictures” window, type keywords in the Bing Image Search 

box. 

4. Choose a suitable image → Click Insert. 

 
     Note: You must be connected to the internet to use this feature. 

 
Formatting Inserted Images 

After inserting your image, you can customize it for better appearance and 

layout: 

Formatting Option How to Apply 

Resize Click and drag image corners to resize proportionally 

Crop Select image → Click “Picture Format → Crop” 

Position Click image → Choose “Wrap Text” option: In Line with Text, 

Square, Tight, Behind Text, etc. 

Apply Styles Select image → Use Picture Styles under Picture Format tab 

(e.g., shadows, borders, reflections) 

Adjust 

Brightness/Contrast 

Use “Corrections” or “Color” under Picture Format to 

enhance visuals 
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How to Insert Clip Art in Word 2013 and Above (Accessing Clip Art Manually from PC) 

Although the Clip Art button was removed after Office 2010, you can still access 

Clip Art illustrations by manually locating the Clip Art folder stored on your 

computer. 

 

Step-by-Step Instructions: 

1. Open Microsoft Word 2013 or newer (e.g., Word 2016, 2019, or 2021). 

2. Go to the Insert tab on the Ribbon. 

3. Click Pictures → This Device (or "From File" in some versions). 

4. In the file explorer window, navigate to the following folder location: 

 

C:\Program Files\Microsoft Office\root\CLIPART\PUB60COR 

 

(If you installed Office in a different directory, adjust accordingly) 

5. Select any image from the Clip Art (PUB60COR) collection. 

6. Click Insert to add it into your document. 

7. Format it using Picture Tools, just like other images. 

 

Figure 58: Word document with a positioned and styled image, demonstrating Wrap Text 

and border formatting 
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          Activity 5.2.6: Practice – Inserting and Formatting Images 
 

1. Open a document titled “Modern ICT Tools” 

2. Insert: 

o A picture of a laptop from your device 

o A clip art-style image downloaded from the internet 

3. Apply the following formatting: 

o Resize both images 

o Use Wrap Text → Square 

o Add a border and shadow effect 

4. Save the document in both .docx and .pdf formats 
 

   Best Practices When Working with Images 

  Choose high-quality, relevant images 

  Keep image sizes appropriate—not too big or small 

  Use text wrapping to position images neatly 

  Combine images with captions for clarity 

  Avoid clutter—use only images that support the content 
 

   Reflection Questions 

• How do images enhance the meaning of a document? 

• What challenges do you face when inserting or formatting pictures? 

• How can you position images neatly beside text? 
 

5.2.7 Inserting Charts and Graphs in a Document 

Charts and graphs are visual tools that help you represent numerical or statistical 

data in a way that is easy to understand and analyze. Instead of using lengthy tables 

or plain numbers, charts allow you to summarize complex data visually using bars, 

lines, or pie segments. 

 

Why Use Charts and Graphs in Documents? 

  Help readers understand data quickly 

  Improve data presentation and analysis 

  Support decision-making with clear visuals 

  Make documents more interactive and professional 
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      Example: A student writing a report on “School Attendance Rates” inserts a bar 

chart showing attendance by class to help visualize the trends more clearly. 

 

 

Figure 59: A Graph in a Word Document 

 
Common Types of Charts and Their Uses 

Chart Type Use Case Example 

Bar Chart Comparing quantities across 

categories 

Number of students per class 

Pie Chart Showing parts of a whole Percentage of budget allocation 

Line Graph Showing trends over time School performance over terms 

Column 

Chart 

Similar to bar chart but vertical Sales performance 

Area Chart Displaying cumulative trends Agricultural yield per year 

 
Step-by-Step: Inserting a Chart in MS Word 

1. Click Insert → Chart 

2. Select the chart type (e.g., Column, Pie, Line) 

3. Click OK – an Excel-style data sheet will appear 

4. Enter your data in the table provided 

5. The chart updates automatically in your Word document 

6. Use the Chart Tools → Design and Format tabs to:  

o Change colors and styles 
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o Add titles, legends, and data labels 

o Adjust layout and size 

   Tip: You can also create the chart in Excel, copy it, and paste it into your Word 

document. 
 

          Activity 5.2.7: Practical Task – Creating a Chart 

1. Open a new document titled “ICT Tool Usage in My School” 

2. Insert a bar chart showing different ICT tools and how many students use 

them (e.g., Computers, Tablets, Projectors) 

3. Format the chart:  

o Add a chart title 

o Label axes 

o Apply a color style 

4. Save the document 
 

Extension Task: Data Visualization Report 

1. Create a report titled “Student Performance in 3 Subjects” 

2. Create a table with student names and scores in Math, English, and Science 

3. Insert a column chart showing scores for each subject 

4. Format the chart with:  

o Clear labels 

o Data values displayed 

o Neatly aligned in the document 

   Bonus: Add a SmartArt summary showing the top three performing students. 
 

Best Practices When Using Charts and Graphs 

  Choose the right chart type for your data 

  Always include titles, labels, and legends 

  Keep the chart simple and easy to read 

  Avoid using too many colors or 3D effects unnecessarily 

  Explain your chart in the document if needed 
 

   Reflection Questions 

• Which chart type is most suitable for comparing student marks? 

• How does a chart improve your document compared to a table alone? 

• What challenges do you face when formatting charts? 
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5.2.8 Using Mail Merge for Automated Document Creation 
 
When you want to send the same document to many people, such as invitation 

letters, certificates, or report cards, it can be time-consuming to create each one 

manually. Mail Merge allows you to create one standard document and 

automatically personalize it for multiple recipients, saving time and ensuring 

consistency. 

 

Why Use Mail Merge? 

  Saves time in preparing multiple personalized documents 

  Ensures consistency in layout and formatting 

  Reduces typing errors and improves accuracy 

  Makes it easy to send customized letters, certificates, or reports 

      Example: A school secretary needs to send admission letters to 100 students. 

Instead of typing each letter separately, she uses Mail Merge to generate all letters 

from one master document linked to a student list in Excel. 

 
Mail Merge Components 

Component Description 

Main Document The base template (e.g., letter or certificate) 

Recipient List A data source (Excel table or Word table) with recipient 

information 

Merge Fields Placeholder text in the main document that will be replaced with 

actual data 

 
Step-by-Step: Using Mail Merge in MS Word 
 

Method 1: Using the Step-by-Step Mail Merge Wizard 

1. Open Word → Click Mailings → Start Mail Merge → Step-by-Step Mail 

Merge Wizard 

2. Choose Document Type (e.g., Letters or Labels) 

3. Select Starting Document (current or template) 

4. Choose Recipient List (e.g., Excel file with names and addresses) 
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5. Insert Merge Fields (e.g., <<First Name>>, <<Class>>) into your 

document 

6. Click Preview Results to check the personalized output 

7. Click Finish & Merge → Print Documents / Send Email / Edit Individual 

Documents 

 
Method 2: Manual Mail Merge (Without Wizard) 

1. Click Mailings → Start Mail Merge → Letters 

2. Click Select Recipients → Use Existing List 

3. Navigate and select your Excel sheet or table 

4. Click Insert Merge Field → Choose desired fields 

5. Customize your letter with merge fields 

6. Finish and merge as in Method 1 

 

Figure 60: Word document showing a Mail Merge field and recipient list 

 
          Activity 5.2.8: Practice Mail Merge Task 
 

1. Prepare a main letter inviting students for a school event.  

o Include merge fields like: <<Student Name>>, <<Class>>, <<Event 

Date>> 

2. Create a recipient list in Excel with at least 5 students 

3. Link the document and generate merged letters 
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4. Save the merged output 

   Bonus: Export letters as PDF or print ready format. 

 
Best Practices in Mail Merge 

  Ensure the recipient list is accurate and clean 

  Preview documents before final merge 

  Save your main template separately for reuse 

  Always test the merge with a few entries first 

  Name your output files clearly for easy printing or emailing 

 
   Reflection Questions 

• What type of documents can Mail Merge help you automate? 

• How does Mail Merge save time and improve accuracy? 

• What challenges might you face when working with recipient lists? 

 
5.2.9 Using Table of Contents in a Word Document 

In long documents such as reports, research papers, school magazines, or manuals, 

it is important to include a Table of Contents (TOC). A Table of Contents gives a 

quick overview of the document structure and helps readers easily locate different 

sections or topics. 

Most word processing software, especially Microsoft Word, allows users to 

automatically generate and update a dynamic Table of Contents based on 

headings and subheadings in the document. 

 

Why Use a Table of Contents? 

  Helps readers find sections quickly 

  Adds structure and organization to the document 

  Enhances the professional appearance of long documents 

  Allows automatic updates when content changes 

  Improves document readability and navigation 

 

      Example: A student preparing a science project report adds a Table of Contents 

that shows headings like Introduction, Objectives, Data Analysis, and Conclusion, 

each with corresponding page numbers. 
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Step-by-Step: Creating a Table of Contents in MS Word 
 

1. Apply Heading Styles: 

o Highlight your main titles → Home → Styles → Heading 1 

o Highlight subheadings → Heading 2 or Heading 3 

2. Insert Table of Contents: 

o Click References → Table of Contents → Choose a format (Automatic 

Table 1 or 2) 

3. Update Table of Contents (after editing content): 

o Click inside the TOC → Click Update Table → Choose Update Page 

Numbers Only or Update Entire Table 

   Tip: Use Heading styles consistently so that your TOC reflects the correct 

structure. 

 

Figure 61: Word document showing a TOC and a list of headings with page numbers 

 
          Activity 5.2.9: Practice Task – Creating a Table of Contents 
 

1. Create a sample document titled “My Career Development Guide” 

2. Add at least 4 sections with proper headings, such as: 

o Introduction 

o Career Goals 

o Required Skills 

o Action Plan 
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3. Apply Heading 1 to each title 

4. Insert a Table of Contents at the beginning of the document 

5. Edit your content and practice updating the TOC 
 

Extension Task: Building a Table of Contents from a Sample Document 

1. Your teacher provides a sample project or report document without a TOC 

2. Identify and apply appropriate heading styles to titles and subheadings 

3. Insert and format a Table of Contents 

4. Customize font style, spacing, and indentation in the TOC (optional) 

   Bonus: Use “Custom Table of Contents” to adjust appearance settings. 
 

Best Practices When Using Table of Contents 

  Apply correct heading styles before inserting TOC 

  Keep headings short and meaningful 

  Update the TOC after any major editing 

  Use consistent formatting for headings and subheadings 

  Always place the TOC before the main body of the document 

   Reflection Questions 

• What challenges did you face while creating a Table of Contents? 

• How does a TOC improve the structure of a large document? 

• Why is it important to update the TOC after editing? 
 

5.2.10 Using Document Referencing Tools (Citations, Footnotes, Endnotes) 

In academic and professional documents, it is important to acknowledge sources 

of information. This is done through referencing tools such as citations, footnotes, 

and endnotes. These tools help you show where your ideas come from, give credit 

to original authors, and maintain integrity in your writing. 
 

Why Use Referencing Tools? 

  Avoids plagiarism by giving credit to sources 

  Supports research and academic writing 

  Provides readers with additional information sources 

  Makes your work more credible and professional 

  Helps organize long documents clearly 

      Example: A student writing a Geography report includes a citation and 

bibliography for a textbook used, and uses a footnote to explain a difficult term. 
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Types of Referencing Tools in Word Processing 

Tool Function Example 

Citation Insert reference to a source 

within the text 

(Ministry of Education, 

2022) 

Footnote Add extra information at the 

bottom of the page 

Explaining technical terms 

Endnote Like footnote, but appears at 

the end of the document 

Notes and references 

Bibliography / 

References List 

List of all cited sources in the 

document 

Books, articles, websites 

used 

 

 

Step-by-Step: Inserting a Citation and Bibliography in MS Word 

1. Click References → Insert Citation → Add New Source 

2. Select Type of Source (e.g., Book, Website, Journal) 

3. Enter the details (author, title, year, publisher, etc.) 

4. Click OK – citation appears in the document 

5. To create a list of sources:  

o Click Bibliography → Choose Bibliography or Works Cited format 

   Tip: You can choose different referencing styles (APA, MLA, Chicago) under 

Style menu in References tab. 
 

Step-by-Step: Adding Footnotes and Endnotes 
 

1. Place the cursor after the word or sentence to explain 

2. Click References → Insert Footnote / Insert Endnote 

3. Type your note text at the bottom of the page (footnote) or end of the 

document (endnote) 

   Tip: Footnotes use automatic numbering and formatting for consistency. 
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          Activity 5.2.10: Referencing Practice Task 

1. Create a document titled “The Importance of ICT in Health” 

2. Write a paragraph referring to a textbook or article 

3. Insert:  

o A citation for the source used 

o A footnote explaining a medical term 

o A bibliography at the end of the document 

   Bonus: Change referencing style from APA to MLA using the Style drop-down 

menu. 

 
Extension Task: Document with Multiple References 

1. Create a report draft on a topic like “The Impact of Social Media on Youth” 

2. Use:  

o Multiple citations from books and websites 

o At least two footnotes 

o Generate a complete bibliography section 

3. Save your document and prepare it for class presentation 

 
Best Practices When Using Referencing Tools 

  Use consistent referencing style throughout the document 

  Insert citations immediately after the referenced idea 

  Include all cited sources in the bibliography 

  Do not confuse footnotes with citations—citations show source, 

footnotes give extra info 

  Keep endnotes brief and relevant 

 

   Reflection Questions 

• Why is it important to cite sources in your documents? 

• How do footnotes and endnotes improve document quality? 

• What is the difference between a bibliography and a reference list? 
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Sample Activity of Integration 
 

     Scenario: A youth organization is organizing a community event and needs 

official documents, including an invitation letter, an event program, and a 

sponsorship request letter. 

Task: 

Using Microsoft Word, create well-formatted professional documents 

incorporating tables, headers, footers, and referencing tools to enhance readability 

and professionalism.  

 
Self-Assessment Questions 

 
1. Define word processing software and give two examples. 

2. Explain the difference between a template and a document in Microsoft 

Word. 

3. List three ways word processors improve document formatting and 

readability. 

4. What is mail merge, and how can it be used in an office setting? 

5. Describe the importance of using tables and columns in documents. 

6. Explain the purpose of document referencing features such as citations and 

footnotes. 

 

 

In this topic you have learnt about: 

 Format and edit a Word document. 

 Apply document objects to enhance a Word 
document. 

 Use document referencing features 
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TOPIC ELECTRONIC SPREADSHEET 

Key Words 

 Spreadsheet  

 Cell 

 Row & Column 

 Worksheet 

 Formula 

 Function 

 Workbook 

The Content of this topic and the activities 

will enable you to; 

a) collect and organize data 

b) manipulate and analyze data to gain 

insights. 

c) create visual objects (charts, graphs) 

to present data. 
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Introduction 
 
In today’s data-driven world, electronic spreadsheets are 

powerful tools used to organize, analyze, calculate, and 

present data effectively. Whether you are managing a school 

budget, tracking student marks, analyzing business sales, or 

conducting research, spreadsheets help you work faster and smarter. 

This topic introduces learners to Microsoft Excel 2016 and newer versions, as well 

as other spreadsheet tools such as Google Sheets and LibreOffice Calc. You will 

learn to enter and organize data, apply formulas and functions, generate charts 

and graphs, and analyze real-world datasets. 

Why Is Spreadsheet Software Important? 
 

Sector Applications 

Business Budgeting, sales tracking, profit analysis 

Education Recording marks, attendance tracking 

Finance Payroll management, forecasting, financial reports 

Research Data entry, statistical analysis 

Health Patient records, data monitoring 

      Example: A business owner in Uganda uses Excel to track monthly sales, 

calculate profits, and visualize trends using bar charts. 
 

Quick Starter Activity: Spreadsheet Brainstorm 

1. In pairs, list tasks in your school or home where spreadsheets can help 

(e.g., managing class marks, family budget, sports records). 

2. Share your examples with the class and discuss how a spreadsheet can 

make those tasks easier. 

 

6.1 Collect And Organize Data 
 

A major purpose of using spreadsheet software is to collect, store, and organize 

data in a structured and meaningful way. Organizing data helps in easy entry, 

retrieval, sorting, and analysis. 
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Why Organizing Data Is Important 

 

  Makes data easy to read, manage, and analyze 

  Helps you identify patterns, trends, and errors 

  Supports decision-making based on accurate records 

  Saves time in working with large datasets 

      Example: A school bursar organizes student fee payment records in Excel with 

separate columns for Name, Class, Amount Paid, and Balance — making it easier 

to track payments. 
 

Step-by-Step: Creating and Organizing Data in Excel 
 

1. Open Microsoft Excel or Google Sheets 

2. Click on Blank Workbook 

3. Use Row 1 to create column headers (e.g., Name, Class, Score, Remarks) 

4. Enter corresponding data below each header 

5. Use AutoFit to adjust column width 

6. Save your file with a meaningful name 

   Tip: Keep column headers clear and consistent for easier sorting and filtering 

later. 
 

Organizing Data Tips 

  Keep one type of data per column (e.g., don’t mix names and scores in the 

same column) 

  Ensure spelling is consistent (especially for filtering) 

  Leave no blank rows between records 

  Use proper data formats (e.g., text, numbers, date) 

 
          Activity 6.1: Practice Task – Student Performance Record 
 

1. Create a worksheet titled “Term One Performance” 

2. Add column headers:  

o Student Name | Class | English | Math | Science | Total | Average 

3. Enter sample data for at least 5 students 

4. Adjust column width and row height 

5. Save the file as Student_Performance.xlsx 
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Extension Task: Household Budget Sheet 

1. Create a spreadsheet titled “Monthly Household Budget” 

2. Columns: Item | Quantity | Unit Cost | Total Cost 

3. Add at least 8 items (e.g., Maize Flour, Sugar, Transport, Airtime) 

4. Enter values and organize the table 

5. Use formatting tools to make your data neat 

 
Best Practices for Data Entry and Organization 

  Double-check data accuracy before saving 

  Use bold and background colors to highlight headers 

  Use borders to make tables easy to read 

  Use Save As to keep original data before editing further 

  Keep backups of important work 

 
   Reflection Questions 

• Why is it important to organize data properly in a spreadsheet? 

• What challenges do you face when entering and organizing data? 

• How can sorting and filtering help when managing large data tables? 

 
6.1.1 Exploring Spreadsheet Software and Their Functions 
 

There are different types of spreadsheet software, each offering tools to help users 

collect, organize, calculate, and analyze data efficiently. While most features are 

similar across applications, some software is better suited for specific tasks, 

environments, or budgets. 

 

      Example: A student managing a school club’s expenses may choose Google 

Sheets for easy sharing and collaboration with members, while a school bursar may 

use Microsoft Excel for advanced calculations and secure offline use. 
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Commonly Used Spreadsheet Software 

 

Software Features Best Used For 

Microsoft Excel Advanced formulas, charts, 

pivot tables 

Professional and academic 

tasks 

Google Sheets Cloud-based, real-time 

collaboration 

Group projects and online 

data entry 

LibreOffice Calc Free, offline, open-source Personal or school use with 

no budget 

WPS Office 

Spreadsheets 

Lightweight, user-friendly General data tasks on basic 

devices 

   Tip: Choose software based on user needs, device capability, and availability 

of internet connection. 

 
Key Functions of Spreadsheet Software 

Function Purpose Example 

Data Entry Input text, numbers, dates Recording student marks 

Auto Fill Copy patterns or sequences Fill in serial numbers 

automatically 

Sorting and 

Filtering 

Organize and view specific 

data 

View students with marks above 

70% 

Formulas and 

Functions 

Perform calculations SUM, AVERAGE, IF, COUNT 

Data Formatting Change text style, color, cell 

borders 

Highlight high-performing 

students 

Charts and Graphs Visualize data Pie chart of school budget 

allocation 

Data Validation Control data input Restrict entries to only numbers 

Collaboration Tools Work with others in real-

time (online) 

Group project spreadsheet in 

Google Sheets 
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          Activity 6.1.1: Spreadsheet Software Exploration Task 
 

1. In groups, choose two different spreadsheet software (e.g., MS Excel and 

Google Sheets) 

2. Explore and compare the following: 

o User interface 

o Core features 

o Speed and ease of use 

o Offline vs. Online functionality 

3. Complete a comparison table: 

Feature Microsoft Excel Google Sheets 

Ease of use        

Works offline     Limited 

Chart creation        

Collaboration       

4. Discuss: Which software is best for school use, and why? 
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Extension Task: Demonstration Presentation 

1. Prepare a short class presentation comparing spreadsheet software 

2. Include screenshots and highlight special features (e.g., Auto Fill, Charts, 

Conditional Formatting) 

 

Best Practices When Using Spreadsheet Software 

  Choose a tool that fits your task and level of experience 

  Explore menus and tabs to discover more functions 

  Save work frequently, especially when using offline tools 

  Use help tools or tutorials to learn more advanced features 

  Work in groups to improve collaboration and sharing 

 

   Reflection Questions 

• What differences did you notice between spreadsheet software options? 

• Which spreadsheet tool do you prefer and why? 

• How does understanding software features help you perform tasks better? 

 
6.1.2 Creating and Entering Data in a Worksheet 
 
A worksheet is a single sheet within a spreadsheet program where you can enter 

and manage data in an organized format. It consists of rows and columns, and 

each cell (intersection of a row and column) can hold text, numbers, dates, or 

formulas. 

 
Why Is Accurate Data Entry Important? 

  Ensures that calculations and analysis are accurate 

  Makes your data easy to read and organize 

  Supports sorting, filtering, and visual presentation 

  Prevents errors that may affect decision-making 

      Example: A class teacher entering student test scores into Excel ensures each 

mark is typed in the correct cell under the right subject, avoiding confusion and 

errors when calculating averages. 
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Key Concepts to Understand 

 

Term Meaning 

Cell A single data entry box (e.g., A1) 

Cell Range A group of selected cells (e.g., A1:A10) 

Row A horizontal line of data (1, 2, 3…) 

Column A vertical line of data (A, B, C…) 

Active Cell The currently selected cell for typing 

 
Step-by-Step: Creating a New Worksheet and Entering Data 
 

1. Open Microsoft Excel or Google Sheets 

2. Click Blank Workbook 

3. In Row 1, type your column headings (e.g., Name, Class, English, Math, 

Science) 

4. Click on each cell below the headings and enter data for each student 

5. Press Enter or Tab to move to the next cell 

6. Save your worksheet (e.g., “Student_Marks.xlsx”) 

   Tip: Always start your data from the top-left corner (Cell A1) for neat 

arrangement. 

 
Data Entry Guidelines 

  Keep one data type per column (e.g., all scores in one column) 

  Avoid blank rows or columns between data 

  Use correct formats (e.g., numbers for marks, text for names) 

  Double-check spelling and values for accuracy 

  Use AutoFill to quickly enter repeated values (e.g., Class “S4”) 

 
          Activity 6.1.2: Practice Task – Student Marks Entry 

1. Create a worksheet titled “Term Two Results” 

2. Column Headings: Student Name | Class | English | Math | Science | Total | 

Average 

3. Enter sample data for at least 5 students 

4. Save your file and review your entries for accuracy 

   Bonus: Highlight the heading row with bold text and background color 
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Extension Task: Class Registration Worksheet 

1. Create a worksheet titled “Class Registration List” 

2. Columns: Admission No | Student Name | Gender | Class | Date of Birth 

3. Enter data for 10 learners 

4. Use Date format for Date of Birth 

5. Format the worksheet for neat presentation 

 
Best Practices When Entering Data 

  Use bold font for headers 

  Align numbers and text properly (e.g., left for names, right for marks) 

  Save your file with a meaningful name 

  Keep backups of important files 

  Practice using different types of data (text, numbers, dates) 

 
Practical Formatting Tips: 

• Use bold font for headers (Home → Bold). 

• Apply number formatting (Home → Number group → Select format). 

• Adjust column width: Hover over the column line and drag to widen. 

 
   Reflection Questions 

• What challenges do you face when entering data into spreadsheets? 

• How can formatting make your data easier to understand? 

• Why is it important to use correct data types (e.g., number, text, date)? 

 
6.1.3 Creating a Simple Budget Worksheet 
 
A budget worksheet is a useful tool for planning and managing income and 

expenses. It helps you track spending, make informed financial decisions, and avoid 

unnecessary debt. Using spreadsheet software, you can create a budget worksheet 

that automatically calculates totals and balances. 

 

      Example: A Senior Four student in Uganda uses Excel to plan monthly pocket 

money by listing income sources (e.g., pocket money, part-time job) and expenses 

(e.g., transport, lunch, airtime). 
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Why Create a Budget Using a Spreadsheet? 

  Organize your financial data clearly 

  Monitor your income and expenses 

  Calculate total spending and remaining balance 

  Save time by automating calculations 

  Build personal financial literacy skills 

 

Key Elements of a Budget Worksheet 

Item Description 

Income Money received (e.g., allowance, sales, salary) 

Expenses Money spent (e.g., food, transport, school supplies) 

Balance Difference between income and total expenses 

Totals Sum of all income or expenses 

Labels and headings Clear identifiers for each column and row 

 
Step-by-Step: Creating a Budget Worksheet in Excel 
 

1. Open Microsoft Excel or Google Sheets 

2. Create column headings:  

o Item | Category | Amount 

3. Enter a list of income and expense items in separate sections 

4. Add a Total row using the SUM formula 

5. Add a row for Balance = Total Income - Total Expenses 

6. Apply formatting:  

o Bold headings 

o Borders for table cells 

o Currency format for amounts 
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Sample Budget Table Layout 

Item Category Amount (UGX) 

Pocket Money Income 100,000 

Transport Expense 30,000 

Lunch Expense 20,000 

Airtime/Data Expense 10,000 

Total Income — =SUM(income) 

Total Expenses — =SUM(expenses) 

Balance — =Income - Expenses 

   Tip: Use bold and color to differentiate income, expenses, and totals. 

 
          Activity 6.1.3: Create Your Personal Budget Worksheet 
 

1. Create a worksheet titled “My Monthly Budget” 

2. Add income and expense items relevant to your life 

3. Enter realistic values 

4. Use SUM formula to calculate totals 

5. Calculate your balance (Remaining money) 

6. Format your worksheet professionally 

 
Extension Task: Family or School Budget Planning 

1. In small groups, prepare a budget plan for a family or school club 

2. Include categories like:  

o Income: Fundraising, donations, support 

o Expenses: Materials, meals, transport, printing 

3. Calculate totals and balance 

4. Share your budget plan with the class 

 
Best Practices in Budget Worksheets 

  Use clear headings and labels 

  Format amounts in currency format (UGX) 

  Keep calculations accurate using formulas 
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  Save and backup your worksheet 

  Review your spending regularly 

 

   Reflection Questions 

• Why is budgeting important for students? 

• How can spreadsheets help in financial planning? 

• What formulas did you use to calculate totals and balance? 

 
6.1.4 Sorting Data in a Spreadsheet 
 
As your spreadsheet grows with more data, it becomes important to arrange (sort) 

that data in a way that makes it easier to read, analyze, and interpret. Sorting helps 

you reorganize data based on specific criteria, such as alphabetical order, 

numerical values, or dates. 

 

Why Is Sorting Important? 

  Helps you view data in a meaningful order 

  Makes it easier to compare records 

  Saves time when searching for specific entries 

  Supports analysis and decision-making 

      Example: A teacher uses sorting to arrange students by highest to lowest 

score to identify top performers in a class. 

 

Figure 62: Sorted Excel dataset by sales amount 
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Types of Sorting 

Sort Type Description Example 

Ascending Order (A→Z or 

0→9) 

From smallest to 

largest 

Sorting students by name or 

marks 

Descending Order (Z→A or 

9→0) 

From largest to 

smallest 

Sorting expenses from highest 

to lowest 

Custom Sort Sort using multiple 

levels 

Sort by Class, then by Name 

 

Step-by-Step: Sorting Data in Microsoft Excel 
 

1. Select the entire table including column headings 

2. Click Data → Sort 

3. Choose the column you want to sort by (e.g., Name, Marks) 

4. Choose Ascending or Descending order 

5. Click OK to apply the sort 

   Tip: Always include the header row when sorting to avoid mixing data. 

 
          Activity 6.1.4: Practice Task – Sorting Student Marks 
 

1. Open your “Term Two Results” worksheet 

2. Sort data by Math marks in descending order 

3. Next, try sorting by Student Name in ascending order 

4. Record your observations: Who scored highest in Math? 

   Bonus: Sort by Class first, then by Name (Custom Sort) 

 
Extension Task: Sorting School Expenses 

1. Create a worksheet titled “School Budget Summary” 

2. Add items with Expense Categories and Amounts 

3. Sort the list by Amount (Descending) to see the most expensive items 

4. Discuss how sorting helps in analyzing spending patterns 
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Best Practices When Sorting Data 

  Select the entire dataset before sorting 

  Always include column headers 

  Double-check data after sorting to ensure values remain aligned 

  Use custom sort when sorting by more than one field 

  Save a backup copy before sorting large datasets 

 
   Reflection Questions 

• How does sorting help you analyze data faster? 

• What mistakes can happen if you don’t select the full dataset? 

• When would you use a custom sort in a real-life scenario? 

 
6.1.5 Filtering Data to Display Specific Information 
 
When working with large datasets in a spreadsheet, it can be difficult to find the 

information you need. Filtering helps you to quickly display only the specific data 

that matches certain criteria, without deleting the rest of the content. This makes 

it easier to focus on relevant records for analysis or reporting. 

 
Why Use Filtering? 

  Displays only relevant data and hides the rest 

  Makes it easy to find specific entries or trends 

  Supports data analysis and reporting 

  Saves time when working with large spreadsheets 

      Example: A school bursar uses filtering to view only students with unpaid fees 

without deleting the rest of the records. 

 

Difference Between Sorting and Filtering 

Sorting Filtering 

Reorders the entire data based on a 

selected column 

Hides unwanted data and shows only 

selected criteria 

Data remains fully visible Only matching data is shown 

Often used for ranking Often used for searching 
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Step-by-Step: Applying Filters in Microsoft Excel 
 

1. Select your data including headers 

2. Click Data → Filter 

3. Small drop-down arrows will appear in each column header 

4. Click the arrow on a specific column (e.g., Class or Score) 

5. Choose the condition or value to filter (e.g., only “S4” or scores above 70) 

6. The spreadsheet will now display only matching rows 

   Tip: To remove filters, click Data → Clear Filter or turn off filtering. 

 
Filtering Options 

Type of Filter Example Use 

Text Filter View only learners from Class “S4” 

Number Filter View students with marks ≥ 60 

Date Filter View records from a specific term or year 

Multiple Filters Combine filters on multiple columns (e.g., Class and Gender) 

 
          Activity 6.1.5: Practice Task – Filtering Student Results 
 

1. Open your “Term Two Results” worksheet 

2. Apply a filter to the Class column → Show only students in “S4” 

3. Apply a filter to Science column → Show only those who scored above 65% 

4. Observe: How many students match both filters? 

5. Clear the filter and try a different condition 

   Bonus: Combine filters (e.g., S4 Boys scoring ≥ 70 in Math) 
 

Extension Task: Filtering School Expenses 

1. Create a worksheet titled “Annual Expenses” 

2. Add items with columns for: Item, Category, Month, Cost 

3. Filter: 

o Only Transport expenses 

o Expenses in Term 1 

o Costs greater than UGX 50,000 

4. Present your findings in class and explain how filtering helped. 
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Best Practices in Filtering 

  Always include column headers before filtering 

  Use filters to narrow down specific views, not to edit content 

  Clear filters regularly to see the full data again 

  Use number filters to target value ranges (e.g., >50) 

  Save your file before and after filtering 

 
   Reflection Questions 

• How does filtering help you work with large datasets? 

• What is the difference between filtering and sorting? 

• When might you use filters in a real-life school or business scenario? 

 
6.1.6 Collecting and Organizing Real-World Data 
 
Spreadsheets are not just tools for entering pre-given information — they are also 

powerful for working with real-world data collected from different sources. 

Whether you're conducting a school survey, budgeting for a club project, or 

collecting marks from different teachers, spreadsheet software helps you collect, 

organize, and prepare the data for analysis. 

 
Why Collect and Organize Real-World Data? 

  Connects learning to real-life situations 

  Builds skills in data gathering and management 

  Helps you develop critical thinking and analysis skills 

  Supports decision-making using accurate information 

  Prepares learners for project work, business planning, and academic research 

      Example: A group of S4 students conducts a survey on students’ internet usage 

and uses Excel to record, organize, and analyze the responses. 
 

   Sources of Real-World Data 

Source Type of Data You Can Collect 

School environment Attendance records, performance data, ICT usage 

Community surveys Income levels, business activities, education levels 

Personal records Expenses, time logs, mobile usage 

Internet or books Public datasets, research findings, statistical reports 
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Step-by-Step: Collecting and Organizing Data in Excel 

1. Plan what data to collect (define purpose and questions) 

2. Choose appropriate data categories/fields (e.g., Name, Age, Gender, Score) 

3. Use paper survey forms or interviews to collect data 

4. Open Excel → Create column headings based on your fields 

5. Enter the collected data row by row 

6. Format the worksheet: bold headings, apply borders, highlight totals 

   Tip: Organize similar data together (e.g., numeric values in one column, 

names in another). 

 
          Activity 6.1.6: Group Survey and Spreadsheet Entry 

1. In small groups, conduct a classroom survey (e.g., “Student Hobbies”, 

“Favorite ICT Tool” or “Daily Transport Mode”) 

2. Design a simple survey form or table with fields like: 

o Name | Gender | Favorite Tool | Frequency of Use 

3. Enter the collected data into Excel 

4. Format the worksheet clearly and save it as “ICT_Tool_Survey.xlsx” 

   Bonus: Use filters to view how many students prefer each tool. 

 
Extension Task: Organizing Club or School Project Data 

1. Choose a real scenario (e.g., a school trip or club project) 

2. Collect data such as:  

o Participants | Roles | Contributions | Contact Information 

3. Organize data into an Excel sheet 

4. Apply formatting for clarity and presentation 

   Discuss: How was this better than keeping data in a notebook? 

 
Best Practices in Data Collection and Organization 

  Design your data fields before collecting 

  Use clear, consistent naming and formatting 

  Always verify entries before analysis 

  Store your file with a meaningful name and location 

  Protect sensitive data if necessary (e.g., using password or saving on a 

secure device) 
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   Reflection Questions 

• What methods can you use to collect real-world data? 

• How does spreadsheet software help you organize collected data? 

• What challenges did you face during the data entry process? 
 

6.1.7 Using Online Tools for Data Collection 
In the modern digital world, collecting data no longer has to be done using paper 

forms only. Today, there are online tools that make data collection faster, easier, 

and more organized. These tools allow you to create digital surveys or forms that 

can be shared with people through the internet, and responses are collected 

automatically in a spreadsheet format. 

In this section, you will learn how to use online tools like Google Forms, Microsoft 

Forms, and other web-based platforms to collect real-world data and organize it 

efficiently for analysis using spreadsheet software. 

 
Why Use Online Tools for Data Collection? 

  Allows faster data collection from many people 

  Automatically stores responses in a spreadsheet 

  Reduces paperwork and human error 

  Enables real-time response tracking and analysis 

  Accessible from any device (computer, phone, tablet) 

      Example: A school ICT club conducts a survey using Google Forms to gather 

students' opinions on introducing a new computer lab. All responses are saved 

directly in Google Sheets, ready for analysis. 
 

   Popular Online Data Collection Tools 

Tool Features Best Use Case 

Google Forms Free, user-friendly, links to 

Google Sheets 

School surveys, quizzes, event 

registration 

Microsoft Forms Easy to use, links to Excel 

Online 

Student assessments, feedback 

forms 

JotForm / Typeform Professional form layouts, 

advanced logic 

Community surveys, business 

data collection 



230 

 

   Tip: You only need a Google or Microsoft account to start creating online 

forms. 

 
Step-by-Step: Creating a Google Form for Data Collection 
 

1. Open your browser → Go to https://forms.google.com 

2. Click Blank Form 

3. Type your Form Title and Description 

4. Add different types of questions:  

o Short answer, multiple choice, checkboxes, dropdown, etc. 

5. Click Send → Copy Link or Email the form to respondents 

6. Click Responses → View in Sheets to open the collected data in Google 

Sheets 

   Tip: You can use QR codes or email to share your form quickly. 

 
Figure 63: Using Google Forms to Collect Data 

 
          Activity 6.1.7: Create a Digital Survey and Collect Responses 
 

1. Design a digital form titled “Digital Literacy Survey” 

2. Add questions like:  

o Name, Age, Gender, Class, Do you own a smartphone?, Have you 

used Excel before? 

3. Share the form with classmates or friends 

4. View and organize the responses in Google Sheets 

5. Download and open the file in Excel for further formatting 

https://forms.google.com/
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   Extension Task: Collecting Community Data Digitally 

1. In small groups, prepare a survey titled “ICT Access in Our Community” 

2. Questions could include:  

o Occupation, ICT devices owned, Internet usage, Preferred ICT 

training areas 

3. Use Google Forms or Microsoft Forms to collect responses 

4. Organize and present the results using spreadsheet tools and charts 

 
Best Practices for Online Data Collection 

  Keep your questions simple and clear 

  Test your form before sharing it widely 

  Use multiple question types (e.g., short answer, dropdown, multiple 

choice) 

  Always review and organize your responses in a spreadsheet 

  Save backups of downloaded data 

 
   Reflection Questions 

• How does online data collection differ from manual data collection? 

• What advantages do tools like Google Forms offer? 

• How can you use spreadsheet software to organize collected digital 

responses? 

 

Figure 64: Exporting Google responses to Excel / Google sheets 
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6.2 Manipulate and Analyze Data to Gain Insights 
 
Collecting and organizing data is just the beginning. The real power of a 

spreadsheet lies in its ability to manipulate and analyze data to make meaningful 

conclusions and informed decisions. This includes applying formulas and functions, 

analyzing trends, comparing data, and using logical and statistical tools to discover 

useful patterns. 

 
Why Data Analysis Is Important 

  Helps to summarize large datasets 

  Supports decision-making in real life 

  Reveals trends, averages, totals, and patterns 

  Increases productivity and accuracy in tasks like budgeting, 

performance monitoring, and sales analysis 

      Example: A school bursar uses Excel functions to calculate total fees collected, 

outstanding balances, and identify students with unpaid dues. 

 
   Examples of Data Analysis in Real Life 

Scenario Spreadsheet Analysis Used 

Student marks analysis AVERAGE, MAX, MIN functions to evaluate performance 

Business sales report SUM and IF functions to track profits or filter top-selling 

items 

Household budget 

tracking 

Calculating total expenses and balance 

Attendance monitoring COUNT function to identify present/absent records 

Community survey results Calculating frequency and percentages 

 

Key Concepts to Understand 

Term Meaning 

Formula A custom calculation you write using cell references (e.g., 

=B2+C2) 

Function A built-in formula in Excel that performs a specific task 

(e.g., =SUM(A1:A5)) 



233 

 

Cell Reference Refers to the location of a value in the worksheet (e.g., 

A1) 

Relative and Absolute 

Reference 

Relative adjusts when copied (A1), Absolute stays fixed 

($A$1) 

 
Quick Starter Activity: Exploring Formula Concepts 

1. Open your Student Marks Worksheet 

2. In the Total column, write a formula to sum subject marks: =B2+C2+D2 

3. In the Average column, use the function: =AVERAGE(B2:D2) 

4. Discuss: What happens if you change one subject mark? How does the 

total update? 

 
   Reflection Questions 

• Why is data analysis an important skill in today’s digital world? 

• How do formulas and functions help in understanding your data better? 

• What types of analysis would be useful in your school or community? 

 
6.2.1 Using Formulas for Data Analysis 
 
Formulas are the backbone of spreadsheet calculations. They allow users to 

perform custom calculations using numbers, cell references, and mathematical 

operators. With formulas, you can quickly calculate totals, balances, differences, 

and more — without doing manual arithmetic. 

 

Why Use Formulas in Spreadsheets? 

  Speeds up calculations 

  Reduces errors compared to manual calculations 

  Updates automatically when data changes 

  Helps analyze data such as totals, averages, balances, and differences 

      Example: A student calculating total marks for English, Math, and Science in 

Excel writes a formula: =B2+C2+D2 — and Excel does the work! 
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Common Mathematical Operators Used in Formulas 

Operator Function Example 

+ Addition =B2+C2 

- Subtraction =C2-D2 

* Multiplication =B2*E2 

/ Division =D2/E2 

= Start of every formula =B2+C2 

   Tip: A formula always starts with an equal sign (=) in Excel or Google Sheets. 
 

Step-by-Step: Creating a Formula in Excel 
 

1. Click the cell where you want your result to appear 

2. Type the equal sign (=) 

3. Click or type the cells you want to calculate 

4. Use operators (e.g., +, -, *, /) as needed 

5. Press Enter to see the result 

   Example: To add values in cells B2 and C2, type: =B2+C2 

 
          Activity 6.2.1: Basic Formula Practice Task 

1. Open your “Term Two Results” worksheet 

2. Add a column titled “Total” 

3. Enter a formula in the first row to calculate total marks: 

=C2+D2+E2 (assuming marks are in columns C, D, E) 

4. Copy the formula down using AutoFill handle (bottom-right corner of the 

cell) 

5. Add another column titled “Balance” to subtract actual fees paid from total 

fees required 

   Try this subtraction formula: =F2-G2 

 
Extension Task: Personal Shopping Budget Worksheet 

1. Create a worksheet with columns: Item | Quantity | Unit Price | Total Cost 

2. Use multiplication formula: 

=Quantity * Unit Price → =B2*C2 

3. Calculate total cost per item, then sum all totals using =SUM() (next lesson) 
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Best Practices When Using Formulas 

  Always begin formulas with = 

  Use correct cell references (e.g., A1, B3) 

  Use AutoFill to apply formulas quickly 

  Always double-check results for accuracy 

  Avoid typing numbers directly into formulas — use cell references instead 

 
   Reflection Questions 

• How do formulas make your work easier in a spreadsheet? 

• What would happen if you change a value in one cell that’s used in a 

formula? 

• What real-life situations could you solve using formulas in spreadsheets? 

 
6.2.2 Applying Statistical, Mathematical, and Date/Time Functions 
 
Spreadsheet software comes with predefined formulas called functions that help 

you analyze, summarize, and calculate data quickly and accurately. These 

functions are more powerful than simple arithmetic formulas because they can 

work on entire ranges of data and perform advanced operations. 

 

Why Use Functions in Data Analysis? 

  Speeds up complex calculations 

  Reduces errors in manual work 

  Automatically updates when values change 

  Helps in summarizing large datasets quickly 

  Useful in reporting, budgeting, monitoring performance, and 

scheduling 

      Example: A teacher uses the AVERAGE function to calculate the class average 

in a test. When new marks are added, the average updates automatically. 

 
Common Spreadsheet Functions and Their Uses 

Function Purpose Example Use 

=SUM(range) Adds values in a range Total marks or expenses 

=AVERAGE(range) Calculates mean value Class average 

=MIN(range) Finds the smallest value Lowest score in a test 
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=MAX(range) Finds the highest value Top mark in a subject 

=COUNT(range) Counts number of numeric 

entries 

Number of students who sat the 

test 

=COUNTA(range) Counts all non-empty cells Total entries including text 

=NOW() Displays current date and time Time record on a receipt 

=TODAY() Displays current date only Attendance date tracking 

 
Step-by-Step: Applying Functions in Excel 

1. Click the cell where you want the result to appear 

2. Type =FUNCTION_NAME(range) — e.g., =SUM(B2:B6) 

3. Press Enter 

4. Use AutoFill if you want to apply the same function for other ranges 

   Tip: You can also click AutoSum (∑) from the toolbar for quick totals. 

 
          Activity 6.2.2: Practice Using Statistical Functions 

1. Open your “Term Two Results” worksheet 

2. Add a row labeled “Class Summary” below the student records 

3. Apply:  

o =SUM() for total class marks in English, Math, Science 

o =AVERAGE() for subject averages 

o =MAX() and =MIN() to find top and lowest scores per subject 

o =COUNT() to count how many students submitted scores 

   Bonus: Highlight top performers using bold font or shading. 
 

          Activity 6.2.2 (Continued): Using Date and Time Functions 

1. In a new cell, enter =TODAY() to show current date 

2. Enter =NOW() to show both date and current time 

3. Discuss how these functions could be useful in:  

o Attendance registers 

o Payment receipts 

o Event planning 
 

Extension Task: School Fee Tracking Sheet 

1. Create a table with: Student Name | Fees Paid | Date of Payment 
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2. Use =SUM() to calculate total fees paid 

3. Use =TODAY() to track the payment date 

4. Format date columns properly using Date format 

 
Best Practices When Using Functions 

  Always use correct function syntax (e.g., =SUM(A1:A5)) 

  Double-check cell ranges before applying 

  Combine functions for advanced analysis (e.g., =AVERAGE(B2:B10)-

MIN(B2:B10)) 

  Format your results (e.g., use Currency or Date format where needed) 

  Save your work regularly to avoid data loss 

 
   Reflection Questions 

• Which function do you find most useful, and why? 

• How do statistical functions help in understanding your data? 

• How can date and time functions be applied in real-world scenarios like 

school or business? 

 
6.2.3 Using Logical Functions (IF, VLOOKUP, HLOOKUP) for Data Analysis 

Logical functions help us perform conditional analysis — where decisions or results 

depend on whether a condition is true or false. Spreadsheet software provides 

logical functions like IF, VLOOKUP, and HLOOKUP that allow you to automate 

decisions and look up values from large datasets without manually searching. 

 

Why Use Logical Functions? 

  Automates decision-making based on conditions 

  Helps classify or categorize data easily 

  Allows you to extract data quickly from large tables 

  Reduces time spent on manual searching and filtering 

      Example: A student uses an IF function to determine whether each classmate 

passed or failed based on their average marks. 
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Common Logical Functions and Their Uses 

Function Purpose Example Use 

=IF(condition, value_if_true, 

value_if_false) 

Returns one value if 

condition is TRUE, 

another if FALSE 

Show “Pass” if marks 

≥ 50, else “Fail” 

=VLOOKUP(lookup_value, table_array, 

column_index, [range_lookup]) 

Searches vertically in 

a table and returns a 

value 

Retrieve a student’s 

class from a list 

=HLOOKUP(lookup_value, table_array, 

row_index, [range_lookup]) 

Searches horizontally 

in a table and returns 

a value 

Retrieve monthly 

sales data by item 

 
Step-by-Step: Using the IF Function 
 

1. Select the cell where the result should appear 

2. Type the formula using the syntax: 

=IF(condition, value_if_true, value_if_false) 

Example: =IF(D2>=50, "Pass", "Fail") (D2 = Average Mark) 

3. Press Enter, then use AutoFill to apply to other rows 

   Tip: You can combine IF with other functions for more complex decisions 

(e.g., nested IFs). 

 

Figure 65: Excel spreadsheet showing Pass/Fail column created using IF() 
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Step-by-Step: Using the VLOOKUP Function 
 

1. Create a lookup table on a separate sheet or nearby columns 

Example: 

Student Class 

Alice S4 

Ben S3 

2. In a new cell, enter: 

=VLOOKUP("Alice", A2:B5, 2, FALSE) → Result will be “S4” 

   Tip: Replace "Alice" with a cell reference for dynamic lookup (e.g., 

=VLOOKUP(A2, A2:B5, 2, FALSE)) 
 

 
Step-by-Step: Using the HLOOKUP Function 
 

1. Create a horizontal table 

Example: 

Item Maize Beans Rice 

Price 2000 3000 2500 

2. In a new cell, type: 

=HLOOKUP("Rice", A1:D2, 2, FALSE) → Result is “2500” 

   Use cell references instead of text directly for dynamic lookup. 

 
          Activity 6.2.3: Applying IF and Lookup Functions 
 

1. Open your “Term Two Results” worksheet 

2. Add a new column titled “Status” 

3. Use =IF(Average>=50, "Pass", "Fail") 

4. Create a lookup table for Class Teachers: 

Class Class Teacher 

S4 Mr. Kamya 

S3 Ms. Namaganda 

5. Use =VLOOKUP(Class, table_range, 2, FALSE) to display each student's class 

teacher 
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   Extension Task: Using Logical Functions in Business 

1. Create a product price list and a sales record sheet 

2. Use VLOOKUP to pull product prices from the price list into the sales sheet 

3. Calculate total cost using =Quantity * Price 

4. Use an IF formula to offer a discount if total is above UGX 100,000 

 
   Best Practices for Logical Functions 

  Always check that lookup tables are correctly referenced 

  Use absolute references ($) when fixing lookup ranges 

  Keep formulas simple and easy to understand 

  Test your formulas with sample data before applying to entire dataset 

  Save your work regularly 

 

   Reflection Questions 

• How does the IF function help in decision-making? 

• When would you use VLOOKUP instead of manually searching a table? 

• What challenges might arise when using logical functions? 

 

6.2.4 Consolidating Data Using Pivot Tables 
 

When you have a large amount of data from multiple sources or different 

categories, it can be difficult to summarize or interpret it clearly. Pivot Tables are 

powerful tools in spreadsheet software that help you consolidate, group, and 

analyze data efficiently. 

 

Why Use Pivot Tables? 

  Organize complex data into meaningful summaries 

  Consolidate totals, averages, or counts by group 

  Quickly rearrange data without changing the original table 

  Improve decision-making through simplified reports 

      Example: A teacher has a large table with student marks in different subjects 

and uses a Pivot Table to summarize the total and average marks per class. 
 
 
 
 



241 

 

 
Real-Life Applications of Pivot Tables 

Scenario How Pivot Tables Help 

School academic performance Summarize total/average marks per class or subject 

Sales tracking Compare sales by product or region 

Budget analysis Total expenses by category 

Survey analysis Count responses per gender or age group 

 
Key Terms in Pivot Tables 

Term Meaning 

Row Labels Categories to group data by rows (e.g., Class, Item) 

Column Labels Categories to group data by columns (e.g., Gender, Term) 

Values Data to be summarized (e.g., SUM of scores, AVERAGE of costs) 

Filters Conditions to narrow down data (e.g., filter only S4 students) 

 
Step-by-Step: Creating a Pivot Table in Excel 
 

1. Prepare your data with clear column headers (no merged cells) 

2. Select the entire dataset 

3. Click Insert → PivotTable 

4. Choose New Worksheet or Existing Worksheet for the Pivot Table location 

5. In the Pivot Table Field List, drag:  

o Row Labels (e.g., Class, Student Name) 

o Column Labels (e.g., Subject) 

o Values (e.g., Sum or Average of Marks) 

6. Analyze the summarized table and apply formatting as needed 

   Tip: You can change the summary function (SUM, AVERAGE, COUNT) by 

clicking the value field → “Value Field Settings”. 
 

          Activity 6.2.4: Creating a Pivot Table for Student Results 
 

1. Open your “Term Two Results” worksheet 

2. Select the full table (including Student Name, Class, Subjects, Marks) 

3. Insert a Pivot Table 

4. Summarize:  

o Total Marks per Class 
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o Average Marks per Subject 

   Bonus: Add filters to analyze by gender or performance level. 
 

Extension Task: Pivot Table in School Budget Analysis 

1. Create a dataset with: Item | Category | Term | Cost 

2. Insert a Pivot Table to:  

o Show Total Cost per Category 

o Show Total Cost per Term 

o Filter only Term 1 expenses 

 

Figure 66: Pivot Table showing regional sales breakdown 
 

Best Practices When Using Pivot Tables 

  Ensure your source data has no blank rows or columns 

  Use meaningful headings and labels 

  Keep Pivot Tables simple and well-formatted 

  Always refresh Pivot Tables if the source data changes 

  Practice building different layouts to explore data from various angles 

 
   Reflection Questions 

• How does a Pivot Table help in summarizing large data? 

• What are the advantages of Pivot Tables over ordinary tables? 

• What other school or community data could you analyze using Pivot 

Tables? 
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6.2.5 Peer Reviewing and Improving Spreadsheets 

Just like in writing or designing documents, reviewing and improving spreadsheets 

is essential for accuracy, clarity, and presentation. Peer review allows learners to 

evaluate each other’s work, provide constructive feedback, and make 

improvements in structure, calculations, formatting, and visual presentation. 

 
Why Peer Review Is Important 

  Encourages collaborative learning and critical thinking 

  Helps identify errors or missing information 

  Improves layout and data presentation 

  Builds teamwork, communication, and feedback skills 

  Prepares learners for real-life collaborative work environments 

      Example: Two students working on a budgeting worksheet review each other’s 

spreadsheets to check whether totals and formulas are correct and if charts are 

clearly labeled and readable. 

 
Key Areas to Review in a Spreadsheet 

Aspect to Review What to Check 

Data Accuracy Correct entries, no spelling or numeric errors 

Formulas and Functions Correct use of SUM, AVERAGE, IF, etc. 

Formatting Clear headings, borders, cell alignment, bold totals 

Layout and Organization Logical arrangement of columns/rows, use of 

merged cells or headings 

Charts and Visuals Clear labels, appropriate chart types, titles 

Clarity and Readability Easy to understand, consistent formatting 

Documentation and File 

Naming 

Proper file names, structured worksheet tabs 

 
Step-by-Step: Conducting Peer Review of a Spreadsheet 

1. Exchange your spreadsheet with a partner 

2. Review the spreadsheet based on a checklist 

3. Use comments or notes to suggest improvements 

4. Discuss the feedback face-to-face or in a group 
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5. Apply corrections and enhancements to your spreadsheet 

6. Save the improved version with a revised file name 

 
Sample Peer Review Checklist 

Criteria Yes / No Comments 

Are formulas used correctly?   SUM works well, check IF formula 

Is data arranged logically?   Consider rearranging column order 

Are charts clearly labeled? ✘ Add axis titles to bar chart 

Is formatting consistent?   Good use of bold and color 

Any spelling or numeric errors? ✘ Spelling error in “Expenditure” 

   Tip: Save reviewed work as “Student_Performance_Reviewed.xlsx” 

 
          Activity 6.2.5: Peer Review and Improvement Task 
 

1. Create a spreadsheet project (e.g., Student Marks, Monthly Budget, or Club 

Records) 

2. Exchange your file with a classmate 

3. Review and give feedback using a checklist 

4. Revise your spreadsheet based on the comments 

5. Present the improved version to the class 
 

Extension Task: Group Spreadsheet Quality Evaluation 

1. In small groups, rotate multiple spreadsheets 

2. Each group reviews a spreadsheet and provides oral or written feedback 

3. Create a summary report showing:  

o Key strengths 

o Areas needing improvement 

o Suggestions for better analysis or layout 
 

Best Practices for Reviewing and Improving Spreadsheets 

  Be respectful and constructive in feedback 

  Check both content and appearance of the spreadsheet 

  Use comments and annotations to suggest edits 

  Apply consistent formatting and structure 

  Always test formulas and charts after corrections 
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   Reflection Questions 

• What did you learn by reviewing another person’s spreadsheet? 

• How did peer feedback help you improve your spreadsheet? 

• What aspects of spreadsheet design are often overlooked but important? 

 

Figure 67: Spreadsheet under review with comments or corrections 

 

6.3 Create Visual Objects (Charts, Graphs) to Present Data 
 
Charts and graphs are powerful tools used in spreadsheets to represent numerical 

data visually, making it easier to understand patterns, comparisons, and trends. 

Instead of looking at rows and columns of numbers, charts help you interpret the 

data quickly and communicate findings clearly. 

 
   Why Use Charts and Graphs? 

  Visualize data for easier interpretation 

  Highlight trends, comparisons, or relationships 

  Present complex data in a simple format 

  Improve clarity and communication in reports and presentations 

  Enhance the professional appearance of your spreadsheet 

      Example: A student preparing a report on school performance uses a bar chart 

to show the average marks per subject — making the results more engaging and 

easier to analyze. 
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Step-by-Step: Creating a Chart in Excel 
 

1. Highlight the data you want to chart (including headers) 

2. Click Insert → Choose Chart Type (e.g., Column, Pie, Line) 

3. Customize your chart:  

o Add Chart Title and Axis Titles 

o Adjust color and style under Chart Design 

o Add Data Labels if needed 

4. Move or resize the chart on your worksheet for clarity 

   Tip: Right-click any part of the chart to format it or change chart type. 

 
          Activity 6.3: Practice Task – Creating a Chart 
 

1. Open your “Term Two Results” worksheet 

2. Select Average Marks per Subject 

3. Insert a Bar Chart showing performance in English, Math, Science 

4. Add:  

o Chart Title: “Average Subject Performance” 

o Axis Titles: Subject (X-axis), Average Marks (Y-axis) 

o Data Labels to show exact values 
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6.3.1 Exploring Chart Types in Spreadsheet Software 
 
Spreadsheet software like Microsoft Excel, Google Sheets, and LibreOffice Calc 

provides a wide range of chart types to help users present data in visual formats 

that are clear, attractive, and easy to understand. 

 
   Why Explore Different Chart Types? 

  Different chart types suit different kinds of data 

  Makes your reports and presentations more engaging 

  Helps readers grasp key insights quickly 

  Supports better decision-making by comparing and interpreting data 

visually 

      Example: A school administrator uses a Pie Chart to show how the budget is 

shared among departments, and a Line Graph to show student enrollment over 5 

years. 

 
Common Chart Types and Their Uses 
 

Chart Type Description Best Use Cases 

Column 

Chart 

Vertical bars to compare values Marks per student, item costs 

Bar Chart Horizontal bars for comparison Survey results, sales per region 

Pie Chart Circular chart showing parts of a 

whole 

Budget distribution, market share 

Line Graph Shows changes or trends over 

time 

Student attendance per term, 

rainfall data 

Area Chart Filled version of line graph 

showing total values 

Revenue growth 

Combo 

Chart 

Combines two chart types (e.g., 

line + bar) 

Comparing test scores and 

attendance 

Scatter Plot Plots individual data points Scientific measurements, exam 

score distribution 

   Tip: The Insert → Chart menu in Excel gives a preview of chart types and allows 

switching between types easily. 
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Factors to Consider When Choosing a Chart Type 

  Nature of data (comparison, distribution, trend) 

  Number of categories or data points 

  Audience — which type is easiest for them to interpret 

  Space available for displaying the chart 

  Purpose of communication (summary or detail) 
 

          Activity 6.3.1: Chart Type Exploration Task 
 

1. Open a sample worksheet (e.g., student marks or budget data) 

2. Try inserting the same data using different chart types:  

o Column Chart 

o Pie Chart 

o Line Graph 

3. Compare the effectiveness and clarity of each chart type 

4. Discuss with a classmate:  

o Which chart type is most suitable and why? 

   Bonus: Present your findings to the class, showing the same dataset in 3 

different chart types. 
 

Extension Task: Chart Type Matching Game 
 

1. Your teacher gives you a list of data scenarios (e.g., budget distribution, 

rainfall patterns, attendance records) 

2. In groups, match each scenario with the most appropriate chart type 

3. Justify your choice to the class 

Scenario Best Chart Type Reason 

Student marks by subject Bar Chart Easy comparison 

Monthly rainfall data Line Graph Shows trend 

School budget breakdown Pie Chart Shows proportions 
 

 
Best Practices When Creating Charts 

  Select appropriate chart type for your data 

  Always add titles and labels for clarity 

  Avoid clutter — keep charts simple and readable 

  Use consistent colors and styles 

  Preview the chart before printing or sharing 
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   Reflection Questions 

• Why are charts better than plain tables in some cases? 

• Which type of chart do you prefer and why? 

• What are the most common mistakes people make when creating charts? 

 
6.3.2 Presenting Data Using Appropriate Visualization Objects 

After choosing the right chart type, it is important to present your data clearly and 

effectively using suitable visualization objects such as charts, graphs, labels, 

legends, and titles. Good presentation ensures that the message in your data is 

easy to understand and visually engaging. 

 
      Example: A school bursar uses a Pie Chart in a staff meeting to show how the 

term’s budget is allocated, making it easier for non-technical staff to understand 

financial figures. 

 

Figure 68: A fully customized Excel chart showing title, axis labels, and color formatting 

 
6.3.3 Customizing Charts for Clarity and Presentation 
 
A chart becomes more effective when it is not only accurate but also clear, visually 

appealing, and easy to understand. Customizing your charts involves changing 

their appearance, layout, labels, and color schemes to make them communicate 

your message better. 
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Why Customize Charts?  

  Helps highlight the most important information 

  Improves chart readability and attractiveness 

  Makes data easier to interpret for different audiences 

  Enhances the overall presentation quality of your spreadsheet or report 

      Example: A student presenting a performance chart for English, Math, and 

Science changes the bar colors, adds data labels, and uses a bold title and axis 

labels so that the teacher and classmates understand it at a glance. 

 
Common Chart Customization Options 

Customization 

Option 

Purpose How It Helps 

Chart Title Describes the chart content Makes the chart meaningful 

Axis Titles Labels for X and Y axes Helps interpret chart data 

Data Labels Show values on chart Makes values visible without 

guessing 

Legend Position Explains chart elements Clarifies multiple data series 

Chart Style and 

Color 

Change visual appeal Attracts attention and improves 

contrast 

Gridlines Support visual alignment Improves value estimation 

Font and Size Adjust text appearance Enhances readability 

Chart Layout Change arrangement of 

elements 

Creates a professional look 

   Tip: All customization tools can be found under Chart Tools – Design and 

Format tabs in Excel or Chart Editor in Google Sheets. 

 
Step-by-Step: Customizing a Chart in Excel 
 

1. Click on the Chart to activate customization options 

2. Go to Chart Design and Format tabs 

3. Customize:  

o Chart Title → Edit text 

o Axis Titles → Add and label appropriately 

o Change Colors → Chart Styles or Format Data Series 

o Add Data Labels → Show actual values on bars or lines 
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o Move Legend to top/bottom/right/left for better clarity 

o Apply a Chart Style from the Design tab 

   Tip: Use consistent colors and font styles to keep a professional appearance. 
 

          Activity 6.3.3: Practice Task – Customizing a Student Marks Chart 
 

1. Open your “Term Two Results” worksheet 

2. Create a Column Chart of average subject performance 

3. Customize:  

o Chart Title → “Average Marks per Subject – S5” 

o Axis Titles → X-axis: Subject, Y-axis: Average Marks 

o Add Data Labels to display average values on bars 

o Change bar colors to different shades per subject 

o Adjust font size and apply a readable font style 
 

Extension Task: Create a Fully Customized Visual Report 

1. Design a report titled “Monthly ICT Club Expenses” 

2. Add a Pie Chart and Bar Chart from the data 

3. Customize the charts:  

o Titles, Data Labels, Font Styles, Chart Styles, Colors 

o Remove gridlines or add background shading (optional) 

4. Save or print your final report for class display 
 

Best Practices in Chart Customization 

  Use bold, readable fonts for titles and labels 

  Keep color contrast high for better visibility 

  Use uniform formatting styles across charts in a report 

  Don’t overload charts with too much text or decoration 

  Ensure all chart elements (title, labels, legend) are included 

 
   Reflection Questions 

• Why is it important to choose proper visualization elements? 

• How does chart customization improve presentation quality? 

• Which customization feature did you find most helpful? 

• What can go wrong when charts are not properly formatted? 

• What challenges did you face when formatting charts? 
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6.3.4 Creating a Combo Chart for Data Comparison 
 

Sometimes, one type of chart is not enough to show different types of information 

clearly. That’s where Combo Charts come in. A Combo Chart combines two or more 

chart types (such as a bar chart and a line graph) in one chart. This helps you to 

compare multiple data sets more effectively. 

 
Why Use Combo Charts? 

  Helps compare two or more different types of data clearly 

  Combines visual strengths of multiple chart types 

  Makes data interpretation easier for mixed information 

  Useful when data has different scales or units 

      Example: A student creates a Combo Chart showing monthly internet usage 

(bar chart) and monthly costs (line graph) to understand how increased use affects 

cost. 

 

Figure 69: A combo chart with bars and line representing different data sets on dual axes 
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Common Combo Chart Applications 

Use Case Bar Chart Shows Line Chart Shows 

Academic performance Subject Marks Average Class Performance 

Sales report Quantity Sold Revenue Generated 

Budget analysis Actual Spending Budgeted Amount 

Student analysis Test Scores Attendance Rates 

 
Step-by-Step: Creating a Combo Chart in Excel 
 

1. Select your dataset (including headers for two different types of data) 

Example: 

Month Sales Profit 

Jan 500,000 200,000 

2. Click Insert → Combo Chart → Custom Combo Chart 

3. Assign: 

o Bar Chart to Sales 

o Line Chart to Profit 

4. Check Secondary Axis if values have different scales 

5. Add: 

o Chart Title 

o Axis Titles and Labels 

o Legend for clarity 

   Tip: Customize each chart type individually using Chart Tools → 

Format/Design Tabs 
 

          Activity 6.3.4: Practice Task – Comparing Marks and Attendance 
 

1. Open a worksheet titled “Term Two Student Analysis” 

2. Columns: Student Name | Average Mark | Attendance (%) 

3. Create a Combo Chart:  

o Bar Chart for Average Mark 

o Line Chart for Attendance Percentage 

4. Add:  
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o Chart Title:  “Academic Performance vs. Attendance” 

o Axis Titles for clarity 

o Secondary Axis for Attendance if necessary 
 

Extension Task: Monthly Sales and Expenses Comparison 
 

1. Create a worksheet titled “Monthly Sales vs Expenses” 

2. Columns: Month | Sales | Expenses 

3. Insert a Custom Combo Chart:  

o Bar Chart for Sales 

o Line Chart for Expenses 

4. Customize titles, axis labels, data labels, and colors 

5. Analyze: In which month was profit highest? Lowest? 
 

Best Practices for Combo Charts 

  Use contrasting colors for different chart types 

  Always label axes and legends clearly 

  Use secondary axis only when necessary 

  Keep layout simple and easy to read 

  Test different combinations for clarity 

 
   Reflection Questions 

• How do Combo Charts help in comparing two different data sets? 

• When would you use a combo chart instead of two separate charts? 

• What challenges did you face when customizing the Combo Chart? 

 
6.3.5 Collaborating Online to Analyze and Visualize Data 
 

In today’s digital world, learners and 

professionals often work together remotely 

using online tools to collect, analyze, and present 

data. Spreadsheet software like Google Sheets 

and Microsoft Excel Online supports real-time 

collaboration, allowing multiple users to edit, 

analyze, and visualize data together on the same 

document from different locations. 
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Why Collaborate Online?  

  Encourages teamwork and digital communication 

  Saves time by allowing multiple users to work at once 

  Enables real-time editing and feedback 

  Helps in joint analysis, decision-making, and report creation 

  Prepares learners for the modern digital workplace 

      Example: A group of students works on a shared Google Sheet to collect survey 

responses, apply formulas, and insert charts to analyze results from different school 

clubs. 
 

Tools for Online Collaboration in Spreadsheets 

Tool Features Best Use Case 

Google Sheets Real-time editing, auto-save, 

comment and chat features 

School group projects, 

peer feedback 

Microsoft Excel 

Online 

Live co-authoring, integrated with 

OneDrive 

Team data analysis and 

reporting 

Zoho Sheet / WPS 

Office Cloud 

Free collaborative features Basic joint data entry 

tasks 

   Tip: All you need is a Google or Microsoft account to collaborate online. 
 

Key Features that Support Collaboration 

Feature Purpose 

Share Button Invite others to view or edit the file 

Comment Tool Leave feedback or suggestions 

Version History Track changes and restore previous edits 

Chat / Notes Discuss work inside the document 

Live Cursors See where others are working in real time 

 
Step-by-Step: Collaborating in Google Sheets 

1. Create or open a Google Sheet 

2. Click “Share” → Enter collaborators’ emails 

3. Choose editing, viewing, or commenting rights 

4. Collaborators can join and work in real-time 

5. Use comments or chat box to discuss entries or formulas 

6. Insert charts and analysis collaboratively 
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          Activity 6.3.5: Collaborative Data Analysis Task 
 

1. In small groups, create a shared Google Sheet titled “School ICT Usage 

Survey” 

2. Each group member:  

o Enters part of the data 

o Applies formulas (e.g., AVERAGE, MAX, MIN) 

o Creates one chart (bar or pie) to present a dataset 

3. Leave comments on each other’s work suggesting improvements 

4. Present the final visualized dataset to the class 

   Bonus: Export charts into Google Slides or PowerPoint for presentation. 

 
Extension Task: Virtual Peer Review and Improvement 

1. Share your spreadsheet project with a classmate (from another group) 

2. Request peer feedback using comments 

3. Respond to suggestions and improve your data visualization 

4. Submit both the original and improved versions 

 

Figure 70: A shared spreadsheet with multiple users editing and viewing charts in real-

time 

 
Best Practices for Online Spreadsheet Collaboration 

  Assign roles and responsibilities in your group 

  Communicate clearly using chat or comments 

  Be respectful and constructive in peer feedback 

  Always save and name your file versions clearly 

  Use Version History to track progress 
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   Reflection Questions 

• How does online collaboration improve teamwork in data analysis? 

• What tools/features helped you work better as a group? 

• What challenges did you face while collaborating online? 

 

Sample Activity of Integration 
 

     Scenario: A school bursar wants an automated financial record to track student 

fees, payments, and outstanding balances. 

Task: 

Using Microsoft Excel, design a fees management spreadsheet that calculates total 

payments, outstanding balances, and generates a summary report using formulas, 

functions, and charts. 

 
Self-Assessment Questions 

 
1. What is spreadsheet software, and what are its key uses? 

2. Differentiate between a cell, a row, and a column in a spreadsheet. 

3. List three common spreadsheet formulas and explain their functions. 

4. Explain how charts and graphs help in data presentation. 

5. Compare the benefits of Microsoft Excel vs. Google Sheets. 

6. How can spreadsheets be used in budgeting and financial management? 

 

 

In this topic you have learnt about: 

 collect and organize data 

 manipulate and analyze data to gain insights. 

 create visual objects (charts, graphs) to 

present data. 

To
p

ic
 S

u
m

m
a

ry
 



258 

 

 

Glossary  
 

Animations Visual effects applied to objects in a slide to 

enhance engagement. 

Application Software Programs designed for specific tasks like word 

processing or web browsing. 

Audience Engagement Techniques used to keep an audience interested 

during a presentation. 

Automated Slide Show A presentation that advances slides automatically 

without manual input. 

BIOS/UEFI Firmware that initializes hardware during startup. 

Booting Process The startup sequence of a computer that loads the 

operating system. 

Bullets and Numbering Used to create ordered and unordered lists in a 

document. 

Cell The intersection of a row and column where data is 

entered. 

Charts and Graphs Visual representations of data to improve 

understanding. 

Cloud Storage Storing data on remote servers accessed via the 

internet (e.g., Google Drive). 

Cloud-Based Word 

Processing 

Using online platforms such as Microsoft OneDrive 

and Google Docs for real-time document 

collaboration. 

Collaboration Tools Cloud-based platforms that enable multiple users 

to edit presentations in real time (e.g., Google 

Slides, Microsoft PowerPoint Online). 

Column A vertical arrangement of cells in a spreadsheet. 

Communication Devices Hardware used for network connectivity (e.g., 

router, modem, NIC). 
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Computer Assembly The process of putting together computer 

components. 

Computer System A combination of hardware and software working 

together to process data. 

Conditional Formatting A tool that highlights data based on predefined 

conditions. 

Customization Adjusting fonts, colors, and slide elements to 

improve visual appeal. 

Cybersecurity Protecting digital devices and data from threats like 

hacking and malware. 

Data Consolidation Combining data from multiple sheets into one 

summary sheet. 

Data Validation A feature that restricts the type of data entered 

into a cell. 

Digital Literacy The ability to use ICT tools effectively in daily life. 

Digital Tools Software and hardware used for performing digital 

tasks. 

Document Formatting Adjusting fonts, spacing, alignment, and colors to 

enhance document appearance. 

Driver A program that enables communication between 

hardware and the operating system. 

Electrostatic Discharge 

(ESD) 

The transfer of static electricity that can damage 

computer components. 

Event Viewer A tool that logs software errors and helps 

troubleshoot issues. 

File Management Organizing, storing, and retrieving digital files 

efficiently. 

Filtering Displaying only specific data that meets certain 

criteria. 
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Formula A mathematical equation used to calculate values 

in a spreadsheet. 

Function A predefined formula that performs calculations 

automatically (e.g., SUM, AVERAGE, COUNTIF). 

Hardware The physical components of a computer system. 

Hardware The physical components of a computer system. 

Headers and Footers Text, page numbers, or images placed at the top or 

bottom of a document page. 

Heat Sink A component that absorbs and disperses heat from 

the CPU. 

Hyperlinks Clickable links that direct users to web pages, other 

documents, or sections within the document. 

ICT  Information and Communication Technology is the 

use of technology to process, store, and 

communicate information. 

Indentation Adjusting the spacing of paragraphs to improve 

readability. 

Input Devices Devices that allow users to enter data into a 

computer (e.g., keyboard, mouse). 

Input Devices Tools used to enter data into a computer (e.g., 

keyboard, mouse). 

Installation The process of setting up software on a computer. 

Local Storage Saving files on physical devices like hard drives and 

USBs. 

Mail Merge A feature that allows users to create personalized 

letters, labels, or emails from a database. 

Malware Malicious software like viruses and spyware that 

harm computer systems. 

Multimedia Elements Images, videos, audio, and charts used to enrich 

presentations. 
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Networking Connecting computers to share resources and 

information. 

Operating System (OS) The software that manages hardware and 

applications (e.g., Windows, macOS, Linux). 

Output Devices Devices that display or present processed 

information (e.g., monitor, printer). 

Output Devices Devices that display or produce results from 

processed data (e.g., monitor, printer). 

Page Layout The arrangement of margins, columns, and page 

sizes for better presentation. 

Paragraph Alignment Arranging text in different styles such as left, right, 

center, and justified. 

Peripheral Devices External devices connected to a computer (e.g., 

speakers, scanners). 

Pivot Table A tool used to summarize and analyze large 

datasets quickly. 

Power Supply Unit (PSU) Converts electrical power into a usable form for the 

computer. 

Presentation Software Applications used to create and deliver slideshows 

(e.g., PowerPoint, Google Slides). 

Preventive Maintenance Routine cleaning and servicing to ensure optimal 

hardware performance. 

Processing Unit The component responsible for executing 

instructions (e.g., CPU, GPU). 

Professional Presentation A well-structured and visually appealing slideshow 

designed for formal settings like business and 

education. 

Ribbon Interface The toolbar at the top of Microsoft Word that 

provides access to different tools and features. 

Row A horizontal arrangement of cells in a spreadsheet. 
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Slide A single page within a digital presentation. 

Slide Layout The arrangement of text, images, and objects 

within a slide. 

Slideshow Mode The feature that allows users to view and navigate 

through presentation slides. 

Software A collection of programs that enable a computer to 

perform tasks. 

Software Programs and applications that run on a computer. 

Software Compatibility The ability of a program to function correctly on a 

specific operating system. 

Software Licensing Legal agreements that define how software can be 

used (e.g., free, proprietary, open-source). 

Software Update A new version of a program that includes bug fixes 

and performance improvements. 

Sorting Arranging data in a specific order (alphabetical, 

numerical, or date-based). 

Speaker Notes Notes added to slides to guide the presenter 

during a presentation. 

Spell Check and Grammar 

Check 

Features that detect and correct spelling and 

grammatical errors. 

Spreadsheet A digital tool used to organize, analyze, and 

manipulate data in tabular form. 

Storage Devices Components used to store data permanently or 

temporarily (e.g., HDD, SSD, USB drive). 

Storytelling in 

Presentations 

Structuring slides in a way that delivers a 

compelling narrative. 

Styles and Themes Predefined formatting settings that give a 

document a consistent look. 
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System Diagnostics Tools used to check hardware health and 

functionality (e.g., Task Manager, System 

Information). 

System Requirements The minimum hardware and software specifications 

needed for a program to run. 

System Restore A feature that allows users to revert a computer to 

a previous working state. 

Tables and Charts Elements used to organize and present data in a 

structured format. 

Task Manager A system tool that monitors running applications 

and system performance. 

Template A pre-designed slide layout used for structuring 

content. 

Track Changes A tool that enables multiple users to review and 

edit a document collaboratively. 

Transitions Effects applied when moving from one slide to 

another. 

Troubleshooting Diagnosing and fixing problems in ICT systems. 

Troubleshooting Identifying and fixing hardware problems. 

Utility Software Tools that help maintain and optimize computer 

performance (e.g., antivirus, disk cleanup). 

Virtual Machine A simulated computer system used for testing 

different operating systems. 

Word Processor A software application used for creating and 

editing text-based documents (e.g., Microsoft 

Word). 

Workbook A collection of multiple worksheets in a 

spreadsheet file. 

Worksheet A single spreadsheet within a workbook. 
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