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Microsoft Expression Web

About the Tutonal

Microsoft Expression Web is a full-featured professional tool for designing, developing, and
publishing feature-rich websites that conform to web standards. Expression Web uses its
own standard rendering engine, which is different from Internet Explorer's Trident engine.

In the following chapters of this tutorial, we will look closely at Microsoft Expression Web
and learn how it works.

Audience

This tutorial has been prepared for aspiring web designers to familiarize them with the
interface and features of Microsoft Expression Web.

After completing this tutorial, you will gain sufficient knowledge on Microsoft Expression
Web from where you can take yourself to the next level.

Prerequisites

It is quite a simple tutorial written in a very user-friendly manner. You can make the most
of it with a very basic knowledge of web designing and web development.

Disclaimer & Copyright

© Copyright 2018 by Tutorials Point (I) Pvt. Ltd.

All the content and graphics published in this e-book are the property of Tutorials Point (I)
Pvt. Ltd. The user of this e-book is prohibited to reuse, retain, copy, distribute or republish
any contents or a part of contents of this e-book in any manner without written consent
of the publisher.

We strive to update the contents of our website and tutorials as timely and as precisely as
possible, however, the contents may contain inaccuracies or errors. Tutorials Point (I) Pvt.
Ltd. provides no guarantee regarding the accuracy, timeliness or completeness of our
website or its contents including this tutorial. If you discover any errors on our website or
in this tutorial, please notify us at contact@tutorialspoint.com.
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1. Expression Web - Overview

Microsoft Expression Web is a full-featured professional tool for designing, developing, and
publishing feature-rich websites that conform to web standards. You can use Expression
Web to create web pages and sites that let you transfer files between your computer and
your hosting account.

Expression Web can design and develop web pages using HTML5, CSS 3, ASP.NET, PHP,
JavaScript, XML+XSLT and XHTML.

Expression Web 4 requires .NET Framework 4.0 and Silverlight 4.0 to install and run.

Microsoft Expression Web — History

Microsoft released the first Community Technology Preview (CTP) version of Expression
Web on May 14, 2006.

Microsoft Expression Web 4 was released on June 7, 2010.

e It added the option of HTML add-ins and access to a web-based functionality for
testing pages on browsers that cannot be installed on the user's system, such as
Mac OS X or Linux browsers.

e It also provides an SEO Checker using which you can analyze already created
websites against the best practices for getting the highest possible search engine
rankings.

Expression Web Service Packs

Expression Web 4 Service Pack 1 was released in March 2011 and added support for
IntelliSense for HTML5 and CSS.

Expression Web 4 Service Pack 2 was released in July 2011. It fixed a number of issues
and introduced new features such as

e jQuery IntelliSense support

e a panel for managing snippets

e Interactive Snapshot Panel

e comment/uncomment functionality in Code View, and

e workspace and toolbar customization.

In December 2012, Microsoft announced that Expression Studio will no longer be a stand-
alone product. Expression Blend is being integrated into Visual Studio, while Expression
Web and Expression Design will now be free products.

-
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Microsoft Expression Web

System Requirements

To create a website using Microsoft Expression Web, your computer should meet the
following requirements:

Actual

You should have at least Windows XP with Service Pack 3 or the latest operating
systems.

You should have a PC with 1 GHz or faster processor.

Your PC should have 1 GB of RAM or more.

Your PC should have 2 GB or more of available hard disk space.
You should have .NET Framework 4.0 and Silverlight 4.0.

Your PC should support Microsoft DirectX® 9.0 graphics.
You should have DVD compatible drive.

You should have 1024 x 768 or higher resolution monitor with 24-bit color.

Some product features require Firefox 3.0 or later, Internet Explorer 8. So you
should have the same version.

requirements and product functionality may vary based on your system

configuration and operating system.

@ tutorialspoint
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2. Expression Web - Environment Setup

Microsoft provides a free version of Microsoft Expression Web which can be downloaded
from https://www.microsoft.com/en-pk/download/details.aspx?id=36179.

Installation

Step 1: Before you can install Expression Web, you will need to have .NET Framework 4.0
installed.

Step 2: Once downloading is complete, run the installer. The following dialog will be
displayed.

License agreement

You must accept the terms of this agreement to continue. If you do not want
to accept the Microsoft Software License Terms, click Decline.

MICROSOFT SOFTWARE LICENSE TERMS

MICROSOFT EXPRESSION WEB 4 AND
EXPRESSION DESIGN 4

These license terms are an agreement between Microsoft Corporation
(or based on where you live, one of its affiliates) and you. Please
read them. They apply to the software named above, which includes
the media on which you received it, if any. The terms also apply to
any Microsoft

Accept Decline

Step 3: Click the Accept button.
Step 4: Select the Yes radio button and then click Next.

' tutorialspoint
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Microsoft Expression Web

- X

Join the Customer Experience Improvement
Program

Would you like to help improve Microsoft Expression Web 4 by joining the

Customer Experience Improvement Program to periodically send basic
performance and usage information to Microsoft?

Step 5: You can choose other location as well for installation. Select the location and click
the Install button.

- X
Installation
Choose the programs you want to install:
g Expression Web 4
: 4 Options
Location: |C\Program Files {x86)\Microsoft Expression | Browse

Required: 265.1 MB Available: 48.3 GB

tutorialspoint
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Microsoft Expression Web

The installation process starts.

Installation

Setup is installing the following programs:

" g4+l Expression Web 4

Once the installation is complete, you will see the following dialog.

Thank you

Setup has successfully installed Microsoft Expression Web 4.

| View release notes I

Step 6: Click Finish to continue.

tutorialspoint
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3. Expression Web — New Website

In the previous chapter, we have installed Microsoft Expression Web and now we are ready
to start working on it. In this chapter, we will learn how to create a new website from
scratch.

Create a Website

To create a new website, let’s open Microsoft Expression Web.

[ Microsoft Expression Web 4 - [m} >

File Edit View Insert Format Tools Table Site Data View Panels Window Help

A~-BEE-

Folder List . x Toolbox *  Snippets

Tag Properties *  CSS Properties ' x Apply Styles Manage... =

E

Selected style preview:

Next, you need to follow the steps given below.

-
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Microsoft Expression Web

Step 1: Select Site -> New Site... menu option.

[l Micrasoft Expression Web 4 — m] X

File Edit View Insert Format Tools Table Nl Data View Panels |

E-EHE- | Mew Site.., Ctrl+Shift+
B = Open Site... Ctrl+Shift+ 0

Folder List n x Recent Sites 1 Toolbox *  Snippets

Close

Publishing

Publishing Settings...

Publish Current File... Ctrl+Shift+ L
Publish Changed Files... Ctrl+5hift+H
Publish All Files... Ctrl+Shift+4

Delete...
Export to Web Package...

Import

Manage Sites List...
Site Settings...
|

Tag Properties *  CSS Properties Apply Styles | Manage...

Selected style preview:

Step 2: It will open the following dialog from which you can create or import different
types of website.

Mew ? bt
Site
i i Description
General 'tJ One Page Site : o )
¢=J Empty Site Create a new site with a single blank page.

Templates g Import Site Wizard

Options

Add to current site

Use Encrypted Connection (S5L)

Specify the name and location of the new site

Location: | C:\WUsers'Muhammad. Wagas\Documents My Web Sites\mysite e | Browse. ..

Add to Managed List MName: |mysite

-
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Microsoft Expression Web

Step 3: For simplicity let’s select General -> One Page Site.

Specify the location or you can browse to the location where you want the new
website to be created.

e Type in the name of your web in the name field and click OK.

[ cUsers\Muhammad. Wagas\Documents\My Web Sites\mysite - Microsoft Expression Web 4

File Edit View |Insert Format Tools Table Site DataView Panels Window Help

E-EpE- B . -

Folder List "% Site View e Sninpcts

Contents of 'C:\Users\Muhammad. Wagas\Documents\My Web Sites'mysite’
9 Name Title Size Type Modified Date

fat defaulthtml  default.himl KB html 7/21/2016 8:37AM Bl

l C: Wsers\Muhammad. Wagas\DocumentsiM

i default.html

o Apply Styles Manage... >

Tag Properties * 55 Properties "X "
;, Attach 5 eet...

(S5 styles:

Selected style preview:

Folders  Publishinc

-
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Microsoft Expression Web

Step 4: The new web will be created with one page named default.htm. Let’s rename it
to index.html with a right-click on the file and clicking on the Rename option.

m ChUsers\Muhammad.Wagas\Documents\My Web Sites\mysite - Microsoft Expression Web 4 - m} x

File Edit View Insert Format Tools Table Site Data View Panels Window Help
hK-EHpE-

Folder List * % | Site View e Snipcts

Contents of 'C:\Users\Muhammad. Wagas\Documents\My Web Sitegimysite’

Name Title Size  Type Modified Date

fa¥index.himl index. hirnl 1KE  html 7/21/2016 8:33 AM Bj
sers\Muhammad. Wagas\DocumentsiM

Tag Properties *  CSS Properties % x Apply Styles | Manage.. * % x

[optons - |

Selected style preview:

Folders  Publishing Reports  Hyperlinks

-
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Microsoft Expression Web

Step 5: The default doctype used in Expression Web is:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.0rg/TR/xhtmll/DTD/xhtmll-transitional.dtd">

<html xmlns="http://www.w3.0rg/1999/xhtml">

You can see it by just switching to the code view.

[ c\Users\Muhammad Wagas\Documentsihy Web Sites\mysite\index html - Microsoft Expression Web 4 - [m| X

File Edi Insert Format T Table Site Dataliew Panels v Help
A-EE-E o6 S T T

Folder List ® xS ¢ index.html = Toolbox * . Snippets
+ HTML

~ Tags

il < | DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.8 Transitional//EN" "http: "

l Wsers\Muhammad. Wagas\Documents M <heads

index. html ¢meta content="text/html; charset=utf-8" http-equiv="Content-Type" /> "
4 </head> &= Horizontal Line

P Image
<body> & Inline Frame
&l </body> W Layer

bl < /htmls 9 Paragraph

~ Form Controls
= Advanced Button

g Drop-Down Box

Tag Properties ? 5 ol Manage...

= Attributes
& xmins http: /fwww.w3.0...
i dir
& enableview...

5 visible Selected style preview:
25 xml:lang

= Events
= ondatabind...
<% ondisposed

Design  Split  Code

Line 13, Column 1 | Br B~ xHTMU10T 200bytes| B~ B~

10
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Microsoft Expression Web

You can change the doctype from Tools -> Page Editor Options -> Authoring.
Page Editor Options ? 4

General AutoThumbnail Ciefault Fonts Code Formatting C55
Color Coding Authoring Picture Ruler and Grid InteliSense Font Families

Mew Documents
Choose the default type of new documents and the default file extension of new HTML

documents.
Default Document: &dd a byte order mark (BOM) when
creating or renaming LTF-8 documents
— - with these file extensions
Default HTML File Extension: him Js
hitml html [ ].php
@ h 55 St
() .htm A.dwt [ xml

Doctype and Secondary Schema

Choose the doctype dedaration to be inserted into new pages. A matching document
schema will be used to drive incompatibility notifications and InteliSense for HTML and
script. If a page has no doctype or an unrecognized doctype is dedared, the
secondary Schema will be used.

Document Type Dedaration: Secondary Schema:
¥HTML 1.0 Transitional e Internet Explorer 8.0 w
C55 Schema

This schema determines what is available in C55 IntelliSense,
Schema version:
Cc55 2.1 AT

K Cancel

11
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Microsoft Expression Web

Step 6: Now, let's add <h1> tag inside the body tag and some text as shown in the
following code.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.0rg/TR/xhtmll/DTD/xhtmll-transitional.dtd">

<html xmlns="http://www.w3.0rg/1999/xhtml">
<head>

<meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
</head>
<body>

<h1>

This my first Web page

</h1>
</body>
</html>

Step 7: To see our web in a browser, let’s go to the File menu and select the Preview in
Browser -> Any browser, let’s say, Internet Explorer.

[ C\Users\Muhammad Wagas\Documents\My Web Sites\mysite2\index html - Micrasoft Expression Web 4 - O X

ZICW Edit View Inset Format Tools Table Site DataView Panels Help

e T 7o -@Bm -0
[ Open... Ctrl+0
Recent Files LB < SiteView  indexhtml x Toolbex ¥  Snippets
Lj'C\use F S ~ HTML
« Tags
el Save Ctrl+S 1 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.8 Transitional//EN" "http://wwni.u3.org/TR/xhtm =
Z «<html wmlns="http://www.w3.0rg/1999/xhtml">
[l Save As... 3
Save All 4 <head> = Breal
Save A , =
5 «meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
& </head> = Horizontal Line
Import L 7 P Image
§ <body> £ Inline Frame
5 Display in SuperPreview Shift+F12 9 <hl> This my first Web page </h1> 5 = e
PP ayer
Pr.eviewm Browser L gl'l Internet Explorer 11 F12 91 Paragraph
Print ¥ |€) 2 Internet Explorer 11 (1024 x 768)
Properties... &, 3 Firefox 45.2.0 = Frm@neb
\ I Advanced Button
. . %, 4 Firefox 45.2.0 (1024 x 768) .
Source Control » 3 B Drop-Down Box
£ 5 Chrome Form
&3, 6 Chrome (1024 x 768)

ly Styles Manage Styles =

Preview in Multiple Browsers
Preview in Multiple Browsers (1024 x 768)

Edit Browser List...

This my first Web page|

i align
i dass

o dir

i enableview...
i id

i lang

i runat

i style Selected style preview:
o title

i visble
5 xmlilang
= Events
_Z_onrick

Design  Split  Code

Line 9, Column 32 \l,- B v XHTML10T 324bytes| B~ B~ css21 667x224~

12
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Microsoft Expression Web

It will open our web in Internet Explorer.

a C\Users\Muhammad.Wagas\Documentsi\My Web O ~ & || @& C\Users\Muhammad.Wag...

This my first Web page

#125% -

13

-
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4. Expression Web - Blank Web Page

As we have already created our website, now we will need to create our Home Page. In
the previous chapter, we have created a one-page website, and our Home Page was
created at that time automatically by Expression Web. So, if you have created a blank
website, then you will need to create a Home Page for your site.

Microsoft Expression Web can create the following types of pages:

HTML

ASPX

ASP

PHP

CSsSs

Master Page

Dynamic Web Template
JavaScript

XML

Text File

In this chapter, we will create an HTML page and its corresponding style sheet.

Create a Blank Page
To create a blank page, you can simply go to File menu and select New -> Page... menu
option.
Mew ? et
Page
|#] HTML || Description
General — ‘
|_=-| ASPEY Create a blank HTML web page.
ASP.NET 8] Asp
18 pHP
£S5 Layouts A Css
E Master Page Preview
Style Sheets [ ] Dynamic Web Template
%] Javascript
Frames Pages |2 wmL
=] TextFile

__',_"] Create from Dynamic Web Template...
E} Create from Master Page. ..

QOptions
Page Editor Options...

Cancel

14
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Microsoft Expression Web

From the new dialog, you can create different types of blank pages such as HTML page,
ASPX page, CSS page, etc. and click OK.

E Untitled 1 (Untitled_T1.html) - Microsoft Expression Web 4 - O *

File Edit View |nsert Format Table Site DataView Panels Window Help

RSB - [ CEET T

Folder List ® % SikeView  indexhtml Untitled_1.html = Toolbox *  Snippets
+ HTML

i < !DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.8 Transitional//EN" “http:
P <html xmlns="http://www.w3.org/1999/xhtml">
ers\Muhammad. Wagas\Documents\M <heads>
dex. html ] <meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
J<titlesUntitled l¢/title> 3 Horizontal Line
</head> F Image
£ Inline Frame
- Layer
1 </body> 9] Paragraph

=l <body >

= Form Controls
= Advanced Button

& Drop-Down Box

Tag Properties S5 Properties nox Apply Styles Manage... *

Selected style preview:

Design  Split ~ Code

\ B~ B~ xumior

As you can see here, the default code is already added by Microsoft Expression Web.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.0rg/TR/xhtmll/DTD/xhtmll-transitional.dtd">

<html xmlns="http://www.w3.0rg/1999/xhtml">

<head>

<meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
<title>Untitled 1</title>

</head>

<body>
<h1l>
This is a blank web page
</h1>
</body>
</html>

15
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Microsoft Expression Web

As you can see, your newly created page has the file name Untitled_1.html or
Untitled_1.htm. You will need to save the page by pressing Ctrl + S and specify the
name.

As our website already contains an index.html page, we dont need another one.
However, if you have created an Empty website, then name this page index.html.

To see your web in a browser, let’s go to the File menu and select the Preview in Browser
-> Any browser, let's say Internet Explorer.

£ | Ch\Users\Muhammad.Wagas\Documents\My Web Sites\mysite2\ir Jo R ¢ 2 C\Users\Muhammad.Wag...

This is a blank web page

H1B5% -

16
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Create a CSS Page

Microsoft Expression Web

Let’s take you through the step-by-step process of creating a CSS page.

Step 1: To create a CSS page, go to the File menu and select New -> Page... menu

option.
Mew
Page

General § HTML
=] AsPx

ASP.NET 8] asp
T prp

55 Layouts Alicss
j Master Page

Style Sheets j Dynamic Web Template

Frames Pages

%] JavaScript

=] XML

=] TextFile

_-'_’] Create from Dynamic Web Template...

_=_1| Create from Master Page. ..

-
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Description
Create a blank Cascading Style Sheet,

Prewview

Options
Page Editor Options...

Cancel
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Microsoft Expression Web

Step 2: Select General -> CSS and click OK.

E Untitled_1.css - Microsoft Expression Web 4
File Edit View Insert Format Tools Table Site DataView Panels Window

R-EE-0F

Folder List v # SiteView  index.html Untitled_1.css =

1

Wagas\DocumentsM

ISe a

Tag Properties *  CS5 Properties R x

Help

Toolbox * Snippets

Apply Styles ~ Manage.

Selected style preview:

Step 3: Save the page and type a name for the style-sheet.

E Save As

P W)« Muhammad Wagas » Documents » My Web Sites »  mysite v | 0 Search miysite 2

Organize = New folder

”
E Microsoft Expressi Marme

_ 27 index.html
@ OneDrive

[ This PC
[ Desktop
@ Documents
; Downloads
J‘! Music
&=/ Pictures
B videos

am Windows ()

Date modified Type Size

7/21/2016 8:38 AM HTML Document 1KB

File narme: | S0 0=

e

Save as type: | Web Pages (" htm;* html;*.shtml;* shtm;™.stm; ™. asp; ™. asp™ master™. dwt™ hitt;" hta;".htc™ jsp; ™ of ;™ phtml ™. php: . php2™.pk ~

Page title:

Change title...

» Hide Folders

) ' tutorialspoint
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Step 4: Click the Save button.

[ C\Users\Muhammad.Wagas\Documents\My Web Sites\mysite\sample.css - Microsoft Expression Web 4

File 5 Format

il sample.css =

roperties

Step 5: Now, let’s go to the index.html page.

[ coUsers\Muhammad. Wagas\Documents\My Web Sites\mysitelindexhtml - Microsoft Expression Web 4

File Edit ; Insert Format Table Site DataView Panel ndow Help
5 - S T ) -

index.html =

KE-BEE-"

Folder List sample.css

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.8 Transitio
<html wxmlns="http://www.w3.org/1999/xhtml ">

<head>

<meta content="text/html; charset=utf-8" http-equis
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Step 6: In the Manage Styles Panel, click Attach Style Sheet.

Attach Style Sheet

"

=

LIRL: |5-3|TIF'|E-'255 . Browse,..

Attach to: () All HTML pages Attach as: (®)Link
Selected page(s) () Import
I:EI Current page

QK Cancel

Step 7: Browse to your style-sheet and select the Current page from “Attach to” and Link
from “Attach as” and click OK.

E ChUsers\Muhammad.Wagas\Documentsi\My Web Sites\mysite\indexchtml - Microsoft Expression Web 4 - O x

File Edit View Insert Format Table Site DataView Pan Help
A-EE-E RS- (S T T 0 - - 086

Folder List " % SiteView  indexhtml* x  sample.css Toolbox *  Snippets

" sample.css
% B} <! DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.@ Transitionals/EN" “http://wy

l <html xmlns="http://www.w3.org/1999/xhtml">
: == Horizontal Line
.Wagas\Documents\M £ Tnine Frame
e Frame
] <meta content="text/html; charset=utf-8" http-equiv="Content-Type" />

[ <style type="text/css"> e 91 Paragraph
il < /styler
] <1link href="sample.css" rel="styleshest" type="text/css" /> ~ Form Controls
i </head> ™ Advanced Bu... | g Drop-Down Box
Form Group Box
3 nput (Button) Input (Check. ..
-@ Input (File) Input (Hidden)
¥ Input (Image) Input
% Tnnot Madind - et Tnnor

CSS Properties | I Apply Styles ~ Manage Styles %

= Attributes S5 styles:
=& href sample.css

#5 rel stylesheet
i type textfcss
! charset

8 dass

#5 dir

& enableview. ..
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sample.css

Selected style preview:

“d media Design  Split = Code
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Step 8: Now, you will see that a new line is added automatically in the index.html page.

<link href="sample.css" rel="stylesheet" type="text/css" />
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Step 9: The body element defines the document's body. To style the <body> tag, we
need to create a new style. First, select the body tag in Design View and then click on the
New Style... in Apply Styles panel or Manage Styles panel, which will open the New Style
dialog.

MNew Style ? x
Selector: | body ~ | ] apply new style to document selection

Define in: | Existing style sheet ~ | URL: | sample.css “ Browse. ..
Category:

Block font-family: | Segoe LI, Tahoma, Geneva, Verdana, sans-serif |

o
Background font-size: = [ px text-decoration:
Border Radius m ]
overline
it [Jline-through

Layout ' [ blirk

List text-transform: [Jnone

Table :

color: | EXR w -
Preview:
AaBbYyGgLlj
Description: font-family: “Segoe UL, Tahoma, Geneva, Verdana, sans-serif; font-size: large; color: #0000FF

Cancel Apply

Here, you can define the different options for your style. The first step is to select the body
from the Selector dropdown list and then select the Existing style sheet from “Define in”
dropdown list.
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Step 10: From the URL, select the sample.css file. On the left side, there is a Category
list like font, background, etc. and currently the Font is highlighted. Set the Font related
information as per your requirements as shown in the above screenshot and click Ok.

E Ch\Users\Muhammad,Waqas\Documents\My Web Sites\mysiteZ\index.html - Microsoft Expression Web 4 — [m] *
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sl 1 <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.8 Transitional//EN" “http://www.w3.org/TR/xhtm:

: 2 <html xmlns="http://www.w3.0org/1999/xhtml">
3
4 <head>

o 5 «<meta content="text/html; charset=utf-3" http-eguiv="Content-Type" />
sample. css 6 <link href="sample.css" rel="stylesheet" type="text/css" />

7 </head>
8
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11 </body>
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13 </html>
14
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> [l -1

bo

=]
= Attributes ~
alink e 1
zy L This is a blank web page = sample.css
&t backg (@body
47 bgcolor [} ‘ =
57 dlass
A dir
57 enableview..
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i lang
g link (]
[t runat
5 style
o text 1
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Step 11: Now you can see in the design view that the background color and the font has
changed to what we have selected. Now, if you open the sample.css file, you will see that
all the information is automatically stored in the CSS file.

[ CAUsers\Muhammad.Wagqas\Dacuments\My Web Sites\mysite2\sample.css - Microsoft Expression Web 4 - ] X

File Edit View Inset Format T Table Site DataView Panels

A~-EE-"

Folder List & % SiteView indexhtml sample.css = Toolbox *  Snippets

% sample.css

sersMuhammad. Wagas\Document:

body {
font-family: “"Segoe UI", Tahoma, Geneva, Verdana, sans-serif;
font-size: large;
color: #BBOBFF;

@ Wk e
e

Tag Properties *  CSS Properties Ex L Styles ~ Manage Styles *

=] sample.css
(@) body

| l/' E:::-' | %'

22

-

|§j’ tutorialspoint

EIMPLYEAEYLEARNINEG



Microsoft Expression Web

Let's preview our web page in a browser. You will observe that the style is applied from
the CSS file.

a Ch\Users\Muhammad. Wagas\Documents'\My Web Sites\mysite2\ir LD~-c i%\ C\Users\Muhammad.Wagq...

This is a blank web page

H125% v
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End of ebook preview
If you liked what you saw...

Buy it from our store @ https://store.tutorialspoint.com
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